aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-raspell/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:40:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:40:10 +0000
commit1cc520232fd05c2a43b076aa65d939a284617992 (patch)
tree2135d316fdd46272ad7b3d38f17b37e7df593113 /textproc/ruby-raspell/Makefile
parentf66b7b2e41e7850d743ddf94aa096847ca7b2f13 (diff)
downloadports-1cc520232fd05c2a43b076aa65d939a284617992.tar.gz
ports-1cc520232fd05c2a43b076aa65d939a284617992.zip
Add ruby-raspell, a Ruby interface binding to aspell.
Notes
Notes: svn path=/head/; revision=69816
Diffstat (limited to 'textproc/ruby-raspell/Makefile')
-rw-r--r--textproc/ruby-raspell/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/ruby-raspell/Makefile b/textproc/ruby-raspell/Makefile
new file mode 100644
index 000000000000..aa2c83e3ac9c
--- /dev/null
+++ b/textproc/ruby-raspell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rAspell
+# Date created: 10 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= raspell
+PORTVERSION= 0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.rb ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>