aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xmlparser
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-04-27 13:18:07 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-04-27 13:18:07 +0000
commitf6c29a10925556f207432973723811baa2096782 (patch)
tree9a151514dd336f85ac08f3e72321697512a63763 /textproc/ruby-xmlparser
parent57e4f10e06f014452cb30a0395e71be4c74d3ff7 (diff)
downloadports-f6c29a10925556f207432973723811baa2096782.tar.gz
ports-f6c29a10925556f207432973723811baa2096782.zip
Update to 0.6.2.
Explicitly specify a perl-enc-map directory. PR: ports/37302 Submitted by: Fuyuhiko Maruyama <fuyuhik8@is.titech.ac.jp>
Notes
Notes: svn path=/head/; revision=58225
Diffstat (limited to 'textproc/ruby-xmlparser')
-rw-r--r--textproc/ruby-xmlparser/Makefile49
-rw-r--r--textproc/ruby-xmlparser/distinfo2
-rw-r--r--textproc/ruby-xmlparser/files/patch-aa12
-rw-r--r--textproc/ruby-xmlparser/pkg-plist108
4 files changed, 90 insertions, 81 deletions
diff --git a/textproc/ruby-xmlparser/Makefile b/textproc/ruby-xmlparser/Makefile
index dd473b8bc313..56dc13fb96b0 100644
--- a/textproc/ruby-xmlparser/Makefile
+++ b/textproc/ruby-xmlparser/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmlparser
-PORTVERSION= 0.6.1
-PORTREVISION= 3
+PORTVERSION= 0.6.2
CATEGORIES= textproc ruby
MASTER_SITES= http://www.yoshidam.net/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -23,56 +22,26 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv \
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
PERL_ARCHLIB= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_ARGS= --with-perl-enc-map
+CONFIGURE_ARGS= --with-perl-enc-map=${PERL_ARCHLIB}/XML/Parser/Encodings
INSTALL_TARGET= site-install
-EXAMPLES_EN= dtd/ext1.dtd dtd/ext2.dtd dtd/extdtd.rb dtd/extdtd.xml \
- namespaces/namespace1.rb namespaces/namespace1.xml \
- namespaces/namespace2.rb namespaces/namespace2.xml \
- digesttest.rb doctype.rb doctype.xml doctypei.rb \
- idattrtest.rb my-html.rb saxtest.rb \
- visitortest.rb writer.rb xmlcomments.rb xmlstats.rb
-EXAMPLES_JA= buildertest.rb buildertest2.rb digesttest2.rb document.dtd \
- gtktree.rb index_euc.xml index_jis.xml index_noenc.xml \
- index_sjis.xml index_u16.xml index_u8.xml treetest.rb \
- videolist.dtd videolist.rb videolist.xml visitor.rb \
- xmlcheck.rb xmlevent.rb xmlgrep.rb xmliter.rb \
- xpointer.rb xpointertest.rb
-RD_DOCS= xmltree.rb xmltreebuilder.rb xmltreevisitor.rb
+post-extract:
+ ${RM} -r ${WRKSRC}/samples/expat-1.2
post-patch:
${RUBY} -i -pe 'gsub /%%PREFIX%%/, "${PREFIX}"' ${WRKSRC}/lib/wget.rb
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_EXAMPLESDIR}/xmlparser/dtd
- ${MKDIR} ${RUBY_EXAMPLESDIR}/xmlparser/namespaces
- ${MKDIR} ${RUBY_EXAMPLESDIR}/xmlparser/ja
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/samples/${f} \
- ${RUBY_EXAMPLESDIR}/xmlparser/${f}
-.endfor
-.for f in ${EXAMPLES_JA}
- ${INSTALL_DATA} ${WRKSRC}/samples/${f} \
- ${RUBY_EXAMPLESDIR}/xmlparser/ja/${f}
-.endfor
-.for f in ${RD_DOCS}
- @cd ${WRKSRC}/lib; \
- ${RUBY_RD} ${f} > ${f:S/.rb$/.html/}
-.endfor
- ${MKDIR} ${RUBY_DOCDIR}/xmlparser/ja
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/xmlparser/
- ${INSTALL_DATA} ${WRKSRC}/README.ja ${RUBY_DOCDIR}/xmlparser/ja/
-.for f in ${RD_DOCS:S/.rb$/.html/}
- ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${RUBY_DOCDIR}/xmlparser/
-.endfor
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/README.ja ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
.include <bsd.port.mk>
diff --git a/textproc/ruby-xmlparser/distinfo b/textproc/ruby-xmlparser/distinfo
index 6c2056718592..f0eb394f12f5 100644
--- a/textproc/ruby-xmlparser/distinfo
+++ b/textproc/ruby-xmlparser/distinfo
@@ -1 +1 @@
-MD5 (ruby/xmlparser-0.6.1.tar.gz) = 2496698f6ea32365af4fc284e3345948
+MD5 (ruby/xmlparser-0.6.2.tar.gz) = 16782db3080993f02ac03efcca78028d
diff --git a/textproc/ruby-xmlparser/files/patch-aa b/textproc/ruby-xmlparser/files/patch-aa
index 8ce291d1c44b..e5211bf30f63 100644
--- a/textproc/ruby-xmlparser/files/patch-aa
+++ b/textproc/ruby-xmlparser/files/patch-aa
@@ -1,13 +1,13 @@
---- extconf.rb.orig Sun Oct 15 15:22:39 2000
-+++ extconf.rb Mon Oct 16 05:40:33 2000
-@@ -22,8 +22,8 @@
+--- extconf.rb.orig Wed Jun 20 12:35:18 2001
++++ extconf.rb Sat Apr 27 22:11:57 2002
+@@ -23,8 +23,8 @@
##$CFLAGS="-I#{cwd}/expat/xmlparse -I#{cwd}/expat/xmltok" +
## ' -DXML_ENC_PATH=getenv\(\"XML_ENC_PATH\"\)' +
## " -DNEW_EXPAT"
-$CFLAGS = "-I#{cwd}/expat/xmlparse -I#{cwd}/expat/xmltok"
--$LDFLAGS = "-L#{cwd}/expat/xmlparse"
+-$LDFLAGS = "-L#{cwd}/expat/xmlparse -Wl,-rpath,/usr/local/lib"
+#$CFLAGS = "-I#{cwd}/expat/xmlparse -I#{cwd}/expat/xmltok"
-+#$LDFLAGS = "-L#{cwd}/expat/xmlparse"
++#$LDFLAGS = "-L#{cwd}/expat/xmlparse -Wl,-rpath,/usr/local/lib"
+ #$LDFLAGS = "-L#{cwd}/expat/xmlparse"
dir_config("xmltok")
dir_config("xmlparse")
- if xml_enc_path
diff --git a/textproc/ruby-xmlparser/pkg-plist b/textproc/ruby-xmlparser/pkg-plist
index 41700590d235..baf48ed1ab59 100644
--- a/textproc/ruby-xmlparser/pkg-plist
+++ b/textproc/ruby-xmlparser/pkg-plist
@@ -1,63 +1,103 @@
+%%RUBY_SITEARCHLIBDIR%%/xmlparser.so
%%RUBY_SITELIBDIR%%/sax.rb
%%RUBY_SITELIBDIR%%/saxdriver.rb
%%RUBY_SITELIBDIR%%/wget.rb
+%%RUBY_SITELIBDIR%%/xml/dom/builder-ja.rb
+%%RUBY_SITELIBDIR%%/xml/dom/builder.rb
+%%RUBY_SITELIBDIR%%/xml/dom/core.rb
+%%RUBY_SITELIBDIR%%/xml/dom/digest.rb
+%%RUBY_SITELIBDIR%%/xml/dom/visitor.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/attr.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/cdatasection.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/characterdata.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/comment.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/core.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/document.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/documentfragment.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/documenttype.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/dombuilder.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/dombuilderfilter.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/domentityresolver.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/domentityresolverimpl.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/domexception.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/domimplementation.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/dominputsource.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/element.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/entity.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/entityreference.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/namednodemap.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/node.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/nodelist.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/notation.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/processinginstruction.rb
+%%RUBY_SITELIBDIR%%/xml/dom2/text.rb
+%%RUBY_SITELIBDIR%%/xml/encoding-ja.rb
+%%RUBY_SITELIBDIR%%/xml/parser.rb
+%%RUBY_SITELIBDIR%%/xml/parserns.rb
+%%RUBY_SITELIBDIR%%/xml/sax.rb
+%%RUBY_SITELIBDIR%%/xml/saxdriver.rb
%%RUBY_SITELIBDIR%%/xmldigest.rb
%%RUBY_SITELIBDIR%%/xmlencoding-ja.rb
-%%RUBY_SITELIBDIR%%/xmlparser.rb
%%RUBY_SITELIBDIR%%/xmltree.rb
%%RUBY_SITELIBDIR%%/xmltreebuilder-ja.rb
%%RUBY_SITELIBDIR%%/xmltreebuilder.rb
%%RUBY_SITELIBDIR%%/xmltreevisitor.rb
-%%RUBY_SITEARCHLIBDIR%%/xmlparser.so
+@dirrm %%RUBY_SITELIBDIR%%/xml/dom2
+@dirrm %%RUBY_SITELIBDIR%%/xml/dom
+@dirrm %%RUBY_SITELIBDIR%%/xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/buildertest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/buildertest2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/digesttest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/digesttest2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctype.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctype.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctypei.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/document.dtd
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/dom2test1.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/dom2test2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/test.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/test1.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/test2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dom2/test2.xml
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dtd/ext1.dtd
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dtd/ext2.dtd
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dtd/extdtd.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/dtd/extdtd.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/gtktree.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/idattrtest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_euc.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_jis.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_noenc.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_sjis.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_u16.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/index_u8.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/my-html.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/namespaces/namespace1.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/namespaces/namespace1.xml
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/namespaces/namespace2.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/namespaces/namespace2.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/buildertest.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/buildertest2.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/digesttest2.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/document.dtd
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/gtktree.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_euc.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_jis.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_noenc.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_sjis.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_u16.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/index_u8.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/treetest.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/videolist.dtd
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/videolist.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/videolist.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/visitor.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xmlcheck.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xmlevent.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xmlgrep.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xmliter.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xpointer.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/ja/xpointertest.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/digesttest.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctype.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctype.xml
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/doctypei.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/idattrtest.rb
-%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/my-html.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/nstest.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/saxtest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/treetest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/videolist.dtd
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/videolist.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/videolist.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/visitor.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/visitortest.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/writer.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmlcheck.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmlcomments.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmlevent.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmlgrep.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmliter.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xmlstats.rb
-%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/xmlparser/ja
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xpointer.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/xmlparser/xpointertest.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/xmlparser/namespaces
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/xmlparser/dtd
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/xmlparser/dom2
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/xmlparser
%%PORTDOCS%%%%RUBY_DOCDIR%%/xmlparser/ja/README.ja
%%PORTDOCS%%%%RUBY_DOCDIR%%/xmlparser/README
-%%PORTDOCS%%%%RUBY_DOCDIR%%/xmlparser/xmltree.html
-%%PORTDOCS%%%%RUBY_DOCDIR%%/xmlparser/xmltreebuilder.html
-%%PORTDOCS%%%%RUBY_DOCDIR%%/xmlparser/xmltreevisitor.html
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/xmlparser/ja
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/xmlparser