aboutsummaryrefslogtreecommitdiff
path: root/textproc/saxon-devel
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-12-21 15:43:14 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-12-21 15:43:14 +0000
commitb3a368ebff121e4df6033789c27318332e825ea0 (patch)
tree243a8911da043ac273bfbf22e8990d49fb32a9f6 /textproc/saxon-devel
parent6db2d48a43497f4fcda2b1f59e748d23c23dce33 (diff)
downloadports-b3a368ebff121e4df6033789c27318332e825ea0.tar.gz
ports-b3a368ebff121e4df6033789c27318332e825ea0.zip
- Update to version 8.2
- Use SUB_FILES/SUB_LIST for launcher shell script
Notes
Notes: svn path=/head/; revision=124708
Diffstat (limited to 'textproc/saxon-devel')
-rw-r--r--textproc/saxon-devel/Makefile12
-rw-r--r--textproc/saxon-devel/distinfo4
-rw-r--r--textproc/saxon-devel/files/saxon.sh.in (renamed from textproc/saxon-devel/files/saxon.sh)4
3 files changed, 9 insertions, 11 deletions
diff --git a/textproc/saxon-devel/Makefile b/textproc/saxon-devel/Makefile
index 6035ba940385..a15946d3c77b 100644
--- a/textproc/saxon-devel/Makefile
+++ b/textproc/saxon-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= saxon
-PORTVERSION= 8.1.1
+PORTVERSION= 8.2
CATEGORIES= textproc java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= saxon
@@ -29,13 +29,11 @@ CONFLICTS= saxon-6.*
JARFILES= saxon8-sql.jar saxon8-jdom.jar saxon8.jar
PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,} bin/saxon bin/saxon-xquery
.if !defined(NOPORTDOCS)
-PORTDOCS= background documentation img javadoc
+PORTDOCS= background documentation img
.endif
-do-configure:
- @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%SAXON_JARS%%|${JARFILES:S,^,${JAVAJARDIR}/,}|' \
- ${FILESDIR}/saxon.sh >${WRKSRC}/saxon
+SUB_FILES= saxon.sh
+SUB_LIST= SAXON_JARS="${JARFILES:S,^,${JAVAJARDIR}/,}"
do-install:
@${ECHO_MSG} -n ">> Installing JARs in ${JAVAJARDIR}/..."
@@ -60,7 +58,7 @@ do-install:
@${ECHO_MSG} -n ">> Installing scripts in ${PREFIX}/bin..."
.for file in saxon saxon-xquery
@${ECHO_MSG} -n " ${file}"
- @${INSTALL_SCRIPT} ${WRKSRC}/saxon ${PREFIX}/bin/${file}
+ @${INSTALL_SCRIPT} ${WRKSRC}/saxon.sh ${PREFIX}/bin/${file}
.endfor
@${ECHO_MSG} " [ DONE ]"
diff --git a/textproc/saxon-devel/distinfo b/textproc/saxon-devel/distinfo
index 68852ab74fb6..801acdfab0a0 100644
--- a/textproc/saxon-devel/distinfo
+++ b/textproc/saxon-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (saxonb8-1-1.zip) = c4463c7a437533188c06bb558aa4f1a5
-SIZE (saxonb8-1-1.zip) = 6155706
+MD5 (saxonb8-2.zip) = 81e74679a641ecaa6523b15c20969a56
+SIZE (saxonb8-2.zip) = 6821610
diff --git a/textproc/saxon-devel/files/saxon.sh b/textproc/saxon-devel/files/saxon.sh.in
index a220ea908e91..5732faa6a5b2 100644
--- a/textproc/saxon-devel/files/saxon.sh
+++ b/textproc/saxon-devel/files/saxon.sh.in
@@ -1,8 +1,8 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-devel/files/Attic/saxon.sh,v 1.5 2004-11-22 16:49:34 hq Exp $
+# $FreeBSD$
-IAM=`basename "$0"`
+IAM="`basename "$0"`"
if [ "${IAM}" = "saxon-xquery" ]
then