aboutsummaryrefslogtreecommitdiff
path: root/textproc/sigil
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-03-16 11:23:49 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-03-16 11:23:49 +0000
commitdf905ebbeac7ac36f2242de129cadddf13af846a (patch)
tree5cdb69b558c0be56329a1ebd6399cbccabf8959b /textproc/sigil
parentbc612340430d4ec1227e1f5339f58c699599e6b4 (diff)
downloadports-df905ebbeac7ac36f2242de129cadddf13af846a.tar.gz
ports-df905ebbeac7ac36f2242de129cadddf13af846a.zip
Update to 0.5.3
PR: ports/165510 Submitted by: Jonathan Chen <jonc@chen.org.nz> (maintainer) Approved by: glarkin@ (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293408
Diffstat (limited to 'textproc/sigil')
-rw-r--r--textproc/sigil/Makefile20
-rw-r--r--textproc/sigil/distinfo4
-rw-r--r--textproc/sigil/files/patch-CMakeLists14
-rw-r--r--textproc/sigil/pkg-plist36
4 files changed, 63 insertions, 11 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 5687707ff64a..383b0784d463 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sigil
-PORTVERSION= 0.2.4
-PORTREVISION= 1
+PORTVERSION= 0.5.3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= Sigil-${PORTVERSION}-Code
@@ -15,22 +14,27 @@ DISTNAME= Sigil-${PORTVERSION}-Code
MAINTAINER= jonc@chen.org.nz
COMMENT= WYSIWYG ePub editor
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
+ hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
+ pcre.1:${PORTSDIR}/devel/pcre
+
USE_ZIP= yes
USE_CMAKE= yes
-USE_DOS2UNIX= DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
+USE_DOS2UNIX= CMakeLists.txt DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
USE_QT_VER= 4
-QT_COMPONENTS= qmake gui svg webkit xml moc uic rcc imageformats
+NO_WRKSUBDIR= yes
+QT_COMPONENTS= qmake gui svg webkit xml moc uic rcc imageformats linguist
DESKTOP_ENTRIES="Sigil Editor" \
"${COMMENT}" \
- "${DATADIR}/sigil.png" \
+ "${PREFIX}/share/pixmaps/sigil.png" \
"sigil" \
"Application;" \
${FALSE}
-post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/src/Sigil/Resource_Files/icon/app_icon_48.png ${DATADIR}/sigil.png
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.pre.mk>
diff --git a/textproc/sigil/distinfo b/textproc/sigil/distinfo
index bcbf1e50defa..7fe1fceb03ce 100644
--- a/textproc/sigil/distinfo
+++ b/textproc/sigil/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Sigil-0.2.4-Code.zip) = 001a535986c90f67bdfa0860964a2c70a0b1c23091cf86ea7f618e02fbc776c3
-SIZE (Sigil-0.2.4-Code.zip) = 9299387
+SHA256 (Sigil-0.5.3-Code.zip) = 9525ac3885e7d3962a85e491b271fd857e8a9430e92868e1772c3bcaeb9bc778
+SIZE (Sigil-0.5.3-Code.zip) = 12843490
diff --git a/textproc/sigil/files/patch-CMakeLists b/textproc/sigil/files/patch-CMakeLists
new file mode 100644
index 000000000000..7f530ec130c0
--- /dev/null
+++ b/textproc/sigil/files/patch-CMakeLists
@@ -0,0 +1,14 @@
+diff -ruN /tmp/Sigil-0.5.3-Code/src/CMakeLists.txt ./src/CMakeLists.txt
+*** ./CMakeLists.txt.orig 2012-02-28 10:17:24.000000000 +1300
+--- ./CMakeLists.txt 2012-02-28 10:17:51.000000000 +1300
+***************
+*** 22,27 ****
+--- 22,29 ----
+ set( SIGIL_REVISION_VERSION 3 )
+ set( SIGIL_FULL_VERSION ${SIGIL_MAJOR_VERSION}.${SIGIL_MINOR_VERSION}.${SIGIL_REVISION_VERSION} )
+
++ link_directories (%%LOCALBASE%%/lib)
++
+ # Check if platform is 64 bit
+ if( NOT APPLE )
+ if( CMAKE_SIZEOF_VOID_P EQUAL 4 )
diff --git a/textproc/sigil/pkg-plist b/textproc/sigil/pkg-plist
index 0ceb50e21f19..9c8722e0c6a4 100644
--- a/textproc/sigil/pkg-plist
+++ b/textproc/sigil/pkg-plist
@@ -1,3 +1,37 @@
bin/sigil
-share/sigil/sigil.png
+share/pixmaps/sigil.png
+share/sigil/dictionaries/About.txt
+share/sigil/dictionaries/de_DE.aff
+share/sigil/dictionaries/de_DE.dic
+share/sigil/dictionaries/en_GB.aff
+share/sigil/dictionaries/en_GB.dic
+share/sigil/dictionaries/en_US.aff
+share/sigil/dictionaries/en_US.dic
+share/sigil/dictionaries/es.aff
+share/sigil/dictionaries/es.dic
+share/sigil/dictionaries/fr.aff
+share/sigil/dictionaries/fr.dic
+share/sigil/dictionaries/hyph_de_DE.dic
+share/sigil/dictionaries/hyph_en_GB.dic
+share/sigil/dictionaries/hyph_en_US.dic
+share/sigil/dictionaries/hyph_es.dic
+share/sigil/dictionaries/hyph_fr.dic
+share/sigil/translations/sigil_cs.qm
+share/sigil/translations/sigil_da_DK.qm
+share/sigil/translations/sigil_de.qm
+share/sigil/translations/sigil_en.qm
+share/sigil/translations/sigil_es_ES.qm
+share/sigil/translations/sigil_fr.qm
+share/sigil/translations/sigil_it.qm
+share/sigil/translations/sigil_ja.qm
+share/sigil/translations/sigil_nl.qm
+share/sigil/translations/sigil_pl.qm
+share/sigil/translations/sigil_pt_BR.qm
+share/sigil/translations/sigil_ru.qm
+share/sigil/translations/sigil_sk.qm
+share/sigil/translations/sigil_tr_TR.qm
+share/sigil/translations/sigil_zh_CN.qm
+share/sigil/translations/sigil_zh_TW.qm
+@dirrm share/sigil/translations
+@dirrm share/sigil/dictionaries
@dirrm share/sigil