aboutsummaryrefslogtreecommitdiff
path: root/textproc/skim
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-28 21:34:56 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-28 21:34:56 +0000
commit4bb553fa46939aa0b92139af1473510681a66b76 (patch)
tree6ac0d7370b17702476e1c1f836e79cedc2a497bc /textproc/skim
parentb7ad3af71f39875855d8b4db529701ab8726eb06 (diff)
downloadports-4bb553fa46939aa0b92139af1473510681a66b76.tar.gz
ports-4bb553fa46939aa0b92139af1473510681a66b76.zip
Add skim 0.9.3, an input method platform based on SCIM library and
KDE/QT. PR: ports/69401 Submitted by: Jie Gao <gaoj@cpsc.ucalgary.ca>
Notes
Notes: svn path=/head/; revision=114969
Diffstat (limited to 'textproc/skim')
-rw-r--r--textproc/skim/Makefile35
-rw-r--r--textproc/skim/distinfo2
-rw-r--r--textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp23
-rw-r--r--textproc/skim/pkg-descr6
-rw-r--r--textproc/skim/pkg-message22
-rw-r--r--textproc/skim/pkg-plist88
6 files changed, 176 insertions, 0 deletions
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
new file mode 100644
index 000000000000..e82763b3aef6
--- /dev/null
+++ b/textproc/skim/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: skim
+# Date created: 21 July 2004
+# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skim
+PORTVERSION= 0.9.3
+CATEGORIES= textproc kde
+MASTER_SITES= http://freedesktop.org/~cougar/skim/downloads/
+
+MAINTAINER= gaoj@cpsc.ucalgary.ca
+COMMENT= An input method platform based on SCIM library and KDE/QT
+
+LIB_DEPENDS= scim-1.0.3:${PORTSDIR}/textproc/scim
+
+USE_KDELIBS_VER=3
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+pre-configure:
+ ${REINPLACE_CMD} "s,-pedantic,,g; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+ ${REINPLACE_CMD} "s, | .*freebsd\*)$$,*),g" ${WRKSRC}/admin/ltmain.sh
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO} To display this message again, type make post-install
+
+.include <bsd.port.mk>
diff --git a/textproc/skim/distinfo b/textproc/skim/distinfo
new file mode 100644
index 000000000000..5345cd8a5a45
--- /dev/null
+++ b/textproc/skim/distinfo
@@ -0,0 +1,2 @@
+MD5 (skim-0.9.3.tar.gz) = e3dd8d58262fdd379e9921ab384051b0
+SIZE (skim-0.9.3.tar.gz) = 876274
diff --git a/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp b/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp
new file mode 100644
index 000000000000..41dcd96d59e1
--- /dev/null
+++ b/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp
@@ -0,0 +1,23 @@
+--- plugins/scimlauncher/scimlauncher.cpp~ Sun Jul 11 06:19:13 2004
++++ plugins/scimlauncher/scimlauncher.cpp Wed Jul 21 15:32:13 2004
+@@ -31,6 +31,20 @@
+ K_EXPORT_COMPONENT_FACTORY( skimplugin_scim,
+ KGenericFactory<ScimLauncher>( "skimplugin_scim" ) );
+
++char* mystrndup (const char* s, size_t n){
++ size_t len=strlen(s);
++ if(len>n)
++ len=n;
++ char* newc=(char*)malloc(len+1);
++
++ if (newc==NULL)
++ return NULL;
++
++ newc[len] = '\0';
++ return (char *)memcpy(newc, s, len);
++}
++#define strndup mystrndup
++
+ ScimThread::ScimThread(QString _args)
+ {
+ args = "skim " + _args;
diff --git a/textproc/skim/pkg-descr b/textproc/skim/pkg-descr
new file mode 100644
index 000000000000..1258fbf67c41
--- /dev/null
+++ b/textproc/skim/pkg-descr
@@ -0,0 +1,6 @@
+Skim is a input method platform based upon scim libraries optimized for KDE. It
+provides a GUI panel (named scim-panel-kde), a KConfig config module and
+SetupUIs for itself and scim-lib. It also has its own plugin system which
+supports on-demand loadable actions.
+
+WWW: http://scim.freedesktop.org/
diff --git a/textproc/skim/pkg-message b/textproc/skim/pkg-message
new file mode 100644
index 000000000000..64eacb808427
--- /dev/null
+++ b/textproc/skim/pkg-message
@@ -0,0 +1,22 @@
+------------------------------------------------------------------------------
+The installation of skim has finished. You can find correponding menu items in
+KDE's menu and Control Center.
+
+Please note this port contains only KDE/QT frontends and utilities to the SCIM
+platform. If you want to use any actual input method, please install the
+following ports as needed:
+
+ Chinese:
+ chinese/scim-tables Table based input methods: Array30, CangJie, Cantonese,
+ Dayi, Erbi, EZ, Jyutping, Simplex, Wubi, Ziranma, ZhuYin
+ chinese/scim-chinese Smart pinyin
+
+ Korean:
+ korean/scim-tables Table based input methods: Hangul, Hanja
+
+ Japanese:
+ japanese/scim-tables Table based input methods: HIRAGANA, KATAKANA, Nippon
+
+You can use the command `skim' to start after properly setting SCIM (please
+refer to the message displayed by scim installation).
+------------------------------------------------------------------------------
diff --git a/textproc/skim/pkg-plist b/textproc/skim/pkg-plist
new file mode 100644
index 000000000000..a10c3f812f33
--- /dev/null
+++ b/textproc/skim/pkg-plist
@@ -0,0 +1,88 @@
+bin/skim
+bin/scim-panel-kde
+lib/kde3/kcm_skimplugin_configplugin.la
+lib/kde3/kcm_skimplugin_configplugin.so
+lib/kde3/kcm_skimplugin_scim_global.la
+lib/kde3/kcm_skimplugin_scim_global.so
+lib/kde3/kcm_skimplugin_inputwindow.la
+lib/kde3/kcm_skimplugin_inputwindow.so
+lib/kde3/kcm_skimplugin_mainwindow.la
+lib/kde3/kcm_skimplugin_mainwindow.so
+lib/kde3/kcm_skimplugin_scim_imengines.la
+lib/kde3/kcm_skimplugin_scim_imengines.so
+lib/kde3/kcm_skimplugin_scim_qtimm.la
+lib/kde3/kcm_skimplugin_scim_qtimm.so
+lib/kde3/kcm_skimplugin_scim_smartpinyin.la
+lib/kde3/kcm_skimplugin_scim_smartpinyin.so
+lib/kde3/kcm_skimplugin_scim_tables.la
+lib/kde3/kcm_skimplugin_scim_tables.so
+lib/kde3/kcm_skimplugin_scim_x.la
+lib/kde3/kcm_skimplugin_scim_x.so
+lib/kde3/kcm_skimplugin_systemtray.la
+lib/kde3/kcm_skimplugin_systemtray.so
+lib/kde3/skimplugin_inputwindow.la
+lib/kde3/skimplugin_inputwindow.so
+lib/kde3/skimplugin_mainwindow.la
+lib/kde3/skimplugin_mainwindow.so
+lib/kde3/skimplugin_scim.la
+lib/kde3/skimplugin_scim.so
+lib/kde3/skimplugin_setupwindow.la
+lib/kde3/skimplugin_setupwindow.so
+lib/kde3/skimplugin_systemtray.la
+lib/kde3/skimplugin_systemtray.so
+lib/skim/libscim-kdeutils.la
+lib/skim/libscim-kdeutils.so
+lib/skim/libscim-kdeutils.so.0
+lib/skim/libskim.la
+lib/skim/libskim.so
+lib/skim/libskim.so.0
+share/applnk/Utilities/skim.desktop
+share/apps/skim/mainwindowui.rc
+share/apps/skim/pics/full_width_letter.png
+share/apps/skim/pics/full_width_punct.png
+share/apps/skim/pics/half_width_letter.png
+share/apps/skim/pics/half_width_punct.png
+share/apps/skim/pics/keyboard.png
+share/apps/skim/pics/pin_down.png
+share/apps/skim/pics/pin_up.png
+share/apps/skim/pics/skim.png
+share/config.kcfg/generictable.kcfg
+share/config.kcfg/qtimm.kcfg
+share/config.kcfg/scimkdeconfig.kcfg
+share/config.kcfg/smartpinyin.kcfg
+share/doc/HTML/en/skim/common
+share/doc/HTML/en/skim/index.cache.bz2
+share/doc/HTML/en/skim/index.docbook
+share/doc/HTML/en/skim/inputwindow.png
+share/doc/HTML/en/skim/kdesystray.png
+share/doc/HTML/en/skim/kdex.dtd
+share/doc/HTML/en/skim/mainwindow.png
+share/doc/HTML/en/skim/setupwindow.png
+share/locale/zh_CN/LC_MESSAGES/skim.mo
+share/services/skimconfiguredialog/kcm_skimplugin_configplugin_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_global_config.desktop
+share/services/skimconfiguredialog/skimplugin_inputwindow_config.desktop
+share/services/skimconfiguredialog/skimplugin_mainwindow_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_imengines_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_qtimm_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_smartpinyin_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_table_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_x_config.desktop
+share/services/skimconfiguredialog/skimplugin_systemtray_config.desktop
+share/services/skimplugin_inputwindow.desktop
+share/services/skimplugin_mainwindow.desktop
+share/services/skimplugin_scim.desktop
+share/services/skimplugin_setupwindow.desktop
+share/services/skimplugin_systemtray.desktop
+share/servicetypes/skimplugin.desktop
+share/servicetypes/skimui.desktop
+@cwd %%X11BASE%%
+lib/scim-1.0/1.0.0/Config/kconfig.la
+lib/scim-1.0/1.0.0/Config/kconfig.so
+lib/scim-1.0/1.0.0/Config/kconfig.so.0
+@cwd %%LOCALBASE%%
+@dirrm share/services/skimconfiguredialog
+@dirrm share/doc/HTML/en/skim
+@dirrm share/apps/skim/pics
+@dirrm share/apps/skim
+@dirrm lib/skim