aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-11 04:21:02 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-11 04:21:02 +0000
commit86b0984bd5ef128965008e514ea8182671bd0eea (patch)
treea8e09deda9a8d21efb6b8d4a05f96821bde40fab /textproc/stardict3
parent8aaad277057f2c57772c157f19519a061819716c (diff)
downloadports-86b0984bd5ef128965008e514ea8182671bd0eea.tar.gz
ports-86b0984bd5ef128965008e514ea8182671bd0eea.zip
- Add patch from Shen Chun-Hsing for stardict2's TTS support
- Update a maintainer E-Mail PR: ports/74449 Submitted by: maintainer Obtained from: http://netlab.cse.yzu.edu.tw/~statue/outta-port/patch-src::readword.cpp
Notes
Notes: svn path=/head/; revision=123683
Diffstat (limited to 'textproc/stardict3')
-rw-r--r--textproc/stardict3/Makefile4
-rw-r--r--textproc/stardict3/files/patch-src::readword.cpp29
2 files changed, 31 insertions, 2 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 8cc7895ea323..8951efebda1e 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -7,13 +7,13 @@
PORTNAME= stardict
PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DIST_SUBDIR= stardict
-MAINTAINER= delphij@FreeBSD.org.cn
+MAINTAINER= delphij@FreeBSD.org
COMMENT= A cross-platform and international dictionary written in Gtk2
GNU_CONFIGURE= yes
diff --git a/textproc/stardict3/files/patch-src::readword.cpp b/textproc/stardict3/files/patch-src::readword.cpp
new file mode 100644
index 000000000000..111abbf783b1
--- /dev/null
+++ b/textproc/stardict3/files/patch-src::readword.cpp
@@ -0,0 +1,29 @@
+--- src/readword.cpp.orig Sat Nov 27 22:35:44 2004
++++ src/readword.cpp Sat Nov 27 22:36:00 2004
+@@ -18,7 +18,7 @@
+ have_data_file = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+ #else
+- have_data_file = g_file_test("/usr/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
++ have_data_file = g_file_test("/usr/local/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
+ #endif
+ }
+
+@@ -34,7 +34,7 @@
+ #ifdef _WIN32
+ gchar *filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ #else
+- gchar *filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ gchar *filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ #endif
+ return_val = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+@@ -56,7 +56,7 @@
+ filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ PlaySound(filename, 0, SND_ASYNC | SND_FILENAME);
+ #else
+- filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ gnome_sound_play(filename);
+ #endif
+ g_free(filename);