aboutsummaryrefslogtreecommitdiff
path: root/textproc/teckit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-28 19:15:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-28 19:15:02 +0000
commitd7343fba11a3eb275af5d732e41221a95b10d1bb (patch)
tree2d6a39de12266facb30901ca9d9af8b2f651e004 /textproc/teckit
parent54d3819d555b25120056a237b68e08d973aeac1b (diff)
downloadports-d7343fba11a3eb275af5d732e41221a95b10d1bb.tar.gz
ports-d7343fba11a3eb275af5d732e41221a95b10d1bb.zip
TECkit (Text Encoding Conversion toolkit) is a toolkit for converting data
between 8-bit legacy encodings and Unicode. It can also be used for transliteration of Unicode between different scripts. TECkit uses a mapping description language (mapping byte encodings to Unicode). Mapping rules can be extended by (1) the use of character sequences rather than single characters on either side; (2) by the addition of contextual constraints (environments) determining when a rule should apply; (3) and by the use of character classes, optional and repeatable elements, grouping and alternation to express more complex patterns to be matched and processed. TECkit is particularly useful with XeTeX (Unicode-aware derivate of TeX). The following binaries are provided: teckit_compile mapping compiler that allows binary mapping tables (.tec) to be built from TECkit description files (.map) sfconv a tool for converting Standard Format (SF) files txtconv a utility to apply TECkit mappings to plain-text files WWW: http://scripts.sil.org/TECkit PR: ports/138212 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Notes
Notes: svn path=/head/; revision=240465
Diffstat (limited to 'textproc/teckit')
-rw-r--r--textproc/teckit/Makefile36
-rw-r--r--textproc/teckit/distinfo3
-rw-r--r--textproc/teckit/pkg-descr22
-rw-r--r--textproc/teckit/pkg-plist23
4 files changed, 84 insertions, 0 deletions
diff --git a/textproc/teckit/Makefile b/textproc/teckit/Makefile
new file mode 100644
index 000000000000..ad0a2ca8273d
--- /dev/null
+++ b/textproc/teckit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: teckit
+# Date created: 24 August 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= teckit
+PORTVERSION= 2.5.1
+CATEGORIES= textproc
+MASTER_SITES= http://scripts.sil.org/svn-view/teckit/TAGS/ \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/
+DISTNAME= TECkit_${PORTVERSION:S|.|_|g}
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= Toolkit for converting data between 8-bit legacy encodings and Unicode
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+DOCS= AUTHORS README NEWS docs/*.pdf license/LICENSING.txt
+
+post-patch:
+ ${CHMOD} ${BINMODE} ${WRKSRC}/configure ${WRKSRC}/install-sh
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/teckit/distinfo b/textproc/teckit/distinfo
new file mode 100644
index 000000000000..b906679bf703
--- /dev/null
+++ b/textproc/teckit/distinfo
@@ -0,0 +1,3 @@
+MD5 (TECkit_2_5_1.tar.gz) = 4913f71f0f42bfd9cf8f161688b35dea
+SHA256 (TECkit_2_5_1.tar.gz) = 59a01952684c4599a7f30b4f0deedcb6276f04fce73ac6fcbcbd55c4e2e6513a
+SIZE (TECkit_2_5_1.tar.gz) = 2630207
diff --git a/textproc/teckit/pkg-descr b/textproc/teckit/pkg-descr
new file mode 100644
index 000000000000..6ef1678bdad1
--- /dev/null
+++ b/textproc/teckit/pkg-descr
@@ -0,0 +1,22 @@
+TECkit (Text Encoding Conversion toolkit) is a toolkit for converting data
+between 8-bit legacy encodings and Unicode. It can also be used for
+transliteration of Unicode between different scripts.
+
+TECkit uses a mapping description language (mapping byte encodings to Unicode).
+Mapping rules can be extended by (1) the use of character sequences rather than
+single characters on either side; (2) by the addition of contextual constraints
+(environments) determining when a rule should apply; (3) and by the use of
+character classes, optional and repeatable elements, grouping and alternation
+to express more complex patterns to be matched and processed.
+
+TECkit is particularly useful with XeTeX (Unicode-aware derivate of TeX).
+
+The following binaries are provided:
+
+ teckit_compile mapping compiler that allows binary mapping tables (.tec)
+ to be built from TECkit description files (.map)
+ sfconv a tool for converting Standard Format (SF) files
+ txtconv a utility to apply TECkit mappings to plain-text files
+
+WWW: http://scripts.sil.org/TECkit
+ http://scripts.sil.org/TECkitDownloads#5b6cf869
diff --git a/textproc/teckit/pkg-plist b/textproc/teckit/pkg-plist
new file mode 100644
index 000000000000..027c2f2d57e1
--- /dev/null
+++ b/textproc/teckit/pkg-plist
@@ -0,0 +1,23 @@
+bin/sfconv
+bin/teckit_compile
+bin/txtconv
+include/teckit/TECkit_Common.h
+include/teckit/TECkit_Compiler.h
+include/teckit/TECkit_Engine.h
+lib/libTECkit.a
+lib/libTECkit.la
+lib/libTECkit.so
+lib/libTECkit.so.0
+lib/libTECkit_Compiler.a
+lib/libTECkit_Compiler.la
+lib/libTECkit_Compiler.so
+lib/libTECkit_Compiler.so.0
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/LICENSING.txt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TECkit_Binary_Format.doc.pdf
+%%PORTDOCS%%%%DOCSDIR%%/TECkit_Language_2.1.doc.pdf
+%%PORTDOCS%%%%DOCSDIR%%/TECkit_version_2.1.doc.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/teckit