aboutsummaryrefslogtreecommitdiff
path: root/textproc/texi2html
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-02-12 22:40:59 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-02-12 22:40:59 +0000
commitba3f22fd1573688131330ef055dfd46d7a992299 (patch)
treec4742c4d45c32ee35740d95e16c323d562159c89 /textproc/texi2html
parenta1dcdbf6a8af99939a37a72dada5fd56caf32c4e (diff)
downloadports-ba3f22fd1573688131330ef055dfd46d7a992299.tar.gz
ports-ba3f22fd1573688131330ef055dfd46d7a992299.zip
Revert to the traditional behavior when building split HTML: do not create a
directory and put the files in there, but create all the files in the current directory with a common prefix instead. Grrr: in the general direction of the texi2html authors for throwing backwards compatibility to the wind without so much as a note in the ChangeLog Reported by: many people, including kris, WRT build failures on many different ports which use texi2html :( Pointy hat to: myself for not at least testing the xboard build ;)
Notes
Notes: svn path=/head/; revision=128649
Diffstat (limited to 'textproc/texi2html')
-rw-r--r--textproc/texi2html/Makefile2
-rw-r--r--textproc/texi2html/files/patch-texi2html.pl41
2 files changed, 42 insertions, 1 deletions
diff --git a/textproc/texi2html/Makefile b/textproc/texi2html/Makefile
index e70e5ca96855..64ae6a5f9941 100644
--- a/textproc/texi2html/Makefile
+++ b/textproc/texi2html/Makefile
@@ -7,7 +7,7 @@
PORTNAME= texi2html
PORTVERSION= 1.76
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_LOCAL}
diff --git a/textproc/texi2html/files/patch-texi2html.pl b/textproc/texi2html/files/patch-texi2html.pl
new file mode 100644
index 000000000000..3d163908646f
--- /dev/null
+++ b/textproc/texi2html/files/patch-texi2html.pl
@@ -0,0 +1,41 @@
+--- texi2html.pl.orig Fri Feb 4 02:16:52 2005
++++ texi2html.pl Sun Feb 13 00:18:09 2005
+@@ -2445,20 +2445,24 @@
+
+ if ($Texi2HTML::Config::SPLIT and ($Texi2HTML::Config::OUT ne ''))
+ {
+- $Texi2HTML::Config::OUT =~ s|/*$||;
+- $docu_rdir = "$Texi2HTML::Config::OUT/";
+- unless (-d $Texi2HTML::Config::OUT)
+- {
+- if ( mkdir($Texi2HTML::Config::OUT, oct(755)))
+- {
+- print STDERR "# created directory $Texi2HTML::Config::OUT\n" if ($T2H_VERBOSE);
+- }
+- else
+- {
+- die "$ERROR can't create directory $Texi2HTML::Config::OUT\n";
+- }
+- }
+- print STDERR "# putting result files into directory $docu_rdir\n" if ($T2H_VERBOSE);
++# $Texi2HTML::Config::OUT =~ s|/*$||;
++# $docu_rdir = "$Texi2HTML::Config::OUT/";
++# unless (-d $Texi2HTML::Config::OUT)
++# {
++# if ( mkdir($Texi2HTML::Config::OUT, oct(755)))
++# {
++# print STDERR "# created directory $Texi2HTML::Config::OUT\n" if ($T2H_VERBOSE);
++# }
++# else
++# {
++# die "$ERROR can't create directory $Texi2HTML::Config::OUT\n";
++# }
++# }
++# print STDERR "# putting result files into directory $docu_rdir\n" if ($T2H_VERBOSE);
++ # FIXME: handle the case when ::OUT includes a basedir
++ $Texi2HTML::Config::PREFIX = $Texi2HTML::Config::OUT;
++ $docu_rdir = '';
++ $Texi2HTML::Config::OUT = '';
+ }
+ elsif (! $Texi2HTML::Config::SPLIT and ($Texi2HTML::Config::OUT ne ''))
+ {