aboutsummaryrefslogtreecommitdiff
path: root/textproc/tth
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:26:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:26:57 +0000
commitbdf3756de64c646dae608aae59e19279e56dbeae (patch)
tree9fd2f28cd4aff7d1e0d3dcd92aac6d05f2495e9d /textproc/tth
parentb0131ccd96846e7c38ce3e63950eaa3b3528c241 (diff)
downloadports-bdf3756de64c646dae608aae59e19279e56dbeae.tar.gz
ports-bdf3756de64c646dae608aae59e19279e56dbeae.zip
[PATCH] textproc/tth: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54954 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88148
Diffstat (limited to 'textproc/tth')
-rw-r--r--textproc/tth/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/textproc/tth/Makefile b/textproc/tth/Makefile
index 51ae6b4f86d5..60d9b32ed48b 100644
--- a/textproc/tth/Makefile
+++ b/textproc/tth/Makefile
@@ -17,12 +17,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A TeX to HTML translator
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
latex:${PORTSDIR}/print/teTeX \
ppmtogif:${PORTSDIR}/graphics/netpbm
MAN1= tth.1
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
do-build:
cd ${WRKSRC}; ${CC} ${CFLAGS} tth.c -o tth -ll