aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-12-02 18:46:55 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-12-02 18:46:55 +0000
commit1a3c9915718ed7c107c4b17caed738f6b7cbcfe4 (patch)
tree1d9746be77ce1d7cafe87f33c86d3e6fcde1aa54 /textproc/uim
parent771fbdbb216d8b74f1871cace91a5c136ee92923 (diff)
downloadports-1a3c9915718ed7c107c4b17caed738f6b7cbcfe4.tar.gz
ports-1a3c9915718ed7c107c4b17caed738f6b7cbcfe4.zip
Add byeoru Korean input module.
PR: ports/89388 Submitted by: Sangwoo Shim <sangwoos@gmail.com>
Notes
Notes: svn path=/head/; revision=150251
Diffstat (limited to 'textproc/uim')
-rw-r--r--textproc/uim/Makefile14
-rw-r--r--textproc/uim/distinfo16
-rw-r--r--textproc/uim/files/patch-scm:Makefile.in20
-rw-r--r--textproc/uim/pkg-plist5
4 files changed, 53 insertions, 2 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 868afb16b5b8..b3f69700fb51 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -7,9 +7,10 @@
PORTNAME= uim
PORTVERSION= 0.4.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
-MASTER_SITES= http://uim.freedesktop.org/releases/
+MASTER_SITES= http://uim.freedesktop.org/releases/ \
+ http://www.tuhep.phys.tohoku.ac.jp/~jhpark/uim/:byeoru
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
@@ -30,6 +31,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB+= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
+BYEORU_FILES= byeoru.scm byeoru-custom.scm byeoru-key-custom.scm \
+ byeoru-symbols.scm byeoru-dic.scm
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${BYEORU_FILES:S/$/:byeoru/}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAN1= uim-xim.1
@@ -70,6 +75,11 @@ PLIST_SUB+= CANNA=""
PLIST_SUB+= CANNA="@comment "
.endif
+post-extract:
+ for i in ${BYEORU_FILES}; do \
+ ${CAT} ${DISTDIR}/$$i >${WRKSRC}/scm/$$i; \
+ done
+
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/scm/skk-custom.scm
diff --git a/textproc/uim/distinfo b/textproc/uim/distinfo
index bf87071bc8d9..3abbf18f729f 100644
--- a/textproc/uim/distinfo
+++ b/textproc/uim/distinfo
@@ -1,2 +1,18 @@
MD5 (uim-0.4.9.1.tar.gz) = 0e2625cc926917d7864c4d0c341c535a
+SHA256 (uim-0.4.9.1.tar.gz) = caad8b67e892f6bff08640dba799ecde97218dec0dd58581e7ccbfa15e870dfc
SIZE (uim-0.4.9.1.tar.gz) = 1602849
+MD5 (byeoru.scm) = 705eb5e99bccad6265eaaf0941d0ac88
+SHA256 (byeoru.scm) = 06517e1c31b350fb48248747bb8245aad0afe76f16129cecfb41fcfcc8c87065
+SIZE (byeoru.scm) = 68232
+MD5 (byeoru-custom.scm) = e38397bfad45cec132b234b53c6b7279
+SHA256 (byeoru-custom.scm) = e221cfe1007b921009279c5de945e1f055bd7ccb19662f7e75dd0b348ffaed31
+SIZE (byeoru-custom.scm) = 5664
+MD5 (byeoru-key-custom.scm) = 583381445b69fe23cb3d20afeedf5c3a
+SHA256 (byeoru-key-custom.scm) = cb99ed2fbe1cac7a1f4056f834b15428d119d918e28ff0a332235ee4eb00f3e8
+SIZE (byeoru-key-custom.scm) = 4254
+MD5 (byeoru-symbols.scm) = ea7f88d399cdf2f06908b884188f2e84
+SHA256 (byeoru-symbols.scm) = 526f187a9e2dd9c3996f4fcdcb5af915cfe0da89eae8c84c54d5c38f5480b6de
+SIZE (byeoru-symbols.scm) = 12379
+MD5 (byeoru-dic.scm) = cee301bd14f261f8a35a695238595dd5
+SHA256 (byeoru-dic.scm) = 9322999fc523c632d2b751015273a1c1d69479808136666764c210ef0c4be7fa
+SIZE (byeoru-dic.scm) = 1246039
diff --git a/textproc/uim/files/patch-scm:Makefile.in b/textproc/uim/files/patch-scm:Makefile.in
new file mode 100644
index 000000000000..f6476fc0ce15
--- /dev/null
+++ b/textproc/uim/files/patch-scm:Makefile.in
@@ -0,0 +1,20 @@
+--- scm/Makefile.in.orig Tue Nov 22 03:25:25 2005
++++ scm/Makefile.in Tue Nov 22 03:27:10 2005
+@@ -283,6 +283,8 @@
+ tcode.scm \
+ tutcode.scm tutcode-key-custom.scm \
+ hangul.scm hangul2.scm hangul3.scm romaja.scm \
++ byeoru.scm byeoru-dic.scm byeoru-symbols.scm \
++ byeoru-custom.scm byeoru-key-custom.scm \
+ viqr.scm \
+ ipa-x-sampa.scm \
+ latin.scm \
+@@ -293,7 +295,7 @@
+ uim-module-manager.scm\
+ $(am__append_1)
+
+-module_names = "pyload" $(am__append_2) $(am__append_3) $(am__append_4) $(am__append_5) "tcode" "tutcode" "hangul" "viqr" "ipa-x-sampa" "latin" $(am__append_6) $(am__append_7)
++module_names = "pyload" $(am__append_2) $(am__append_3) $(am__append_4) $(am__append_5) "tcode" "tutcode" "byeoru" "hangul" "viqr" "ipa-x-sampa" "latin" $(am__append_6) $(am__append_7)
+ subdir = scm
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/textproc/uim/pkg-plist b/textproc/uim/pkg-plist
index 90b3158e09ec..c5f828f44367 100644
--- a/textproc/uim/pkg-plist
+++ b/textproc/uim/pkg-plist
@@ -58,6 +58,11 @@ share/uim/direct.scm
share/uim/generic-custom.scm
share/uim/generic-key-custom.scm
share/uim/generic.scm
+share/uim/byeoru.scm
+share/uim/byeoru-custom.scm
+share/uim/byeoru-key-custom.scm
+share/uim/byeoru-symbols.scm
+share/uim/byeoru-dic.scm
share/uim/hangul.scm
share/uim/hangul2.scm
share/uim/hangul3.scm