aboutsummaryrefslogtreecommitdiff
path: root/textproc/urlview
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-30 12:00:43 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-30 12:00:43 +0000
commit3b920fcd6b569b94ad08020f392998faa20cb70a (patch)
tree9c7d7bcbbff870a001817e660fdfaec6fde00c04 /textproc/urlview
parentfe6b98c6de5b76d3253302a09a8cd8798154b4ce (diff)
downloadports-3b920fcd6b569b94ad08020f392998faa20cb70a.tar.gz
ports-3b920fcd6b569b94ad08020f392998faa20cb70a.zip
- Fix segfault on machines where sizeof(int) != sizeof(char *).
PR: ports/88729 Submitted by: Vasil Dimov <vd@datamax.bg> Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=150033
Diffstat (limited to 'textproc/urlview')
-rw-r--r--textproc/urlview/Makefile2
-rw-r--r--textproc/urlview/files/patch-urlview.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/textproc/urlview/Makefile b/textproc/urlview/Makefile
index c448ffdfea26..aff29aeeba7a 100644
--- a/textproc/urlview/Makefile
+++ b/textproc/urlview/Makefile
@@ -8,7 +8,7 @@
PORTNAME= urlview
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc www
MASTER_SITES= ftp://ftp.mutt.org/mutt/contrib/ \
ftp://ftp.sunsite.auc.dk/pub/mail/mutt/contrib/ \
diff --git a/textproc/urlview/files/patch-urlview.c b/textproc/urlview/files/patch-urlview.c
new file mode 100644
index 000000000000..84fd37140483
--- /dev/null
+++ b/textproc/urlview/files/patch-urlview.c
@@ -0,0 +1,11 @@
+--- urlview.c.orig Wed Nov 9 15:34:39 2005
++++ urlview.c Wed Nov 9 15:35:06 2005
+@@ -46,6 +46,8 @@
+ #include <rx/rxposix.h>
+ #endif
+
++#include "quote.h"
++
+ #define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \t.,;<>\"\\):]"
+ #define DEFAULT_COMMAND "url_handler.sh %s"
+ #define SYSTEM_INITFILE "/usr/local/etc/urlview.conf"