aboutsummaryrefslogtreecommitdiff
path: root/textproc/xalan-j
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-12-15 10:08:00 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-12-15 10:08:00 +0000
commit9dd27e1ac1b3c04cd13e0f1c2daf1afa1fa028f3 (patch)
tree0e066e53735c3b46eac0300a81a427174ab7c1cb /textproc/xalan-j
parentf5c1ec3abfc3c449a4bca8ccb206b471ee404a68 (diff)
downloadports-9dd27e1ac1b3c04cd13e0f1c2daf1afa1fa028f3.tar.gz
ports-9dd27e1ac1b3c04cd13e0f1c2daf1afa1fa028f3.zip
Update to 2.7.1 release:
- switch to binary distribution - general cleanup of port Makefile - take maintainership [1] Approved by: maintainer [1]
Notes
Notes: svn path=/head/; revision=266335
Diffstat (limited to 'textproc/xalan-j')
-rw-r--r--textproc/xalan-j/Makefile49
-rw-r--r--textproc/xalan-j/distinfo5
-rw-r--r--textproc/xalan-j/files/xalan-j.sh.in2
-rw-r--r--textproc/xalan-j/pkg-descr3
4 files changed, 32 insertions, 27 deletions
diff --git a/textproc/xalan-j/Makefile b/textproc/xalan-j/Makefile
index c6b4b94659ac..edb39a680cac 100644
--- a/textproc/xalan-j/Makefile
+++ b/textproc/xalan-j/Makefile
@@ -6,54 +6,57 @@
#
PORTNAME= xalan-j
-PORTVERSION= 2.7.0
-PORTREVISION= 2
+PORTVERSION= 2.7.1
CATEGORIES= textproc java
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
-MASTER_SITE_SUBDIR= ${PORTNAME}/source
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}-src
+MASTER_SITE_SUBDIR= ${PORTNAME}/binaries
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}-bin
-MAINTAINER= hq@FreeBSD.org
+MAINTAINER= ale@FreeBSD.org
COMMENT= Apache XSLT processor for transforming XML documents
-RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+RUN_DEPENDS= ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.2+
-USE_ANT= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/./_/g}
-ALL_TARGET= jar
-.if !defined(NOPORTDOCS)
-ALL_TARGET+= javadocs
-PORTDOCS= apidocs design
-.endif
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
JARFILES= xalan.jar serializer.jar
+
PLIST_FILES= ${JARFILES:S|^|%%JAVAJARDIR%%/|} bin/xalan-j
SUB_FILES= xalan-j.sh
-.include <bsd.port.pre.mk>
-
-.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} != "1.5"
-RUN_DEPENDS+= ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
-.endif
-
do-install:
@${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
.for jarfile in ${JARFILES}
- @${INSTALL_DATA} ${WRKSRC}/build/${jarfile} ${JAVAJARDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/${jarfile} ${JAVAJARDIR}/
@${ECHO_MSG} -n " ${jarfile}"
.endfor
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC}/build/docs && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
- @cd ${WRKSRC}/build/docs && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${DOCSDIR})
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/samples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
@${ECHO_MSG} " [ DONE ]"
.endif
@${ECHO_MSG} -n ">> Installing script in ${PREFIX}/bin/..."
@${INSTALL_SCRIPT} ${WRKDIR}/xalan-j.sh ${PREFIX}/bin/xalan-j
@${ECHO_MSG} " [ DONE ]"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/xalan-j/distinfo b/textproc/xalan-j/distinfo
index 07f593bb2276..71a0b1feda39 100644
--- a/textproc/xalan-j/distinfo
+++ b/textproc/xalan-j/distinfo
@@ -1,3 +1,2 @@
-MD5 (xalan-j_2_7_0-src.tar.gz) = 7859a78a5564cae42c933adcbbecdd01
-SHA256 (xalan-j_2_7_0-src.tar.gz) = 210843fb672b0c44138797d9d11b61c2f538b89400ce8be1f230cd666f70bb02
-SIZE (xalan-j_2_7_0-src.tar.gz) = 6264659
+SHA256 (xalan-j_2_7_1-bin.zip) = 725620850d990f23009619471341c2beb2c97065b46321a3b08c0cebb8dffcb1
+SIZE (xalan-j_2_7_1-bin.zip) = 17336979
diff --git a/textproc/xalan-j/files/xalan-j.sh.in b/textproc/xalan-j/files/xalan-j.sh.in
index 89dbf4c58adf..80eedfb319e7 100644
--- a/textproc/xalan-j/files/xalan-j.sh.in
+++ b/textproc/xalan-j/files/xalan-j.sh.in
@@ -1,4 +1,4 @@
#!/bin/sh
# $FreeBSD$
-JAVA_VERSION="%%JAVA_VERSION%%" exec "%%LOCALBASE%%/bin/java" -cp "%%JAVALIBDIR%%/xml-apis.jar:%%JAVALIBDIR/xercesImpl.jar:%%JAVAJARDIR%%/xalan.jar" org.apache.xalan.xslt.Process "$@"
+"%%LOCALBASE%%/bin/java" -cp "%%JAVALIBDIR%%/xml-apis.jar:%%JAVALIBDIR/xercesImpl.jar:%%JAVAJARDIR%%/xalan.jar" org.apache.xalan.xslt.Process "$@"
diff --git a/textproc/xalan-j/pkg-descr b/textproc/xalan-j/pkg-descr
index da1f2dc837a4..4fafbf9f196c 100644
--- a/textproc/xalan-j/pkg-descr
+++ b/textproc/xalan-j/pkg-descr
@@ -13,3 +13,6 @@ to use.
Xalan-Java also builds on SAX 2 and DOM level 2.
WWW: http://xml.apache.org/xalan-j/
+
+- Alex Dupre
+ale@FreeBSD.org