aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 20:12:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 20:12:37 +0000
commitf6e0b913154ad0a900e62b94883dee4f507dbd43 (patch)
tree57c09f78eebcd9abcff0ea51595fda12c728264c /textproc/xerces-c2
parent0dc09927f73ed35e04ffd997c14bee7607ffd500 (diff)
downloadports-f6e0b913154ad0a900e62b94883dee4f507dbd43.tar.gz
ports-f6e0b913154ad0a900e62b94883dee4f507dbd43.zip
- Add patch for this problem:
The XMLPlatformUtils::openFile function opens files with fopen and passes it "r+" string as mode argument. This makes(according to fopen(3)) it try to open file for reading and writing while it should be opened for reading only. As a result you can't work with files not owned by you which is rather common case for dtd files. - Raise PORTREVISION PR: ports/59499 Submitted by: Konstantin Oznobihin <bork@rsu.ru> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=97101
Diffstat (limited to 'textproc/xerces-c2')
-rw-r--r--textproc/xerces-c2/Makefile1
-rw-r--r--textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index 51264bbe808a..9966df9232dc 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp b/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
new file mode 100644
index 000000000000..9b0f6629c8af
--- /dev/null
+++ b/textproc/xerces-c2/files/patch-src-xercesc-util-Platforms-FreeBSD-FreeBSDPlatformUtils.cpp
@@ -0,0 +1,20 @@
+--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
++++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
+@@ -298,7 +298,7 @@
+ XMLExcepts::CPtr_PointerIsZero);
+ const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
+ ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
+- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
+ return retVal;
+ }
+
+@@ -307,7 +307,7 @@
+ if (fileName == NULL)
+ ThrowXML(XMLPlatformUtilsException,
+ XMLExcepts::CPtr_PointerIsZero);
+- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
++ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
+ return retVal;
+ }
+