aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
commit7464f336e31fd80c931c3eb1c4c62776e4e3f7f1 (patch)
tree967c3aa47957c6218b6c16c34cfdf4261490cfc6 /textproc/xhtml
parentd7f26aaaed78fb07382fa672754350cb37ec40e0 (diff)
downloadports-7464f336e31fd80c931c3eb1c4c62776e4e3f7f1.tar.gz
ports-7464f336e31fd80c931c3eb1c4c62776e4e3f7f1.zip
Switch to using xmlcatmgr from mkcatalog.
# Maintainers, please let me know if I break something in your port. Submitted by: hrs PR: ports/53819, ports/53820, ports/53821, ports/53822, ports/53823, ports/53824, ports/53825, ports/53826, ports/53827, ports/53828, ports/53829, ports/53830, ports/53831, ports/53832, ports/53833, ports/53834, ports/53835, ports/53836, ports/53837
Notes
Notes: svn path=/head/; revision=83949
Diffstat (limited to 'textproc/xhtml')
-rw-r--r--textproc/xhtml/Makefile22
-rw-r--r--textproc/xhtml/files/catalog.xml14
-rw-r--r--textproc/xhtml/pkg-plist7
3 files changed, 34 insertions, 9 deletions
diff --git a/textproc/xhtml/Makefile b/textproc/xhtml/Makefile
index c9daff2f28df..673b0d8cf581 100644
--- a/textproc/xhtml/Makefile
+++ b/textproc/xhtml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xhtml
PORTVERSION= 1.0.20020801
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
#MASTER_SITES= http://www.w3.org/TR/xhtml1/
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -17,21 +17,28 @@ DISTNAME= xhtml1-20020801
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= W3C's XHTML DTD
-BUILD_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
-RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
USE_ZIP= YES
NO_MTREE= YES
NO_BUILD= YES
WRKSRC= ${WRKDIR}/xhtml1-20020801
+PLIST_SUB= XMLCATMGR=${XMLCATMGR}
+PLIST_SUB+= DTDDIR=${DTDDIR}
+PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
+PLIST_SUB+= CATALOG_PORTS_XML=${CATALOG_PORTS_XML}
INSTDIR= ${PREFIX}/share/xml
DTDDIR= ${INSTDIR}/dtd/xhtml
DTDFILES= xhtml-lat1.ent xhtml-special.ent xhtml-symbol.ent \
xhtml.soc xhtml1-frameset.dtd xhtml1-strict.dtd \
- xhtml1-transitional.dtd xhtml1.dcl
-MKCATALOG= ${PREFIX}/sbin/mkcatalog
-PLIST_SUB= MKCATALOG=${MKCATALOG}
+ xhtml1-transitional.dtd xhtml1.dcl ${WRKSRC}/catalog.xml
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+CATALOG_PORTS_XML= ${PREFIX}/share/xml/catalog.ports
+
+post-patch:
+ ${SED} -e 's#@@DTDDIR@@#${DTDDIR}#' < ${FILESDIR}/catalog.xml > ${WRKSRC}/catalog.xml
pre-install:
@[ -d ${DTDDIR} ] || ${MKDIR} ${DTDDIR}
@@ -40,6 +47,7 @@ do-install:
@(cd ${WRKSRC}/DTD; ${INSTALL_DATA} ${DTDFILES} ${DTDDIR})
post-install:
- @${MKCATALOG} -c ${INSTDIR}/catalog -q install dtd/xhtml xhtml.soc
+ ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${DTDDIR}/xhtml.soc
+ ${XMLCATMGR} -c ${CATALOG_PORTS_XML} add nextCatalog ${DTDDIR}/catalog.xml
.include <bsd.port.mk>
diff --git a/textproc/xhtml/files/catalog.xml b/textproc/xhtml/files/catalog.xml
new file mode 100644
index 000000000000..2442f65e0f96
--- /dev/null
+++ b/textproc/xhtml/files/catalog.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0"?>
+<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
+ "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">
+
+<!-- Created by xmlcatmgr-0.2 -->
+
+<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
+ <public publicId="-//W3C//DTD XHTML 1.0 Strict//EN" uri="file://@@DTDDIR@@/xhtml1-strict.dtd" />
+ <public publicId="-//W3C//DTD XHTML 1.0 Transitional//EN" uri="file://@@DTDDIR@@/xhtml1-transitional.dtd" />
+ <public publicId="-//W3C//DTD XHTML 1.0 Frameset//EN" uri="file://@@DTDDIR@@/xhtml1-frameset.dtd" />
+ <public publicId="-//W3C//ENTITIES Latin 1 for XHTML//EN" uri="file://@@DTDDIR@@/xhtml-lat1.ent" />
+ <public publicId="-//W3C//ENTITIES Symbols for XHTML//EN" uri="file://@@DTDDIR@@/xhtml-symbol.ent" />
+ <public publicId="-//W3C//ENTITIES Special for XHTML//EN" uri="file://@@DTDDIR@@/xhtml-special.ent" />
+</catalog>
diff --git a/textproc/xhtml/pkg-plist b/textproc/xhtml/pkg-plist
index df6d2a9a4ab0..90de89ed5264 100644
--- a/textproc/xhtml/pkg-plist
+++ b/textproc/xhtml/pkg-plist
@@ -1,9 +1,12 @@
share/xml/dtd/xhtml/xhtml-lat1.ent
share/xml/dtd/xhtml/xhtml-special.ent
share/xml/dtd/xhtml/xhtml-symbol.ent
-@unexec %%MKCATALOG%% -c %D/share/xml/catalog -q deinstall dtd/xhtml xhtml.soc
+@unexec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% remove %%DTDDIR%%/xhtml.soc
share/xml/dtd/xhtml/xhtml.soc
-@exec %%MKCATALOG%% -c %D/share/xml/catalog -q install dtd/xhtml xhtml.soc
+@exec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% add CATALOG %%DTDDIR%%/xhtml.soc
+@unexec %%XMLCATMGR%% -c %%CATALOG_PORTS_XML%% remove %%DTDDIR%%/catalog.xml
+share/xml/dtd/xhtml/catalog.xml
+@exec %%XMLCATMGR%% -c %%CATALOG_PORTS_XML%% add nextCatalog %%DTDDIR%%/catalog.xml
share/xml/dtd/xhtml/xhtml1-frameset.dtd
share/xml/dtd/xhtml/xhtml1-strict.dtd
share/xml/dtd/xhtml/xhtml1-transitional.dtd