aboutsummaryrefslogtreecommitdiff
path: root/textproc/xincluder
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
commit5fad809a5036ede0aa1484f20794ae259980b7fa (patch)
treecddd9991fc9d4b10a6996ebf4fafeeaf1d756cbe /textproc/xincluder
parentf83af9fadf126ce99ee41552d898bc5eb04fd222 (diff)
downloadports-5fad809a5036ede0aa1484f20794ae259980b7fa.tar.gz
ports-5fad809a5036ede0aa1484f20794ae259980b7fa.zip
Remove NOPORTDOCS and NOPORTEXAMPLES.
Notes
Notes: svn path=/head/; revision=360676
Diffstat (limited to 'textproc/xincluder')
-rw-r--r--textproc/xincluder/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/textproc/xincluder/Makefile b/textproc/xincluder/Makefile
index 30dc6629dbc1..5d4c3cf42b04 100644
--- a/textproc/xincluder/Makefile
+++ b/textproc/xincluder/Makefile
@@ -21,32 +21,30 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
SUFFIXES= -sax -dom -jdom
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar bin/xincluder ${SUFFIXES:S,^,bin/xincluder,}
-.if !defined(NOPORTDOCS)
PORTDOCS= apidoc index.html
-.endif
SUB_FILES= xincluder.sh
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}/
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing scripts in ${PREFIX}/bin..."
@${ECHO_MSG} -n " xincluder"
- @${INSTALL_SCRIPT} ${WRKDIR}/xincluder.sh ${STAGEDIR}${PREFIX}/bin/xincluder
+ ${INSTALL_SCRIPT} ${WRKDIR}/xincluder.sh ${STAGEDIR}${PREFIX}/bin/xincluder
.for suffix in ${SUFFIXES}
@${ECHO_MSG} -n " xincluder${suffix}"
- @${LN} -s xincluder ${STAGEDIR}${PREFIX}/bin/xincluder${suffix}
+ ${LN} -s xincluder ${STAGEDIR}${PREFIX}/bin/xincluder${suffix}
.endfor
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC} \
+ cd ${WRKSRC} \
&& ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; \
&& ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
-.endif
.include <bsd.port.mk>