aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmldiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 07:35:58 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 07:35:58 +0000
commit879a16d795fabb93984a9b96c1949e65f5887eb0 (patch)
treedb1cf1b08bb2437df9d16101a35120bad40f6f11 /textproc/xmldiff
parent65c405f2415cba36ae94235a8cb5f10821fbe021 (diff)
downloadports-879a16d795fabb93984a9b96c1949e65f5887eb0.tar.gz
ports-879a16d795fabb93984a9b96c1949e65f5887eb0.zip
Add xmldiff.
xmldiff uses xmlprpr and diff to display meaningful differences in XML files in an easy to read format. Output formats available include HTML, ANSI colour, and regular diff. The coloured modes are particularly useful for viewing small differences in context within large XML files. WWW: http://software.decisionsoft.com/tools.html PR: ports/92947 Submitted by: Paul Chvostek <paul+ports@it.ca>
Notes
Notes: svn path=/head/; revision=155721
Diffstat (limited to 'textproc/xmldiff')
-rw-r--r--textproc/xmldiff/Makefile31
-rw-r--r--textproc/xmldiff/distinfo3
-rw-r--r--textproc/xmldiff/files/patch-xmldiff.pl17
-rw-r--r--textproc/xmldiff/pkg-descr9
4 files changed, 60 insertions, 0 deletions
diff --git a/textproc/xmldiff/Makefile b/textproc/xmldiff/Makefile
new file mode 100644
index 000000000000..4fb1b7954d95
--- /dev/null
+++ b/textproc/xmldiff/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xmldiff
+# Date created: Sun Oct 9 10:33:37 EDT 2005
+# Whom: Paul Chvostek <paul+ports@it.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmldiff
+PORTVERSION= 0.01
+CATEGORIES= textproc
+MASTER_SITES= http://software.decisionsoft.com/software/ \
+ http://www.it.ca/~paul/src/
+DISTFILES= xmldiff.pl
+
+MAINTAINER= paul+ports@it.ca
+COMMENT= Display meaningful differences between XML files
+
+RUN_DEPENDS= xmlprpr:${PORTSDIR}/textproc/xmlprpr
+
+USE_PERL5= yes
+NO_BUILD= yes
+PLIST_FILES= bin/xmldiff
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -f ${_DISTDIR}/${_DISTFILES} ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/xmldiff.pl ${PREFIX}/bin/xmldiff
+
+.include <bsd.port.mk>
diff --git a/textproc/xmldiff/distinfo b/textproc/xmldiff/distinfo
new file mode 100644
index 000000000000..54540bb01126
--- /dev/null
+++ b/textproc/xmldiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmldiff.pl) = e51781dea77a3a35e5f981dcf17a033a
+SHA256 (xmldiff.pl) = c825e77068bcabfe524ee4fe78d87cbc013e6162d0ac298c854379f7ecefa4f4
+SIZE (xmldiff.pl) = 2976
diff --git a/textproc/xmldiff/files/patch-xmldiff.pl b/textproc/xmldiff/files/patch-xmldiff.pl
new file mode 100644
index 000000000000..9b0ea24d1cec
--- /dev/null
+++ b/textproc/xmldiff/files/patch-xmldiff.pl
@@ -0,0 +1,17 @@
+--- xmldiff.pl.orig Sat Feb 11 08:32:29 2006
++++ xmldiff.pl Sat Feb 11 08:32:38 2006
+@@ -7,12 +7,12 @@
+ #
+
+ #
+-# xmldiff: xmldiff program - uses xmlpp
++# xmldiff: xmldiff program - uses xmlprpr
+ #
+
+ #Change this if xmlpp is not in your current path
+ #for example: $XMLPP = "./xmlpp";
+-$XMLPP = "xmlpp";
++$XMLPP = "xmlprpr";
+
+ # older versions of less don't support -R, consider -r instead
+ my $pagerCmd = ' | less -R ';
diff --git a/textproc/xmldiff/pkg-descr b/textproc/xmldiff/pkg-descr
new file mode 100644
index 000000000000..7e4cdcc84ab9
--- /dev/null
+++ b/textproc/xmldiff/pkg-descr
@@ -0,0 +1,9 @@
+xmldiff uses xmlprpr and diff to display meaningful differences in XML
+files in an easy to read format. Output formats available include HTML,
+ANSI colour, and regular diff. The coloured modes are particularly
+useful for viewing small differences in context within large XML files.
+
+WWW: http://software.decisionsoft.com/tools.html
+
+- Paul Chvostek
+paul+ports@it.ca