aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlroff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2007-09-02 16:22:14 +0000
committerHiroki Sato <hrs@FreeBSD.org>2007-09-02 16:22:14 +0000
commit9338d9f65f924cdeb350314bae7c8df66072d046 (patch)
tree5a46c1557a3576ddac5e246ac6f99a25fcb4e847 /textproc/xmlroff
parenta3820b8483ab2ad94f4fb82e838c02f0dd2e26ce (diff)
downloadports-9338d9f65f924cdeb350314bae7c8df66072d046.tar.gz
ports-9338d9f65f924cdeb350314bae7c8df66072d046.zip
Update to 0.5.2. Changes include:
* Fixed crash in locales with comma as decimal separator (#49) * Cleaned up all compiler warnings (#51) * >99% reduction in 'permanently lost' memory leaks (#52) * Fixed compilation error when GNOME Print not installed (#34) * Fixed segfaults when media-usage not 'paginate'
Notes
Notes: svn path=/head/; revision=198655
Diffstat (limited to 'textproc/xmlroff')
-rw-r--r--textproc/xmlroff/Makefile2
-rw-r--r--textproc/xmlroff/distinfo6
-rw-r--r--textproc/xmlroff/files/patch-area::fo-area-layout.c33
-rw-r--r--textproc/xmlroff/files/patch-datatype::fo-color.c17
-rw-r--r--textproc/xmlroff/files/patch-datatype::fo-enum.c47
-rw-r--r--textproc/xmlroff/files/patch-expr::fo-expr-eval.c93
-rw-r--r--textproc/xmlroff/files/patch-fo-context-util.c173
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-block-area.c19
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-fo.c22
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c17
-rw-r--r--textproc/xmlroff/files/patch-fo-fo-table.c19
-rw-r--r--textproc/xmlroff/files/patch-libfo::fo-doc-gp.c56
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c28
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-font-family.c18
-rw-r--r--textproc/xmlroff/files/patch-property-fo-property-id.c15
-rw-r--r--textproc/xmlroff/files/patch-property::fo-property-util.c29
-rw-r--r--textproc/xmlroff/pkg-plist87
17 files changed, 47 insertions, 634 deletions
diff --git a/textproc/xmlroff/Makefile b/textproc/xmlroff/Makefile
index 03f7b44ac330..e24c8725adfe 100644
--- a/textproc/xmlroff/Makefile
+++ b/textproc/xmlroff/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmlroff
-PORTVERSION= 0.5.0
+PORTVERSION= 0.5.2
CATEGORIES= textproc
MASTER_SITES= http://xmlroff.org/download/
diff --git a/textproc/xmlroff/distinfo b/textproc/xmlroff/distinfo
index c9e21e3d6eb7..ac4508d1f5c7 100644
--- a/textproc/xmlroff/distinfo
+++ b/textproc/xmlroff/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmlroff-0.5.0.tar.gz) = 840efe684709b4af553d3cdab09f748d
-SHA256 (xmlroff-0.5.0.tar.gz) = 852e0b18b280c3ea6e99c074ff7c103523343a80f85e6e3f1ea14f26ce8e417d
-SIZE (xmlroff-0.5.0.tar.gz) = 2612439
+MD5 (xmlroff-0.5.2.tar.gz) = 44149659ebbcec493a110f264738ea14
+SHA256 (xmlroff-0.5.2.tar.gz) = 2212987fbc39daa88f136be1fa1f30e59a9d7efc21ae08e70079d41d83fb6a30
+SIZE (xmlroff-0.5.2.tar.gz) = 2816953
diff --git a/textproc/xmlroff/files/patch-area::fo-area-layout.c b/textproc/xmlroff/files/patch-area::fo-area-layout.c
deleted file mode 100644
index 75e0a7b8f3f9..000000000000
--- a/textproc/xmlroff/files/patch-area::fo-area-layout.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- area/fo-area-layout.c.orig Mon Jan 10 13:51:32 2005
-+++ area/fo-area-layout.c Mon Jan 10 13:52:41 2005
-@@ -543,6 +543,7 @@
- PANGO_SCALE - line_first_pre_height) ||
- line_index == pre_widow_max - 1)
- {
-+ gboolean retain_padding_before;
- #if defined(LIBFO_DEBUG) && 0
- g_message ("layout_split_before_height:: Break:: line: %d",
- line_index);
-@@ -558,7 +559,7 @@
- 0.0);
- fo_area_area_set_border_before (new_area,
- 0.0);
-- gboolean retain_padding_before =
-+ retain_padding_before =
- fo_length_cond_get_condity (fo_property_get_value (fo_block_get_padding_before (area->generated_by)));
-
- if (!retain_padding_before)
-@@ -824,10 +825,12 @@
- fo_area_layout_get_line_height (FoArea *fo_area_layout,
- gint line_number)
- {
-+ FoAreaLayout *layout;
-+
- g_return_val_if_fail (fo_area_layout != NULL, 0.0);
- g_return_val_if_fail (FO_IS_AREA_LAYOUT (fo_area_layout), 0.0);
-
-- FoAreaLayout *layout = FO_AREA_LAYOUT (fo_area_layout);
-+ layout = FO_AREA_LAYOUT (fo_area_layout);
-
- return
- (gdouble) GPOINTER_TO_INT (g_slist_nth_data (layout->line_heights,
diff --git a/textproc/xmlroff/files/patch-datatype::fo-color.c b/textproc/xmlroff/files/patch-datatype::fo-color.c
deleted file mode 100644
index a06859cb7b1b..000000000000
--- a/textproc/xmlroff/files/patch-datatype::fo-color.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- datatype/fo-color.c.orig Thu Mar 3 10:50:38 2005
-+++ datatype/fo-color.c Thu Mar 3 10:51:09 2005
-@@ -307,12 +307,13 @@
- guint blue)
- {
- FoDatatype *color = fo_color_new ();
-+ FoDatatype *hashed_color;
-
- fo_color_set_red (color, red);
- fo_color_set_blue (color, blue);
- fo_color_set_green (color, green);
-
-- FoDatatype *hashed_color =
-+ hashed_color =
- (FoDatatype *) fo_hash_table_lookup (FO_COLOR_GET_CLASS(color)->colors,
- FO_OBJECT (color),
- NULL);
diff --git a/textproc/xmlroff/files/patch-datatype::fo-enum.c b/textproc/xmlroff/files/patch-datatype::fo-enum.c
deleted file mode 100644
index 7419dcede492..000000000000
--- a/textproc/xmlroff/files/patch-datatype::fo-enum.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- datatype/fo-enum.c.orig Mon Jan 10 13:55:20 2005
-+++ datatype/fo-enum.c Mon Jan 10 13:56:26 2005
-@@ -400,6 +400,8 @@
- void
- fo_enum_class_init (FoEnumClass *klass)
- {
-+ int i;
-+
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-@@ -413,7 +415,6 @@
-
- FO_DATATYPE_CLASS (klass)->copy = fo_enum_copy;
-
-- int i;
- for (i = 0; i < FO_ENUM_ENUM_LIMIT; i++)
- {
- enums[i] = NULL;
-@@ -708,10 +709,12 @@
- FoDatatype *
- fo_enum_get_enum_by_value (FoEnumEnum enum_value)
- {
-+ GEnumValue *enum_ptr;
-+
- g_return_val_if_fail (enum_value > FO_ENUM_ENUM_UNSPECIFIED, NULL);
- g_return_val_if_fail (enum_value < FO_ENUM_ENUM_LIMIT, NULL);
-
-- GEnumValue *enum_ptr =
-+ enum_ptr =
- g_enum_get_value (g_type_class_ref (FO_TYPE_ENUM_ENUM),
- enum_value);
-
-@@ -748,10 +751,12 @@
- FoDatatype *
- fo_enum_get_enum_by_nick (const gchar *name)
- {
-+ GEnumValue *enum_ptr;
-+
- g_return_val_if_fail (name != NULL, NULL);
- g_return_val_if_fail (*name != '\0', NULL);
-
-- GEnumValue *enum_ptr =
-+ enum_ptr =
- g_enum_get_value_by_nick (g_type_class_ref (FO_TYPE_ENUM_ENUM),
- name);
-
diff --git a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c b/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
deleted file mode 100644
index f0693e272204..000000000000
--- a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
+++ /dev/null
@@ -1,93 +0,0 @@
---- expr/fo-expr-eval.c.orig Tue Apr 26 07:13:16 2005
-+++ expr/fo-expr-eval.c Wed Jun 15 01:07:29 2005
-@@ -1283,6 +1283,9 @@
- */
-
- FoDatatype *result_datatype = NULL;
-+ FoDatatype *stack_second = NULL;
-+ FoDatatype *stack_third = NULL;
-+ FoDatatype *stack_fourth = NULL;
-
- /* First stack entry */
- FoDatatype *stack_first = fo_expr_context_pop_stack (context);
-@@ -1304,7 +1307,7 @@
- }
-
- /* Second stack entry */
-- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
-+ stack_second = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for second stack entry. */
- if (stack_second == NULL)
-@@ -1324,7 +1327,7 @@
- }
-
- /* third stack entry */
-- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
-+ stack_third = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for third stack entry. */
- if (stack_third == NULL)
-@@ -1344,7 +1347,7 @@
- }
-
- /* fourth stack entry */
-- FoDatatype *stack_fourth = fo_expr_context_pop_stack (context);
-+ stack_fourth = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for fourth stack entry. */
- if (stack_fourth == NULL)
-@@ -1383,9 +1386,11 @@
- static void
- eval_padding_expr (FoExprContext *context)
- {
-+ gchar *name;
-+
- fo_expr_context_skip_blanks (context);
-
-- gchar *name = parse_ncname (context);
-+ name = parse_ncname (context);
-
- if (name == NULL)
- {
-@@ -1745,11 +1750,12 @@
- /* If not 'inherit', then one to four <color> or 'transparent' values. */
- do
- {
-+ gchar *name;
- FoDatatype *intermediate_value = NULL;
-
- fo_expr_context_skip_blanks (context);
-
-- gchar *name = parse_ncname (context);
-+ name = parse_ncname (context);
-
- if (name != NULL)
- {
-@@ -1902,6 +1908,8 @@
- FoDatatype *width_datatype = NULL;
- FoDatatype *style_datatype = NULL;
- FoDatatype *color_datatype = NULL;
-+ FoDatatype *stack_second;
-+ FoDatatype *stack_third;
-
- /* First stack entry */
- FoDatatype *stack_first = fo_expr_context_pop_stack (context);
-@@ -1941,7 +1949,7 @@
- }
-
- /* Second stack entry */
-- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
-+ stack_second = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for second stack entry. */
- if (stack_second == NULL)
-@@ -1984,7 +1992,7 @@
- }
-
- /* Third stack entry */
-- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
-+ stack_third = fo_expr_context_pop_stack (context);
-
- /* Handle possible conditions for third stack entry. */
- if (stack_third == NULL)
diff --git a/textproc/xmlroff/files/patch-fo-context-util.c b/textproc/xmlroff/files/patch-fo-context-util.c
deleted file mode 100644
index ea5baf2d92ef..000000000000
--- a/textproc/xmlroff/files/patch-fo-context-util.c
+++ /dev/null
@@ -1,173 +0,0 @@
---- fo-context-util.c.orig Mon May 2 04:22:17 2005
-+++ fo-context-util.c Wed Jun 15 01:28:36 2005
-@@ -926,6 +926,8 @@
- FoContextPropertyFunc absolute_func;
- FoContextPropertyFunc relative_func;
- FoDatatype *shorthand_component;
-+ FoDatatype *padding_tblr;
-+ FoProperty *padding;
-
- g_return_if_fail (current_context != NULL);
- g_return_if_fail (parent_context != NULL);
-@@ -937,9 +939,9 @@
- 0);
- */
-
-- FoDatatype *padding_tblr = NULL;
-+ padding_tblr = NULL;
-
-- FoProperty *padding = fo_context_get_padding (current_context);
-+ padding = fo_context_get_padding (current_context);
-
- if (padding != NULL)
- {
-@@ -1207,6 +1209,31 @@
- FoProperty *prop_color;
- FoDatatype *initial_color;
-
-+ FoProperty *border_color;
-+ FoDatatype *border_color_tblr;
-+ FoDatatype *border_color_component;
-+ FoProperty *border_style;
-+ FoDatatype *border_style_tblr;
-+ FoDatatype *border_style_component;
-+ FoProperty *border_width;
-+ FoDatatype *border_width_tblr;
-+ FoDatatype *border_width_component;
-+ FoProperty *border;
-+ FoDatatype *border_wsc;
-+ FoDatatype *border_component;
-+ FoProperty *border_bottom;
-+ FoDatatype *border_bottom_wsc;
-+ FoDatatype *border_bottom_component;
-+ FoProperty *border_left;
-+ FoDatatype *border_left_wsc;
-+ FoDatatype *border_left_component;
-+ FoProperty *border_right;
-+ FoDatatype *border_right_wsc;
-+ FoDatatype *border_right_component;
-+ FoProperty *border_top;
-+ FoDatatype *border_top_wsc;
-+ FoDatatype *border_top_component;
-+
- g_return_if_fail (current_context != NULL);
- g_return_if_fail (parent_context != NULL);
- g_return_if_fail (FO_IS_CONTEXT (current_context));
-@@ -1223,93 +1250,93 @@
-
- initial_color = fo_property_get_value (prop_color);
-
-- FoProperty *border_color = fo_context_get_border_color (current_context);
-+ border_color = fo_context_get_border_color (current_context);
-
-- FoDatatype *border_color_tblr = NULL;
-+ border_color_tblr = NULL;
-
- if (border_color != NULL)
- {
- border_color_tblr = fo_property_get_value (border_color);
- }
-
-- FoDatatype *border_color_component;
-+ border_color_component;
-
-- FoProperty *border_style = fo_context_get_border_style (current_context);
-+ border_style = fo_context_get_border_style (current_context);
-
-- FoDatatype *border_style_tblr = NULL;
-+ border_style_tblr = NULL;
-
- if (border_style != NULL)
- {
- border_style_tblr = fo_property_get_value (border_style);
- }
-
-- FoDatatype *border_style_component;
-+ border_style_component;
-
-- FoProperty *border_width = fo_context_get_border_width (current_context);
-+ border_width = fo_context_get_border_width (current_context);
-
-- FoDatatype *border_width_tblr = NULL;
-+ border_width_tblr = NULL;
-
- if (border_width != NULL)
- {
- border_width_tblr = fo_property_get_value (border_width);
- }
-
-- FoDatatype *border_width_component;
-+ border_width_component;
-
-- FoProperty *border = fo_context_get_border (current_context);
-+ border = fo_context_get_border (current_context);
-
-- FoDatatype *border_wsc = NULL;
-+ border_wsc = NULL;
-
- if (border != NULL)
- {
- border_wsc = fo_property_get_value (border);
- }
-
-- FoDatatype *border_component;
-+ border_component;
-
-- FoProperty *border_bottom = fo_context_get_border_bottom (current_context);
-+ border_bottom = fo_context_get_border_bottom (current_context);
-
-- FoDatatype *border_bottom_wsc = NULL;
-+ border_bottom_wsc = NULL;
-
- if (border_bottom != NULL)
- {
- border_bottom_wsc = fo_property_get_value (border_bottom);
- }
-
-- FoDatatype *border_bottom_component;
-+ border_bottom_component;
-
-- FoProperty *border_left = fo_context_get_border_left (current_context);
-+ border_left = fo_context_get_border_left (current_context);
-
-- FoDatatype *border_left_wsc = NULL;
-+ border_left_wsc = NULL;
-
- if (border_left != NULL)
- {
- border_left_wsc = fo_property_get_value (border_left);
- }
-
-- FoDatatype *border_left_component;
-+ border_left_component;
-
-- FoProperty *border_right = fo_context_get_border_right (current_context);
-+ border_right = fo_context_get_border_right (current_context);
-
-- FoDatatype *border_right_wsc = NULL;
-+ border_right_wsc = NULL;
-
- if (border_right != NULL)
- {
- border_right_wsc = fo_property_get_value (border_right);
- }
-
-- FoDatatype *border_right_component;
-+ border_right_component;
-
-- FoProperty *border_top = fo_context_get_border_top (current_context);
-+ border_top = fo_context_get_border_top (current_context);
-
-- FoDatatype *border_top_wsc = NULL;
-+ border_top_wsc = NULL;
-
- if (border_top != NULL)
- {
- border_top_wsc = fo_property_get_value (border_top);
- }
-
-- FoDatatype *border_top_component;
-+ border_top_component;
-
- /* left = start*/
- /* style */
diff --git a/textproc/xmlroff/files/patch-fo-fo-block-area.c b/textproc/xmlroff/files/patch-fo-fo-block-area.c
deleted file mode 100644
index e261d8bf0d2c..000000000000
--- a/textproc/xmlroff/files/patch-fo-fo-block-area.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- fo/fo-block-area.c.orig Mon Jan 30 21:55:41 2006
-+++ fo/fo-block-area.c Mon Jan 30 21:56:28 2006
-@@ -222,6 +222,7 @@
- GSList *line_heights = NULL;
- gint line_count, line_index;
- gint cumulative_height = 0;
-+ gchar *font_family = NULL;
-
- g_return_if_fail (block != NULL);
- g_return_if_fail (FO_IS_BLOCK (block));
-@@ -312,7 +313,7 @@
- font_desc =
- fo_font_desc_copy (fo_doc_get_font_desc (fo_doc));
-
-- gchar *font_family = fo_string_get_value (fo_property_get_value (fo_block_get_font_family (block)));
-+ font_family = fo_string_get_value (fo_property_get_value (fo_block_get_font_family (block)));
- fo_font_desc_set_family (font_desc, font_family);
- g_free (font_family);
-
diff --git a/textproc/xmlroff/files/patch-fo-fo-fo.c b/textproc/xmlroff/files/patch-fo-fo-fo.c
deleted file mode 100644
index da4a101bb1e9..000000000000
--- a/textproc/xmlroff/files/patch-fo-fo-fo.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- fo/fo-fo.c.orig Sat Aug 19 01:29:53 2006
-+++ fo/fo-fo.c Sat Aug 19 01:30:44 2006
-@@ -1213,6 +1213,8 @@
- while (iterator)
- {
- FoProperty *property = NULL;
-+ FoPropertyClass *property_class = NULL;
-+ FoTypeFunc type_func;
-
- /* Skip processing attributes that have already been handled. */
- if (strcmp (xslAttrListIteratorName (iterator), "font-size") == 0 ||
-@@ -1234,8 +1236,8 @@
- }
- }
-
-- FoPropertyClass *property_class = NULL;
-- FoTypeFunc type_func =
-+ property_class = NULL;
-+ type_func =
- g_hash_table_lookup (prop_eval_hash,
- xslAttrListIteratorName (iterator));
-
diff --git a/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c b/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c
deleted file mode 100644
index c5cbd35bbea7..000000000000
--- a/textproc/xmlroff/files/patch-fo-fo-repeatable-page-master-alternatives.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- fo/fo-repeatable-page-master-alternatives.c.orig Mon Jan 30 21:58:24 2006
-+++ fo/fo-repeatable-page-master-alternatives.c Mon Jan 30 21:58:43 2006
-@@ -131,12 +131,13 @@
- GError **error)
- {
- GError *tmp_error = NULL;
-+ FoNode *child_node = NULL;
-
- g_return_val_if_fail (fo != NULL, TRUE);
- g_return_val_if_fail (FO_IS_REPEATABLE_PAGE_MASTER_ALTERNATIVES (fo), TRUE);
- g_return_val_if_fail (error == NULL || *error == NULL, TRUE);
-
-- FoNode *child_node = fo_node_first_child (FO_NODE (fo));
-+ child_node = fo_node_first_child (FO_NODE (fo));
-
- while (child_node)
- {
diff --git a/textproc/xmlroff/files/patch-fo-fo-table.c b/textproc/xmlroff/files/patch-fo-fo-table.c
deleted file mode 100644
index 2c95040f7263..000000000000
--- a/textproc/xmlroff/files/patch-fo-fo-table.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- fo/fo-table.c.orig Mon Jan 30 21:59:46 2006
-+++ fo/fo-table.c Mon Jan 30 22:00:08 2006
-@@ -1700,6 +1700,7 @@
- FoDatatype *column_proportional = NULL;
- FoContext *parent_context = NULL;
- GError *tmp_error = NULL;
-+ gchar *string_value = NULL;
-
- g_return_val_if_fail (error == NULL || *error == NULL, NULL);
-
-@@ -1715,7 +1716,7 @@
- parent_context =
- fo_fo_get_context (FO_FO (fo_node_parent (FO_NODE (table_column))));
-
-- gchar *string_value = fo_string_get_value (column_width_string);
-+ string_value = fo_string_get_value (column_width_string);
- column_proportional =
- fo_expr_eval (string_value,
- "column-width",
diff --git a/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c b/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c
deleted file mode 100644
index d22088db10ae..000000000000
--- a/textproc/xmlroff/files/patch-libfo::fo-doc-gp.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- libfo/fo-doc-gp.c.orig Sun Jul 23 05:13:09 2006
-+++ libfo/fo-doc-gp.c Sat Aug 19 01:26:49 2006
-@@ -1237,6 +1237,7 @@
- gint y)
- {
- PangoLayoutIter *iter;
-+ gint line_number = -1;
-
- g_return_if_fail (context != NULL);
- g_return_if_fail (PANGO_IS_LAYOUT (layout));
-@@ -1245,7 +1246,6 @@
-
- iter = pango_layout_get_iter (layout);
-
-- gint line_number = -1;
- do
- {
- PangoRectangle logical_rect;
-@@ -1296,6 +1296,9 @@
- gdouble x,
- gdouble y)
- {
-+ gdouble x1, x2, y1, y2;
-+ guint line_first, line_last;
-+
- g_return_if_fail (FO_IS_DOC_GP (fo_doc));
- g_return_if_fail (FO_DOC_GP (fo_doc)->context != NULL);
- g_return_if_fail (FO_IS_AREA_LAYOUT (area_layout));
-@@ -1307,9 +1310,9 @@
- * lines that are to be rendered.
- */
-
-- gdouble y1 = y;
-+ y1 = y;
-
-- guint line_first = fo_area_layout_get_line_first (area_layout);
-+ line_first = fo_area_layout_get_line_first (area_layout);
- if (line_first > 0)
- {
- y1 =
-@@ -1317,12 +1320,12 @@
- line_first - 1);
- }
-
-- guint line_last = fo_area_layout_get_line_last (area_layout);
-- gdouble y2 =
-+ line_last = fo_area_layout_get_line_last (area_layout);
-+ y2 =
- y1 - fo_area_layout_get_line_height (area_layout,
- line_last);
-
-- gdouble x2 =
-+ x2 =
- x + fo_area_area_get_width (area_layout);
-
- #if ENABLE_CLIP
diff --git a/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c b/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c
deleted file mode 100644
index 7d4e8d583cb1..000000000000
--- a/textproc/xmlroff/files/patch-property-fo-property-dominant-baseline.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- property/fo-property-dominant-baseline.c.orig Mon Jan 30 22:02:19 2006
-+++ property/fo-property-dominant-baseline.c Mon Jan 30 22:03:47 2006
-@@ -453,12 +453,15 @@
-
- if (dominant_baseline != FO_ENUM_ENUM_RESET_SIZE)
- {
-+ gchar *font_family = NULL;
-+ PangoAttribute *pango_attr = NULL;
-+
- PangoBaseline pango_dominant_baseline =
- fo_property_dominant_baseline_to_pango_baseline (dominant_baseline);
-
- font_desc = pango_font_description_new ();
-
-- gchar *font_family = fo_string_get_value (fo_property_get_value (fo_context_get_font_family (context)));
-+ font_family = fo_string_get_value (fo_property_get_value (fo_context_get_font_family (context)));
- pango_font_description_set_family (font_desc, font_family);
- g_free (font_family);
-
-@@ -473,7 +476,7 @@
- pango_font_description_set_variant (font_desc,
- fo_enum_get_value (fo_property_get_value (fo_context_get_font_variant (context))));
-
-- PangoAttribute *pango_attr = pango_attr_dominant_baseline_new (pango_dominant_baseline,
-+ pango_attr = pango_attr_dominant_baseline_new (pango_dominant_baseline,
- font_desc);
- pango_font_description_free (font_desc);
- return pango_attr;
diff --git a/textproc/xmlroff/files/patch-property-fo-property-font-family.c b/textproc/xmlroff/files/patch-property-fo-property-font-family.c
deleted file mode 100644
index 91f22eaf4f0f..000000000000
--- a/textproc/xmlroff/files/patch-property-fo-property-font-family.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- property/fo-property-font-family.c.orig Mon Jan 30 23:43:52 2006
-+++ property/fo-property-font-family.c Mon Jan 30 23:45:58 2006
-@@ -475,13 +475,14 @@
- fo_property_font_family_new_attr (FoProperty *property)
- {
- gchar *pango_font_family;
-+ PangoAttribute *pango_attr = NULL;
-
- g_return_val_if_fail (FO_IS_PROPERTY_FONT_FAMILY (property), NULL);
-
- pango_font_family =
- fo_string_get_value (property->value);
-
-- PangoAttribute *pango_attr = pango_attr_family_new (pango_font_family);
-+ pango_attr = pango_attr_family_new (pango_font_family);
-
- g_free (pango_font_family);
-
diff --git a/textproc/xmlroff/files/patch-property-fo-property-id.c b/textproc/xmlroff/files/patch-property-fo-property-id.c
deleted file mode 100644
index ba2932843720..000000000000
--- a/textproc/xmlroff/files/patch-property-fo-property-id.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- property/fo-property-id.c.orig Mon Jan 30 23:46:23 2006
-+++ property/fo-property-id.c Mon Jan 30 23:46:44 2006
-@@ -262,10 +262,11 @@
- {
- static int count = 1;
- FoProperty *id;
-+ gchar *id_string = NULL;
-
- id = fo_property_id_new ();
-
-- gchar * id_string = g_strdup_printf ("id-%d",
-+ id_string = g_strdup_printf ("id-%d",
- count++);
- /* Set the initial value here */
- fo_property_set_value (id,
diff --git a/textproc/xmlroff/files/patch-property::fo-property-util.c b/textproc/xmlroff/files/patch-property::fo-property-util.c
deleted file mode 100644
index b18f0139cde6..000000000000
--- a/textproc/xmlroff/files/patch-property::fo-property-util.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- property/fo-property-util.c.orig Tue Apr 26 04:09:35 2005
-+++ property/fo-property-util.c Tue Jun 14 22:22:38 2005
-@@ -1866,6 +1866,8 @@
- FoContext *context,
- GError **error)
- {
-+ FoDatatype *new_style;
-+ FoDatatype *new_color;
- g_return_val_if_fail (datatype != NULL, NULL);
- g_return_val_if_fail (FO_IS_DATATYPE (datatype), NULL);
- g_return_val_if_fail (context != NULL, NULL);
-@@ -1886,7 +1888,7 @@
- return NULL;
- }
-
-- FoDatatype *new_style =
-+ new_style =
- fo_property_util_validate_style (fo_wsc_get_style (datatype),
- context,
- &tmp_error);
-@@ -1897,7 +1899,7 @@
- return NULL;
- }
-
-- FoDatatype *new_color =
-+ new_color =
- fo_property_util_validate_color_transparent (fo_wsc_get_color (datatype),
- context,
- &tmp_error);
diff --git a/textproc/xmlroff/pkg-plist b/textproc/xmlroff/pkg-plist
index 90b1f01e60d2..e42dc0ebf18a 100644
--- a/textproc/xmlroff/pkg-plist
+++ b/textproc/xmlroff/pkg-plist
@@ -1,46 +1,45 @@
@comment $FreeBSD$
bin/xmlroff
-include/libfo-0.5/area/fo-area.h
-include/libfo-0.5/datatype/fo-datatype.h
-include/libfo-0.5/datatype/fo-enum.h
-include/libfo-0.5/fo-context.h
-include/libfo-0.5/fo-node.h
-include/libfo-0.5/fo-object.h
-include/libfo-0.5/fo/fo-fo.h
-include/libfo-0.5/libfo/fo-doc-cairo-private.h
+include/libfo-0.5/libfo/area/fo-area.h
+include/libfo-0.5/libfo/fo/fo-fo.h
+include/libfo-0.5/libfo/datatype/fo-datatype.h
+include/libfo-0.5/libfo/datatype/fo-enum.h
+include/libfo-0.5/libfo/property/fo-property.h
+include/libfo-0.5/libfo/util/fo-hash-table.h
+include/libfo-0.5/libfo/util/fo-image.h
+include/libfo-0.5/libfo/util/fo-pixbuf.h
+include/libfo-0.5/libfo/fo-object.h
+include/libfo-0.5/libfo/fo-node.h
+include/libfo-0.5/libfo/fo-context.h
include/libfo-0.5/libfo/fo-doc-cairo.h
-include/libfo-0.5/libfo/fo-doc-gp-private.h
+include/libfo-0.5/libfo/fo-doc-cairo-private.h
+include/libfo-0.5/libfo/fo-layout-cairo.h
+include/libfo-0.5/libfo/fo-layout-cairo-private.h
include/libfo-0.5/libfo/fo-doc-gp.h
-include/libfo-0.5/libfo/fo-doc-private.h
+include/libfo-0.5/libfo/fo-doc-gp-private.h
+include/libfo-0.5/libfo/fo-layout-gp.h
+include/libfo-0.5/libfo/fo-layout-gp-private.h
include/libfo-0.5/libfo/fo-doc.h
-include/libfo-0.5/libfo/fo-font-desc-private.h
+include/libfo-0.5/libfo/fo-doc-private.h
+include/libfo-0.5/libfo/fo-utils.h
include/libfo-0.5/libfo/fo-font-desc.h
-include/libfo-0.5/libfo/fo-layout-cairo-private.h
-include/libfo-0.5/libfo/fo-layout-cairo.h
-include/libfo-0.5/libfo/fo-layout-gp-private.h
-include/libfo-0.5/libfo/fo-layout-gp.h
-include/libfo-0.5/libfo/fo-layout-private.h
include/libfo-0.5/libfo/fo-layout.h
+include/libfo-0.5/libfo/fo-font-desc-private.h
+include/libfo-0.5/libfo/fo-layout-private.h
+include/libfo-0.5/libfo/fo-libfo.h
include/libfo-0.5/libfo/fo-libfo-basic.h
include/libfo-0.5/libfo/fo-libfo-context.h
-include/libfo-0.5/libfo/fo-libfo.h
-include/libfo-0.5/libfo/fo-utils.h
include/libfo-0.5/libfo/fo-xml-doc-private.h
include/libfo-0.5/libfo/fo-xml-doc.h
include/libfo-0.5/libfo/fo-xml-node-private.h
include/libfo-0.5/libfo/fo-xml-node.h
-include/libfo-0.5/libfo/fo-xsl-formatter.c
include/libfo-0.5/libfo/fo-xsl-formatter.h
include/libfo-0.5/libfo/fo-xslt-transformer.h
include/libfo-0.5/libfo/libfo-compat.h
-include/libfo-0.5/property/fo-property.h
-include/libfo-0.5/util/fo-hash-table.h
-include/libfo-0.5/util/fo-image.h
-include/libfo-0.5/util/fo-pixbuf.h
lib/libfo-0.5.a
lib/libfo-0.5.la
lib/libfo-0.5.so
-lib/libfo-0.5.so.500
+lib/libfo-0.5.so.502
libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/FoArea.html
%%DOCSDIR%%/FoAreaArea.html
@@ -67,6 +66,7 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/FoBlockWhitespace.html
%%DOCSDIR%%/FoBoolean.html
%%DOCSDIR%%/FoChar.html
+%%DOCSDIR%%/FoCharacter.html
%%DOCSDIR%%/FoColor.html
%%DOCSDIR%%/FoContext.html
%%DOCSDIR%%/FoDatatype.html
@@ -98,13 +98,13 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/FoTree.html
%%DOCSDIR%%/FoUnknown.html
%%DOCSDIR%%/FoUriSpecification.html
+%%DOCSDIR%%/FoWrapper.html
%%DOCSDIR%%/FoWrapperBlock.html
%%DOCSDIR%%/FoWrapperInline.html
%%DOCSDIR%%/FoWrapperWhitespace.html
%%DOCSDIR%%/areas.html
%%DOCSDIR%%/backends.html
%%DOCSDIR%%/basic-interface.html
-%%DOCSDIR%%/block.html
%%DOCSDIR%%/ch02.html
%%DOCSDIR%%/conformance.html
%%DOCSDIR%%/context.html
@@ -114,9 +114,9 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/fo-area-c-file.html
%%DOCSDIR%%/fo-c-file.html
%%DOCSDIR%%/fo-h-file.html
+%%DOCSDIR%%/home.png
%%DOCSDIR%%/formatting-objects.html
%%DOCSDIR%%/generating-source.html
-%%DOCSDIR%%/home.png
%%DOCSDIR%%/index.html
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/interfaces.html
@@ -132,8 +132,8 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/utility-modules.html
%%DOCSDIR%%/utility-objects.html
%%DOCSDIR%%/xmlroff-Additional-Pango-attributes-needed-by-LibFO.html
-%%DOCSDIR%%/xmlroff-FoCharacter.html
%%DOCSDIR%%/xmlroff-FoDoc.html
+%%DOCSDIR%%/xmlroff-FoPcw.html
%%DOCSDIR%%/xmlroff-FoDocCairo.html
%%DOCSDIR%%/xmlroff-FoDocGP.html
%%DOCSDIR%%/xmlroff-FoError.html
@@ -143,10 +143,8 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-FoLayoutCairo.html
%%DOCSDIR%%/xmlroff-FoLibfoContext.html
%%DOCSDIR%%/xmlroff-FoNeutralFoIface.html
-%%DOCSDIR%%/xmlroff-FoPcw.html
%%DOCSDIR%%/xmlroff-FoPixbuf.html
%%DOCSDIR%%/xmlroff-FoTblr.html
-%%DOCSDIR%%/xmlroff-FoWrapper.html
%%DOCSDIR%%/xmlroff-FoWrapperInlineEmpty.html
%%DOCSDIR%%/xmlroff-FoWsc.html
%%DOCSDIR%%/xmlroff-FoXmlDoc.html
@@ -163,6 +161,7 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-bidi-override.html
%%DOCSDIR%%/xmlroff-block-container.html
%%DOCSDIR%%/xmlroff-block-progression-dimension.html
+%%DOCSDIR%%/xmlroff-block.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionmaximum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionminimum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionoptimum.html
@@ -173,11 +172,11 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-border-before-color.html
%%DOCSDIR%%/xmlroff-border-before-precedence.html
%%DOCSDIR%%/xmlroff-border-before-style.html
+%%DOCSDIR%%/xmlroff-border-bottom.html
%%DOCSDIR%%/xmlroff-border-before-width.html
%%DOCSDIR%%/xmlroff-border-bottom-color.html
%%DOCSDIR%%/xmlroff-border-bottom-style.html
%%DOCSDIR%%/xmlroff-border-bottom-width.html
-%%DOCSDIR%%/xmlroff-border-bottom.html
%%DOCSDIR%%/xmlroff-border-collapse.html
%%DOCSDIR%%/xmlroff-border-end-color.html
%%DOCSDIR%%/xmlroff-border-end-precedence.html
@@ -198,9 +197,9 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-border-start-width.html
%%DOCSDIR%%/xmlroff-border-style.html
%%DOCSDIR%%/xmlroff-border-top-color.html
+%%DOCSDIR%%/xmlroff-border-top.html
%%DOCSDIR%%/xmlroff-border-top-style.html
%%DOCSDIR%%/xmlroff-border-top-width.html
-%%DOCSDIR%%/xmlroff-border-top.html
%%DOCSDIR%%/xmlroff-border-width.html
%%DOCSDIR%%/xmlroff-border.html
%%DOCSDIR%%/xmlroff-break-after.html
@@ -227,6 +226,7 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-flow.html
%%DOCSDIR%%/xmlroff-fo-area-graphic.html
%%DOCSDIR%%/xmlroff-fo-area-inline.html
+%%DOCSDIR%%/xmlroff-font-size.html
%%DOCSDIR%%/xmlroff-fo-doc-commands.html
%%DOCSDIR%%/xmlroff-fo-layout-gp.html
%%DOCSDIR%%/xmlroff-fo-libfo-basic.html
@@ -234,7 +234,6 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-fo-property-border-color.html
%%DOCSDIR%%/xmlroff-fo-retrieve-marker.html
%%DOCSDIR%%/xmlroff-font-family.html
-%%DOCSDIR%%/xmlroff-font-size.html
%%DOCSDIR%%/xmlroff-font-stretch.html
%%DOCSDIR%%/xmlroff-font-style.html
%%DOCSDIR%%/xmlroff-font-variant.html
@@ -253,8 +252,8 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-inline-progression-dimensionminimum.html
%%DOCSDIR%%/xmlroff-inline-progression-dimensionoptimum.html
%%DOCSDIR%%/xmlroff-inline.html
-%%DOCSDIR%%/xmlroff-instream-foreign-object.html
%%DOCSDIR%%/xmlroff-keep-together.html
+%%DOCSDIR%%/xmlroff-instream-foreign-object.html
%%DOCSDIR%%/xmlroff-keep-togetherwithin-column.html
%%DOCSDIR%%/xmlroff-keep-togetherwithin-line.html
%%DOCSDIR%%/xmlroff-keep-togetherwithin-page.html
@@ -264,9 +263,9 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-keep-with-nextwithin-page.html
%%DOCSDIR%%/xmlroff-keep-with-previous.html
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-column.html
+%%DOCSDIR%%/xmlroff-layout-master-set.html
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-line.html
%%DOCSDIR%%/xmlroff-keep-with-previouswithin-page.html
-%%DOCSDIR%%/xmlroff-layout-master-set.html
%%DOCSDIR%%/xmlroff-leader.html
%%DOCSDIR%%/xmlroff-letter-value.html
%%DOCSDIR%%/xmlroff-line-height.html
@@ -379,16 +378,16 @@ libdata/pkgconfig/libfo-0.5.pc
%%DOCSDIR%%/xmlroff-writing-mode.html
%%DOCSDIR%%/xmlroff.devhelp
%%DOCSDIR%%/xmlroff.devhelp2
-share/xml/libfo-0.5.0/catalog.xml
-share/xml/libfo-0.5.0/libfo-compat.xsl
-share/xml/libfo-0.5.0/xmlroff.fo
-share/xml/libfo-0.5.0/xmlroff.xml
-@dirrm share/xml/libfo-0.5.0
+share/xml/libfo-0.5.2/catalog.xml
+share/xml/libfo-0.5.2/libfo-compat.xsl
+share/xml/libfo-0.5.2/xmlroff.fo
+share/xml/libfo-0.5.2/xmlroff.xml
+@dirrm share/xml/libfo-0.5.2
@dirrm %%DOCSDIR%%
-@dirrm include/libfo-0.5/util
-@dirrm include/libfo-0.5/property
+@dirrm include/libfo-0.5/libfo/util
+@dirrm include/libfo-0.5/libfo/property
+@dirrm include/libfo-0.5/libfo/fo
+@dirrm include/libfo-0.5/libfo/datatype
+@dirrm include/libfo-0.5/libfo/area
@dirrm include/libfo-0.5/libfo
-@dirrm include/libfo-0.5/fo
-@dirrm include/libfo-0.5/datatype
-@dirrm include/libfo-0.5/area
@dirrm include/libfo-0.5