aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlstarlet
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-30 02:29:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-30 02:29:25 +0000
commitd751cb4de210ff40f3ea0cc66bec026c40af5abe (patch)
treebc3ac9053248724440749cfc67f43568c1152cfc /textproc/xmlstarlet
parent2209426c72f32298a9bd2829c0815d287b7aa011 (diff)
downloadports-d751cb4de210ff40f3ea0cc66bec026c40af5abe.tar.gz
ports-d751cb4de210ff40f3ea0cc66bec026c40af5abe.zip
add xmlstarlet 0.9.1
Command Line XML Toolkit
Notes
Notes: svn path=/head/; revision=112573
Diffstat (limited to 'textproc/xmlstarlet')
-rw-r--r--textproc/xmlstarlet/Makefile34
-rw-r--r--textproc/xmlstarlet/distinfo2
-rw-r--r--textproc/xmlstarlet/pkg-descr10
3 files changed, 46 insertions, 0 deletions
diff --git a/textproc/xmlstarlet/Makefile b/textproc/xmlstarlet/Makefile
new file mode 100644
index 000000000000..3b357f0e54f6
--- /dev/null
+++ b/textproc/xmlstarlet/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: xmlstartlet
+# Date created: Jun 30, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlstarlet
+PORTVERSION= 0.9.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmlstar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Command Line XML Toolkit
+
+USE_REINPLACE= yes
+USE_ICONV= yes
+USE_GNOME= libxml2 libxslt
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libxml-prefix=${LOCALBASE} \
+ --with-libxslt-prefix=${LOCALBASE} \
+ --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -liconv"
+
+PLIST_FILES= bin/xml
+MAN1= xmlstarlet.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS," \
+ -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlstarlet/distinfo b/textproc/xmlstarlet/distinfo
new file mode 100644
index 000000000000..b7e861f187bf
--- /dev/null
+++ b/textproc/xmlstarlet/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmlstarlet-0.9.1.tar.gz) = 62bc68b2d0c8fc688d1c3d999adc3a7a
+SIZE (xmlstarlet-0.9.1.tar.gz) = 300459
diff --git a/textproc/xmlstarlet/pkg-descr b/textproc/xmlstarlet/pkg-descr
new file mode 100644
index 000000000000..2e0d4c9649d9
--- /dev/null
+++ b/textproc/xmlstarlet/pkg-descr
@@ -0,0 +1,10 @@
+XMLStarlet is a set of command line utilities (tools) which can be used to
+transform, query, validate, and edit XML documents and files using simple set
+of shell commands in similar way it is done for plain text files using UNIX
+grep, sed, awk, diff, patch, join, etc commands.
+
+This set of command line utilities can be used by those who deal with many XML
+documents on UNIX shell command prompt as well as for automated XML processing
+with shell scripts.
+
+WWW: http://xmlstar.sourceforge.net/