aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-01-03 21:30:57 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-01-03 21:30:57 +0000
commitd4f420056d1f6dd8baf53d87e85da2e015a13e91 (patch)
tree10ed10f3f74108513cf86b4a5eb1154f9af92c22 /textproc
parentf89c03e9662f43b2e2139e05fe658486f2ccbff1 (diff)
downloadports-d4f420056d1f6dd8baf53d87e85da2e015a13e91.tar.gz
ports-d4f420056d1f6dd8baf53d87e85da2e015a13e91.zip
Add enchant, a backend dictionary broker. It provides a framework for
interfacing with various pre-existing dictionary programs.
Notes
Notes: svn path=/head/; revision=97253
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/enchant/Makefile70
-rw-r--r--textproc/enchant/distinfo1
-rw-r--r--textproc/enchant/files/patch-configure10
-rw-r--r--textproc/enchant/pkg-descr4
-rw-r--r--textproc/enchant/pkg-plist19
6 files changed, 105 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 309f13daf1fd..336da0609829 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -79,6 +79,7 @@
SUBDIR += dtdparse
SUBDIR += easydiff
SUBDIR += el-aspell
+ SUBDIR += enchant
SUBDIR += eo-aspell
SUBDIR += eruby
SUBDIR += es-aspell
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
new file mode 100644
index 000000000000..d1707f382b15
--- /dev/null
+++ b/textproc/enchant/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: enchant
+# Date created: 03 January 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= enchant
+PORTVERSION= 1.1.2
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= abiword
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Dictionary/spellchecking framework
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget glib20
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= enchant.1
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libpspell.so)
+WITH_ASPELL= yes
+.endif
+
+.if exists(${LOCALBASE}/bin/ispell)
+WITH_ISPELL= yes
+.endif
+
+.if exists(${LOCALBASE}/bin/hspell)
+WITH_HSPELL= yes
+.endif
+
+.if defined(WITH_ASPELL)
+LIB_DEPENDS+= pspell.15:${PORTSDIR}/textproc/aspell
+.endif
+
+.if defined(WITH_ISPELL)
+BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.endif
+
+.if defined(WITH_HSPELL)
+BUILD_DEPENDS+= hspell:${PORTSDIR}/hebrew/hspell
+.endif
+
+pre-everything::
+.if !defined(WITH_ASPELL) || !defined(WITH_ISPELL) || !defined(WITH_HSPELL)
+ @${ECHO_CMD} '===> The following options are available for this port:'
+.if !defined(WITH_ASPELL)
+ @${ECHO_CMD} '===>'
+ @${ECHO_CMD} '===> Define WITH_ASPELL to enable aspell support'
+.endif
+.if !defined(WITH_ISPELL)
+ @${ECHO_CMD} '===>'
+ @${ECHO_CMD} '===> Define WITH_ISPELL to enable ispell support'
+.endif
+.if !defined(WITH_HSPELL)
+ @${ECHO_CMD} '===>'
+ @${ECHO_CMD} '===> Define WITH_HSPELL to enable hspell (Hebrew) support'
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/enchant/distinfo b/textproc/enchant/distinfo
new file mode 100644
index 000000000000..e7a888be5e4d
--- /dev/null
+++ b/textproc/enchant/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/enchant-1.1.2.tar.gz) = 0d05bd7480382d4189b82111b727263d
diff --git a/textproc/enchant/files/patch-configure b/textproc/enchant/files/patch-configure
new file mode 100644
index 000000000000..00d91c4518c9
--- /dev/null
+++ b/textproc/enchant/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Jan 3 16:19:57 2004
++++ configure Sat Jan 3 16:20:35 2004
+@@ -8164,6 +8164,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/textproc/enchant/pkg-descr b/textproc/enchant/pkg-descr
new file mode 100644
index 000000000000..78a84838fbc2
--- /dev/null
+++ b/textproc/enchant/pkg-descr
@@ -0,0 +1,4 @@
+Enchant is a dictionary backend. It's somewhat of a broker of various
+pre-existing spellchecking programs.
+
+WWW: http://www.abisource.com/enchant/
diff --git a/textproc/enchant/pkg-plist b/textproc/enchant/pkg-plist
new file mode 100644
index 000000000000..46eb3fe08383
--- /dev/null
+++ b/textproc/enchant/pkg-plist
@@ -0,0 +1,19 @@
+bin/enchant
+bin/enchant-lsmod
+include/enchant/enchant++.h
+include/enchant/enchant-provider.h
+include/enchant/enchant.h
+lib/enchant/libenchant_aspell.a
+lib/enchant/libenchant_aspell.so
+lib/enchant/libenchant_aspell.so.2
+lib/enchant/libenchant_ispell.a
+lib/enchant/libenchant_ispell.so
+lib/enchant/libenchant_ispell.so.2
+lib/enchant/libenchant_myspell.a
+lib/enchant/libenchant_myspell.so
+lib/enchant/libenchant_myspell.so.2
+lib/libenchant.a
+lib/libenchant.so.2
+libdata/pkgconfig/enchant.pc
+@dirrm lib/enchant
+@dirrm include/enchant