aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-05-03 05:12:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-05-03 05:12:46 +0000
commiteb1767a0a8dfae6c9f0584cb26c0d0bd93248c24 (patch)
tree2d16735d2297d617505ecefef58f9576cbae404d /textproc
parent0ce43521240046ec851976d31dd2f158adc352f6 (diff)
downloadports-eb1767a0a8dfae6c9f0584cb26c0d0bd93248c24.tar.gz
ports-eb1767a0a8dfae6c9f0584cb26c0d0bd93248c24.zip
Try to unbreak on 4.x.
Based on: hrs's patch
Notes
Notes: svn path=/head/; revision=108242
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-XML-AutoWriter/Makefile9
-rw-r--r--textproc/p5-XML-AutoWriter/files/patch-Doctype.pm12
2 files changed, 20 insertions, 1 deletions
diff --git a/textproc/p5-XML-AutoWriter/Makefile b/textproc/p5-XML-AutoWriter/Makefile
index 2b7c795e7799..b6028b834342 100644
--- a/textproc/p5-XML-AutoWriter/Makefile
+++ b/textproc/p5-XML-AutoWriter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML-AutoWriter
PORTVERSION= 0.38
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@@ -23,4 +24,10 @@ MAN3= XML::AutoWriter.3 \
XML::Doctype::ElementDecl.3 \
XML::Doctype.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS= ${SITE_PERL}/fields.pm:${PORTSDIR}/devel/p5-base
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-AutoWriter/files/patch-Doctype.pm b/textproc/p5-XML-AutoWriter/files/patch-Doctype.pm
new file mode 100644
index 000000000000..35d6151149c4
--- /dev/null
+++ b/textproc/p5-XML-AutoWriter/files/patch-Doctype.pm
@@ -0,0 +1,12 @@
+--- lib/XML/Doctype.pm.orig Mon May 3 13:57:15 2004
++++ lib/XML/Doctype.pm Mon May 3 14:04:55 2004
+@@ -62,7 +62,9 @@
+ =cut
+
+ use strict ;
++use Config;
+ use vars qw( $VERSION %_default_dtds ) ;
++use lib $Config{sitelib};
+ use fields (
+ 'ELTS', # A hash of declared & undeclared elements, keyed by name
+ 'NAME', # The root node (the name from the DOCTYPE decl).