aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /textproc
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cdif/Makefile10
-rw-r--r--textproc/man2html/Makefile6
-rw-r--r--textproc/man2html/files/patch-man.cgi6
-rw-r--r--textproc/sarep/Makefile9
4 files changed, 9 insertions, 22 deletions
diff --git a/textproc/cdif/Makefile b/textproc/cdif/Makefile
index 309234d95baa..9f72be513618 100644
--- a/textproc/cdif/Makefile
+++ b/textproc/cdif/Makefile
@@ -10,7 +10,8 @@ EXTRACT_SUFX= # empty
MAINTAINER= sanpei@FreeBSD.org
COMMENT= Word context diff
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${DISTNAME}
NO_WRKSUBDIR= yes
NO_BUILD= yes
@@ -18,12 +19,7 @@ NO_BUILD= yes
PLIST_FILES= bin/cdif
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}.dist
-
-do-patch:
- ${SED} -e '1s@/usr/local/bin/perl@${PERL}@' \
- < ${WRKSRC}/${DISTNAME}.dist > ${WRKSRC}/${DISTNAME}
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/cdif
diff --git a/textproc/man2html/Makefile b/textproc/man2html/Makefile
index da5790a0308c..24cbc655ebbb 100644
--- a/textproc/man2html/Makefile
+++ b/textproc/man2html/Makefile
@@ -3,7 +3,7 @@
PORTNAME= man2html
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://hydra.nac.uci.edu/indiv/ehood/tar/ \
ftp://ftp.cpan.org/pub/CPAN/modules/by-authors/Earl_Hood/ \
@@ -20,10 +20,6 @@ CGIDIR= ${PREFIX}/www/cgi-bin
PLIST_FILES= bin/man2html man/man1/man2html.1.gz www/cgi-bin/man.cgi
-post-patch:
- ${REINPLACE_CMD} -e "s#/usr/local/bin/perl#${PERL5}#" ${WRKSRC}/man2html
- ${REINPLACE_CMD} -e "s#/usr/bin/perl5.00503#${PERL5}#" ${WRKSRC}/man.cgi
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/man2html ${STAGEDIR}/${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/man2html.1 ${STAGEDIR}/${PREFIX}/man/man1
diff --git a/textproc/man2html/files/patch-man.cgi b/textproc/man2html/files/patch-man.cgi
index 323a2425df80..e61412256bb8 100644
--- a/textproc/man2html/files/patch-man.cgi
+++ b/textproc/man2html/files/patch-man.cgi
@@ -1,11 +1,5 @@
--- man.cgi.orig Wed Aug 13 01:19:18 1997
+++ man.cgi Sat Sep 30 00:46:55 2000
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/perl
-+#!/usr/bin/perl5.00503
- ##---------------------------------------------------------------------------##
- ## File:
- ## @(#) man.cgi 1.2 97/08/12 12:58:26 @(#)
@@ -59,8 +59,8 @@
## systems. If using Tom Christiansen's Perl man program, than
## define use "".
diff --git a/textproc/sarep/Makefile b/textproc/sarep/Makefile
index 2d790210fce5..0a1fada33689 100644
--- a/textproc/sarep/Makefile
+++ b/textproc/sarep/Makefile
@@ -14,11 +14,12 @@ BROKEN= unfetchable
RUN_DEPENDS= p5-Text-CSV_XS>=0:${PORTSDIR}/textproc/p5-Text-CSV_XS
-EXTRACT_CMD= $(SED)
-EXTRACT_BEFORE_ARGS= 's=^\#!/usr/bin/perl =\#!${PERL} =' <
-EXTRACT_AFTER_ARGS= | ${TR} -d '\r' > ${WRKSRC}/sarep
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= ${WRKSRC}/sarep
-USES= perl5
+USES= perl5 dos2unix shebangfix
+SHEBANG_FILES= sarep
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/sarep