aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
commit88bfe4bd43787219ab4de75bd68c490c98776dfc (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /textproc
parent9e8bfe9c71187ea60ac9f3a55c0c7bde80d76033 (diff)
downloadports-88bfe4bd43787219ab4de75bd68c490c98776dfc.tar.gz
ports-88bfe4bd43787219ab4de75bd68c490c98776dfc.zip
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=386097
Diffstat (limited to 'textproc')
-rw-r--r--textproc/dixit/Makefile7
-rw-r--r--textproc/fop/Makefile3
-rw-r--r--textproc/htmldoc/Makefile3
-rw-r--r--textproc/jakarta-commons-digester/Makefile3
-rw-r--r--textproc/jdictionary/Makefile3
-rw-r--r--textproc/kmfl-khmer/Makefile7
-rw-r--r--textproc/kmfl-khmer/distinfo4
-rw-r--r--textproc/kmflcomp/Makefile4
-rw-r--r--textproc/libtranslate/Makefile6
-rw-r--r--textproc/multimarkdown/Makefile11
-rw-r--r--textproc/multimarkdown/distinfo4
-rw-r--r--textproc/p5-Algorithm-RabinKarp/Makefile2
-rw-r--r--textproc/p5-Hash-Merge/Makefile2
-rw-r--r--textproc/p5-Marpa-HTML/Makefile2
-rw-r--r--textproc/refdb/Makefile2
-rw-r--r--textproc/resume/Makefile3
-rw-r--r--textproc/vbindiff/Makefile3
-rw-r--r--textproc/wordnet/Makefile2
-rw-r--r--textproc/xmlto/Makefile4
19 files changed, 33 insertions, 42 deletions
diff --git a/textproc/dixit/Makefile b/textproc/dixit/Makefile
index d36b52884e4d..07e18869b68d 100644
--- a/textproc/dixit/Makefile
+++ b/textproc/dixit/Makefile
@@ -3,23 +3,22 @@
PORTNAME= dixit
PORTVERSION= 11.11
+DISTVERSIONSUFFIX= .${QT_VER}
PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}_qdb:db \
LOCAL/bdrewery/${PORTNAME}/ \
LOCAL/bdrewery/${PORTNAME}:db
-DISTFILES= ${PORTNAME}-${PORTVERSION}.${QT_VER}.tgz \
+DISTFILES= ${DISTNAME}.tgz \
${_DB_D}:db
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.${QT_VER}.tgz
+EXTRACT_ONLY= ${DISTNAME}.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Romanian dictionaries databases and query application
LICENSE= GPLv3 # (or later)
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.${QT_VER}
-
USES= qmake
USE_QT4= corelib gui network moc_build rcc_build
LDFLAGS+= -lz
diff --git a/textproc/fop/Makefile b/textproc/fop/Makefile
index a32dc5dcde8f..edef6dadb027 100644
--- a/textproc/fop/Makefile
+++ b/textproc/fop/Makefile
@@ -4,9 +4,8 @@
PORTNAME= fop
PORTVERSION= 1.1
CATEGORIES= textproc java
-MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:fop/} \
+MASTER_SITES= APACHE/xmlgraphics/fop/source/:fop \
SF/offo/offo-hyphenation/2.0:hyph
-MASTER_SITE_SUBDIR= xmlgraphics/fop/source/:fop
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
DISTFILES= ${DISTNAME}.tar.gz:fop offo-hyphenation_v2.0.zip:hyph
EXTRACT_ONLY= ${DISTNAME}.tar.gz
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index 51e1986485c9..286dcd191e41 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -6,8 +6,7 @@ PORTVERSION= 1.8.28
PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://www.msweet.org/files/project1/ \
- ${MASTER_SITE_EASYSW}
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
+ EASYSW/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= jose@diasfernandes.pt
diff --git a/textproc/jakarta-commons-digester/Makefile b/textproc/jakarta-commons-digester/Makefile
index 3852f1f1e51c..0e4f888e69b3 100644
--- a/textproc/jakarta-commons-digester/Makefile
+++ b/textproc/jakarta-commons-digester/Makefile
@@ -4,8 +4,7 @@
PORTNAME= commons-digester
PORTVERSION= 2.1
CATEGORIES= textproc java devel
-MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_BINARIES}
-MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
+MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
diff --git a/textproc/jdictionary/Makefile b/textproc/jdictionary/Makefile
index 3d1f4e60650b..cb6f1291743c 100644
--- a/textproc/jdictionary/Makefile
+++ b/textproc/jdictionary/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= jdictionary
-PORTVERSION= 1.8
+DISTVERSION= 1_8
PORTREVISION= 4
CATEGORIES= textproc java
MASTER_SITES= SF/jdictionary/jDictionary/jDictionary%20version%20${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,_,}
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Platform independent, plugin based dictionary
diff --git a/textproc/kmfl-khmer/Makefile b/textproc/kmfl-khmer/Makefile
index 8a87b30ba543..8e5124701c21 100644
--- a/textproc/kmfl-khmer/Makefile
+++ b/textproc/kmfl-khmer/Makefile
@@ -4,17 +4,16 @@
PORTNAME= khmer
PORTVERSION= 1.0
CATEGORIES= textproc
-MASTER_SITES= https://github.com/buganini/kmfl-${PORTNAME}/tarball/${PORTVERSION}/
PKGNAMEPREFIX= kmfl-
-DISTNAME= buganini-${PORTNAME}-${PORTVERSION}-0-g${GITVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= KMFL SCIM IMEngine keyboard for Khmer language
RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp
-GITVERSION= a20cc89
-WRKSRC= ${WRKDIR}/buganini-kmfl-${PORTNAME}-${GITVERSION}/kmfl
+USE_GITHUB= yes
+GH_ACCOUNT= buganini
+GH_PROJECT= kmfl-${PORTNAME}
NO_BUILD= yes
KMFL_DIR= share/kmfl
diff --git a/textproc/kmfl-khmer/distinfo b/textproc/kmfl-khmer/distinfo
index 3c9e6f51cc8a..b6b8cdd00b90 100644
--- a/textproc/kmfl-khmer/distinfo
+++ b/textproc/kmfl-khmer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (buganini-khmer-1.0-0-ga20cc89.tar.gz) = 90d59cbf8969fa768946d830870e8d06643c968bf98f9353d8fde579733a4020
-SIZE (buganini-khmer-1.0-0-ga20cc89.tar.gz) = 2895
+SHA256 (buganini-kmfl-khmer-1.0_GH0.tar.gz) = d5cb54c55c4db66ba593040575b8f9c8b61251d208083f627522af503b11a7a1
+SIZE (buganini-kmfl-khmer-1.0_GH0.tar.gz) = 2893
diff --git a/textproc/kmflcomp/Makefile b/textproc/kmflcomp/Makefile
index d44e30d682d0..4d1245a23e2e 100644
--- a/textproc/kmflcomp/Makefile
+++ b/textproc/kmflcomp/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= textproc
MASTER_SITES= SF/kmfl/kmfl/${PORTVERSION}:1 \
SF/kmfl/kmfl/Documentation:2 \
http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/:1,2
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:1 \
+DISTFILES= ${DISTNAME}.tar.gz:1 \
KMFL-Compiler.sxw:2
DIST_SUBDIR= kmfl
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= Compiler of Keyman KMFL keyboard sources to use with SCIM/IBus
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index 45ed2a74825f..e571ae48776c 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -5,13 +5,11 @@ PORTNAME= libtranslate
PORTVERSION= 0.99
PORTREVISION= 8
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} # May append to this
+MASTER_SITES= SAVANNAH
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # May append to this
PATCHFILES= libtranslate-0.99-services.diff libtranslate-0.99-postmarker.diff
PATCH_SITES= ${MASTER_SITES}
-PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index f83d78c52a51..e5a03b7d8604 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -4,11 +4,11 @@
PORTNAME= multimarkdown
PORTVERSION= 4.7
CATEGORIES= textproc
-MASTER_SITES= https://codeload.github.com/fletcher/MultiMarkdown-4/legacy.tar.gz/${MM4_COMMIT}?dummy=/:MM4 \
+MASTER_SITES= GH:MM4 \
https://codeload.github.com/fletcher/MMD-Support/legacy.tar.gz/${SUPPORT_COMMIT}?dummy=/:support \
https://codeload.github.com/fletcher/human-markdown-reference/legacy.tar.gz/${CHEAT_COMMIT}?dummy=/:cheat \
https://codeload.github.com/nddrylliog/greg/legacy.tar.gz/${GREG_COMMIT}?dummy=/:greg
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:MM4 \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:MM4 \
greg-${GREG_COMMIT}${EXTRACT_SUFX}:greg
DIST_SUBDIR= ${PORTNAME}
@@ -17,13 +17,14 @@ COMMENT= Extended Markdown processor with more features, written in C
LICENSE= MIT
-MM4_COMMIT= 90c7ddf
+USE_GITHUB= yes
+GH_ACCOUNT= fletcher
+GH_PROJECT= MultiMarkdown-4
+
SUPPORT_COMMIT= 685c95c
CHEAT_COMMIT= 199dae8
GREG_COMMIT= 98ecf13
-WRKSRC= ${WRKDIR}/fletcher-MultiMarkdown-4-${MM4_COMMIT}
-
ALL_TARGET= ${PORTNAME}
USES= gmake
diff --git a/textproc/multimarkdown/distinfo b/textproc/multimarkdown/distinfo
index 7eee06b6e17f..8d9ba6b4c2c3 100644
--- a/textproc/multimarkdown/distinfo
+++ b/textproc/multimarkdown/distinfo
@@ -1,5 +1,5 @@
-SHA256 (multimarkdown/multimarkdown-4.7.tar.gz) = fedd5dec9ff596cc48d26f5e3df1a1f89b024177f313aaaaf6dee95c5e403e12
-SIZE (multimarkdown/multimarkdown-4.7.tar.gz) = 120602
+SHA256 (multimarkdown/fletcher-MultiMarkdown-4-4.7_GH0.tar.gz) = 6ee0ac92c5e9eff924e3f9713f145cabd561ce62ef55fb9dacd69fa145d0fbfc
+SIZE (multimarkdown/fletcher-MultiMarkdown-4-4.7_GH0.tar.gz) = 120573
SHA256 (multimarkdown/greg-98ecf13.tar.gz) = a3d13c16bdc0fce1f6fc1f8ec4fa9c32956876440c91a25a8183846334ba66c0
SIZE (multimarkdown/greg-98ecf13.tar.gz) = 34304
SHA256 (multimarkdown/human-markdown-reference-199dae8.tar.gz) = 6b7c0e1acfa5f3c40ce09dfdb456161e2fc6cd60159e4b06d9dc7f8772a50c59
diff --git a/textproc/p5-Algorithm-RabinKarp/Makefile b/textproc/p5-Algorithm-RabinKarp/Makefile
index e8cc7b4c7c71..09596c936896 100644
--- a/textproc/p5-Algorithm-RabinKarp/Makefile
+++ b/textproc/p5-Algorithm-RabinKarp/Makefile
@@ -3,12 +3,12 @@
PORTNAME= Algorithm-RabinKarp
PORTVERSION= 0.41
+DISTVERSIONSUFFIX= _1
PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:NNUNLEY
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}_1
MAINTAINER= perl@FreeBSD.org
COMMENT= Rabin-Karp streaming hash
diff --git a/textproc/p5-Hash-Merge/Makefile b/textproc/p5-Hash-Merge/Makefile
index 56f29eebd59f..5dbb461d8dfc 100644
--- a/textproc/p5-Hash-Merge/Makefile
+++ b/textproc/p5-Hash-Merge/Makefile
@@ -3,11 +3,11 @@
PORTNAME= Hash-Merge
PORTVERSION= 0.20
+DISTVERSIONSUFFIX= 0
PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}0
MAINTAINER= perl@FreeBSD.org
COMMENT= Merges hashes
diff --git a/textproc/p5-Marpa-HTML/Makefile b/textproc/p5-Marpa-HTML/Makefile
index 11d5bab8dbd1..ec77a1c35bd8 100644
--- a/textproc/p5-Marpa-HTML/Makefile
+++ b/textproc/p5-Marpa-HTML/Makefile
@@ -3,12 +3,12 @@
PORTNAME= Marpa-HTML
PORTVERSION= 0.112
+DISTVERSIONSUFFIX= 000
PORTREVISION= 1
CATEGORIES= textproc lang perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:JKEGL
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}000
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= High-level HTML Parser
diff --git a/textproc/refdb/Makefile b/textproc/refdb/Makefile
index ecdbf714c81d..42330d2c9468 100644
--- a/textproc/refdb/Makefile
+++ b/textproc/refdb/Makefile
@@ -3,10 +3,10 @@
PORTNAME= refdb
PORTVERSION= 0.9.9
+DISTVERSIONSUFFIX= -1
PORTREVISION= 7
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTNAME}-src-${PORTVERSION}-1
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ohartman@zedat.fu-berlin.de
COMMENT= Bibliographic reference database
diff --git a/textproc/resume/Makefile b/textproc/resume/Makefile
index 971ce2638ae5..d08461f136cb 100644
--- a/textproc/resume/Makefile
+++ b/textproc/resume/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= resume
-PORTVERSION= 1.5.1
+DISTVERSION= 1_5_1
PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/xml${PORTNAME}/xml${PORTNAME}/${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
diff --git a/textproc/vbindiff/Makefile b/textproc/vbindiff/Makefile
index 67b18c5317aa..0baf4003a427 100644
--- a/textproc/vbindiff/Makefile
+++ b/textproc/vbindiff/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= vbindiff
-PORTVERSION= 3.0.b4
+DISTVERSION= 3.0_beta4
CATEGORIES= textproc
MASTER_SITES= http://www.cjmweb.net/vbindiff/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/_beta/}
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Visual binary diff, visually compare binary files
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
index 40047921f1e5..02831ebe5e6f 100644
--- a/textproc/wordnet/Makefile
+++ b/textproc/wordnet/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://wordnetcode.princeton.edu/${PORTVERSION}/:code \
http://wordnetcode.princeton.edu/:dict
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code wn3.1.dict.tar.gz:dict
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:code wn3.1.dict.tar.gz:dict
MAINTAINER= mi@aldan.algebra.com
COMMENT= Dictionaries and thesauri with devel. libraries (C, TCL) and browsers
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index d8894bb7dd04..8cb3e3a6cdac 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= https://fedorahosted.org/releases/x/m/xmlto/:xmlto \
LOCAL/mandree/:xmlto \
http://www.antennahouse.com/XSLsample/sample-xsl-xhtml2fo/:xsl \
LOCAL/mandree/:xsl
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:xmlto \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:xmlto \
xhtml2fo.xsl:xsl
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= mandree@FreeBSD.org
COMMENT= Front-end to an XSL toolchain