aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-10-01 07:05:09 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-10-01 07:05:09 +0000
commit6a56589245df0c857a632c0c0e159efd0a3d7630 (patch)
tree4ddc14f6de8f6e1b2d0ae2ec7be2fabc18dd9d55 /textproc
parent5ef10d7329bd51fb4fc1c8e1210a9065a36f20cb (diff)
downloadports-6a56589245df0c857a632c0c0e159efd0a3d7630.tar.gz
ports-6a56589245df0c857a632c0c0e159efd0a3d7630.zip
New port, wdiff:
Display word differences between text files. PR: 4613 Submitted by: MIHIRA Yoshiro <sanpei@yy.cs.keio.ac.jp>
Notes
Notes: svn path=/head/; revision=8066
Diffstat (limited to 'textproc')
-rw-r--r--textproc/wdiff/Makefile25
-rw-r--r--textproc/wdiff/distinfo1
-rw-r--r--textproc/wdiff/files/patch-aa11
-rw-r--r--textproc/wdiff/files/patch-ab10
-rw-r--r--textproc/wdiff/pkg-comment1
-rw-r--r--textproc/wdiff/pkg-descr21
-rw-r--r--textproc/wdiff/pkg-plist7
7 files changed, 76 insertions, 0 deletions
diff --git a/textproc/wdiff/Makefile b/textproc/wdiff/Makefile
new file mode 100644
index 000000000000..0de712e97f78
--- /dev/null
+++ b/textproc/wdiff/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: wdiff
+# Version required: 0.5
+# Date created: Sep 15, 1997
+# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= wdiff-0.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+
+MAINTAINER= sanpei@yy.cs.keio.ac.jp
+
+GNU_CONFIGURE= yes
+
+MAN1= wdiff.1
+
+post-install:
+ @if [ ! -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+ @install-info ${PREFIX}/info/wdiff.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/textproc/wdiff/distinfo b/textproc/wdiff/distinfo
new file mode 100644
index 000000000000..423a2507ac71
--- /dev/null
+++ b/textproc/wdiff/distinfo
@@ -0,0 +1 @@
+MD5 (wdiff-0.5.tar.gz) = 7f9c78f5dd6fb4f3dabe28fbd4d14319
diff --git a/textproc/wdiff/files/patch-aa b/textproc/wdiff/files/patch-aa
new file mode 100644
index 000000000000..6b3e9c0a9ff1
--- /dev/null
+++ b/textproc/wdiff/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in.org Sun Nov 6 16:45:13 1994
++++ Makefile.in Thu Sep 18 01:40:06 1997
+@@ -129,7 +129,7 @@
+ check: wdiff
+ $(srcdir)/check_it
+
+-install: all
++install: all install-man
+ $(srcdir)/mkinstalldirs $(bindir) $(infodir)
+ for name in $(PROGRAMS); do \
+ $(INSTALL_PROGRAM) $$name \
diff --git a/textproc/wdiff/files/patch-ab b/textproc/wdiff/files/patch-ab
new file mode 100644
index 000000000000..1054da7adb04
--- /dev/null
+++ b/textproc/wdiff/files/patch-ab
@@ -0,0 +1,10 @@
+--- configure.orig Sun Nov 6 16:59:26 1994
++++ configure Thu Sep 18 02:08:30 1997
+@@ -1159,6 +1159,7 @@
+
+
+
++LIBS="$saved_LIBS -ltermcap"
+ for ac_func in strerror tputs
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&4
diff --git a/textproc/wdiff/pkg-comment b/textproc/wdiff/pkg-comment
new file mode 100644
index 000000000000..3031f7ae91d1
--- /dev/null
+++ b/textproc/wdiff/pkg-comment
@@ -0,0 +1 @@
+Display word differences between text files.
diff --git a/textproc/wdiff/pkg-descr b/textproc/wdiff/pkg-descr
new file mode 100644
index 000000000000..bb21a23e2658
--- /dev/null
+++ b/textproc/wdiff/pkg-descr
@@ -0,0 +1,21 @@
+ << wdiff >>
+
+ From man page of wdiff:
+ wdiff compares two files, finding which words have been
+ deleted or added to old_file to get new_file. A word is
+ anything between whitespace. The output is collected and
+ used to produce an annotated copy of new_file on standard
+ output. Suitable annotations produce a nice display of
+ word differences between the original files.
+
+ Example:
+ text-a
+ I like FreeBSD.
+ text-b
+ I love FreeBSD.
+
+ % wdiff -n text-a text-b
+ I [-like-] {+love+} FreeBSD.
+
+- Yoshiro MIHIRA
+(sanpei@yy.cs.keio.ac.jp)
diff --git a/textproc/wdiff/pkg-plist b/textproc/wdiff/pkg-plist
new file mode 100644
index 000000000000..c43845e0028a
--- /dev/null
+++ b/textproc/wdiff/pkg-plist
@@ -0,0 +1,7 @@
+bin/wdiff
+@unexec install-info --delete %D/info/wdiff.info %D/info/dir
+info/wdiff.info
+@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
+@exec install-info %D/info/wdiff.info %D/info/dir
+info/dir
+man/man1/wdiff.1.gz