aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 06:24:38 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 06:24:38 +0000
commit372bf92c0b0a29fb9d19abaccea49d4cada53403 (patch)
treea4100d2ec14c070b63d9ea26122e5df31f4c09af /textproc
parent45d7e712eb09bcfb90a25df7b3e16346bb7e99c3 (diff)
downloadports-372bf92c0b0a29fb9d19abaccea49d4cada53403.tar.gz
ports-372bf92c0b0a29fb9d19abaccea49d4cada53403.zip
Add p5-LJ-SpellCheck 1.0, HTML highlighting misspellings using
ispell compatible program. PR: 26084 Submitted by: Michael Johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=41013
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-LJ-SpellCheck/Makefile24
-rw-r--r--textproc/p5-LJ-SpellCheck/distinfo1
-rw-r--r--textproc/p5-LJ-SpellCheck/pkg-comment1
-rw-r--r--textproc/p5-LJ-SpellCheck/pkg-descr10
-rw-r--r--textproc/p5-LJ-SpellCheck/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 342777947705..79d65818eea3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -83,6 +83,7 @@
SUBDIR += openjade
SUBDIR += opensched
SUBDIR += p5-DelimMatch
+ SUBDIR += p5-LJ-SpellCheck
SUBDIR += p5-PDF-Create
SUBDIR += p5-Sort-ArbBiLex
SUBDIR += p5-Sort-Fields
diff --git a/textproc/p5-LJ-SpellCheck/Makefile b/textproc/p5-LJ-SpellCheck/Makefile
new file mode 100644
index 000000000000..f5970935542a
--- /dev/null
+++ b/textproc/p5-LJ-SpellCheck/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-LJ-SpellCheck
+# Date created: 25 Mar 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LJ-SpellCheck
+PORTVERSION= 1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= http://livejournal.com/files/code/spellcheck/ \
+ ftp://ftp.livejournal.com/code/spellcheck/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ahze@ahze.net
+
+RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+
+PERL_CONFIGURE= yes
+
+MAN3= LJ::SpellCheck.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-LJ-SpellCheck/distinfo b/textproc/p5-LJ-SpellCheck/distinfo
new file mode 100644
index 000000000000..3c74f810e7d8
--- /dev/null
+++ b/textproc/p5-LJ-SpellCheck/distinfo
@@ -0,0 +1 @@
+MD5 (LJ-SpellCheck-1.0.tar.gz) = 0cb041050b227fa956ae0f8beca24305
diff --git a/textproc/p5-LJ-SpellCheck/pkg-comment b/textproc/p5-LJ-SpellCheck/pkg-comment
new file mode 100644
index 000000000000..0e8e58bc83a3
--- /dev/null
+++ b/textproc/p5-LJ-SpellCheck/pkg-comment
@@ -0,0 +1 @@
+HTML highlighting misspellings using ispell compatible program
diff --git a/textproc/p5-LJ-SpellCheck/pkg-descr b/textproc/p5-LJ-SpellCheck/pkg-descr
new file mode 100644
index 000000000000..5f9f16a0e80a
--- /dev/null
+++ b/textproc/p5-LJ-SpellCheck/pkg-descr
@@ -0,0 +1,10 @@
+The object constructor takes a 'spellcommand' argument. This has to be
+some ispell compatible program, like aspell. Optionally, it also takes a
+color to highlight mispelled words.
+
+The only method on the object is check_html, which takes a reference to
+the text to check and returns a bunch of HTML highlighting misspellings
+and showing suggestions. If it returns nothing, then there no misspellings
+found.
+
+WWW: http://livejournal.com/code/spellcheck/
diff --git a/textproc/p5-LJ-SpellCheck/pkg-plist b/textproc/p5-LJ-SpellCheck/pkg-plist
new file mode 100644
index 000000000000..f227c3e49587
--- /dev/null
+++ b/textproc/p5-LJ-SpellCheck/pkg-plist
@@ -0,0 +1 @@
+lib/perl5/site_perl/5.005/LJ/SpellCheck.pm