aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2000-05-10 13:24:51 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2000-05-10 13:24:51 +0000
commitd3c8a431bb6ddfbbd55ebabd3ac7d54230ffbda8 (patch)
tree69f11696921f304c300e5cd184fe15d5419c53c3 /textproc
parentc36dc7c3b3ab8070a103285cc808114a021ce2c6 (diff)
downloadports-d3c8a431bb6ddfbbd55ebabd3ac7d54230ffbda8.tar.gz
ports-d3c8a431bb6ddfbbd55ebabd3ac7d54230ffbda8.zip
W3C's XHTML DTD.
Notes
Notes: svn path=/head/; revision=28391
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xhtml/Makefile33
-rw-r--r--textproc/xhtml/distinfo1
-rw-r--r--textproc/xhtml/pkg-comment1
-rw-r--r--textproc/xhtml/pkg-descr11
-rw-r--r--textproc/xhtml/pkg-plist11
5 files changed, 57 insertions, 0 deletions
diff --git a/textproc/xhtml/Makefile b/textproc/xhtml/Makefile
new file mode 100644
index 000000000000..bfbd3070092b
--- /dev/null
+++ b/textproc/xhtml/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: XHTML DTD
+# Date created: 10 May 2000
+# Whom: kuriyama
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhtml
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.w3.org/TR/xhtml1/
+DISTNAME= xhtml1
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+USE_ZIP= YES
+NO_MTREE= YES
+NO_BUILD= YES
+#WRKSRC= ${WRKDIR}/
+
+INSTDIR= ${PREFIX}/share/xml
+DTDDIR= ${INSTDIR}/dtd/xhtml
+DTDFILES= xhtml-lat1.ent xhtml-special.ent xhtml-symbol.ent \
+ xhtml.soc xhtml1-frameset.dtd xhtml1-strict.dtd \
+ xhtml1-transitional.dtd xhtml1.dcl
+
+pre-install:
+ @[ -d ${DTDDIR} ] || ${MKDIR} ${DTDDIR}
+
+do-install:
+ @(cd ${WRKSRC}/DTD; ${INSTALL_DATA} ${DTDFILES} ${DTDDIR})
+
+.include <bsd.port.mk>
diff --git a/textproc/xhtml/distinfo b/textproc/xhtml/distinfo
new file mode 100644
index 000000000000..736bfe96948a
--- /dev/null
+++ b/textproc/xhtml/distinfo
@@ -0,0 +1 @@
+MD5 (xhtml1.zip) = 71021c96035916518ddcf0ac08a1353e
diff --git a/textproc/xhtml/pkg-comment b/textproc/xhtml/pkg-comment
new file mode 100644
index 000000000000..a96fc9c3511d
--- /dev/null
+++ b/textproc/xhtml/pkg-comment
@@ -0,0 +1 @@
+W3C's XHTML DTD
diff --git a/textproc/xhtml/pkg-descr b/textproc/xhtml/pkg-descr
new file mode 100644
index 000000000000..0a7549b0bdde
--- /dev/null
+++ b/textproc/xhtml/pkg-descr
@@ -0,0 +1,11 @@
+This specification defines XHTML 1.0, a reformulation of HTML 4 as an
+XML 1.0 application, and three DTDs corresponding to the ones defined
+by HTML 4.
+
+The semantics of the elements and their attributes are defined in the
+W3C Recommendation for HTML 4.
+
+These semantics provide the foundation for future extensibility of XHTML.
+
+Compatibility with existing HTML user agents is possible by following
+a small set of guidelines.
diff --git a/textproc/xhtml/pkg-plist b/textproc/xhtml/pkg-plist
new file mode 100644
index 000000000000..d47e2b9a3392
--- /dev/null
+++ b/textproc/xhtml/pkg-plist
@@ -0,0 +1,11 @@
+share/xml/dtd/xhtml/xhtml-lat1.ent
+share/xml/dtd/xhtml/xhtml-special.ent
+share/xml/dtd/xhtml/xhtml-symbol.ent
+share/xml/dtd/xhtml/xhtml.soc
+share/xml/dtd/xhtml/xhtml1-frameset.dtd
+share/xml/dtd/xhtml/xhtml1-strict.dtd
+share/xml/dtd/xhtml/xhtml1-transitional.dtd
+share/xml/dtd/xhtml/xhtml1.dcl
+@dirrm share/xml/dtd/xhtml
+@unexec rmdir %D/share/xml/dtd 2>/dev/null || true
+@unexec rmdir %D/share/xml 2>/dev/null || true