aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>1999-07-22 13:14:20 +0000
committerKris Kennaway <kris@FreeBSD.org>1999-07-22 13:14:20 +0000
commita30e573225e06c333070e3e9430a2baf2b49aa85 (patch)
tree6ca7ff17fd27c674a01f010a2aaf286fc05911e9 /textproc
parent8602d898ba30c99c66f868dc6ff7b2d952e264cc (diff)
downloadports-a30e573225e06c333070e3e9430a2baf2b49aa85.tar.gz
ports-a30e573225e06c333070e3e9430a2baf2b49aa85.zip
GTK app which queries a dictionary server and returns a word definition.
Based on dict. PR: 12694 Submitted by: domi@saargate.de
Notes
Notes: svn path=/head/; revision=20312
Diffstat (limited to 'textproc')
-rw-r--r--textproc/gdict/Makefile21
-rw-r--r--textproc/gdict/distinfo1
-rw-r--r--textproc/gdict/files/patch-aa14
-rw-r--r--textproc/gdict/files/patch-ab25
-rw-r--r--textproc/gdict/files/patch-ac26
-rw-r--r--textproc/gdict/pkg-comment1
-rw-r--r--textproc/gdict/pkg-descr6
-rw-r--r--textproc/gdict/pkg-plist2
8 files changed, 96 insertions, 0 deletions
diff --git a/textproc/gdict/Makefile b/textproc/gdict/Makefile
new file mode 100644
index 000000000000..1f02c346f629
--- /dev/null
+++ b/textproc/gdict/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: gdict
+# Version required: 0.7
+# Date created: Sun Jul 18 1999
+# Whom: domi@saargate.de
+#
+# $Id: Makefile,v 1.1.1.1 1999/06/09 01:54:51 steve Exp $
+#
+
+DISTNAME= gdict-0.7
+CATEGORIES= textproc
+MASTER_SITES= http://www.psilord.com/code/gdict/
+
+MAINTAINER= domi@saargate.de
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gdict ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/dict ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/gdict/distinfo b/textproc/gdict/distinfo
new file mode 100644
index 000000000000..36efd0412821
--- /dev/null
+++ b/textproc/gdict/distinfo
@@ -0,0 +1 @@
+MD5 (gdict-0.7.tar.gz) = ef81d5142345dc2b0b9af662a0cc3cc0
diff --git a/textproc/gdict/files/patch-aa b/textproc/gdict/files/patch-aa
new file mode 100644
index 000000000000..f93fc2ce03f6
--- /dev/null
+++ b/textproc/gdict/files/patch-aa
@@ -0,0 +1,14 @@
+--- Makefile Mon Mar 29 08:02:27 1999
++++ Makefile~ Thu Jul 22 22:25:09 1999
+@@ -1,8 +1,8 @@
+ # Makefile for gdict
+
+-CC = gcc
+-CFLAGS = -O6 -Wall
+-CFL_GTK = $(CFLAGS) `gtk-config --cflags` `gtk-config --libs`
++CC ?= gcc
++CFLAGS ?= -O6 -Wall
++CFL_GTK = $(CFLAGS) `gtk12-config --cflags` `gtk12-config --libs`
+ CFL = $(CFLAGS)
+ OBJECTS_GDICT = gdict.c
+ OBJECTS_DICT = dict.c
diff --git a/textproc/gdict/files/patch-ab b/textproc/gdict/files/patch-ab
new file mode 100644
index 000000000000..3dca82fad976
--- /dev/null
+++ b/textproc/gdict/files/patch-ab
@@ -0,0 +1,25 @@
+--- dict.c Mon Mar 29 08:10:35 1999
++++ dict.c~ Thu Jul 22 22:25:16 1999
+@@ -4,11 +4,12 @@
+ * Thanks goes out to #linuxos also. :)
+ */
+
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <sys/socket.h>
+ #include <unistd.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <string.h>
+
+ int main (int argc, char *argv[]) {
+@@ -40,7 +41,7 @@
+ Sockaddr.sin_port = htons(2627);
+ Sockaddr.sin_addr.s_addr = inet_addr("128.52.39.7");
+
+- err = connect (sd, &Sockaddr, sizeof(Sockaddr) );
++ err = connect (sd, (struct sockaddr *) &Sockaddr, sizeof(Sockaddr) );
+
+ if (err != 0) {
+ printf("Could not connect to dictionary server!\n");
diff --git a/textproc/gdict/files/patch-ac b/textproc/gdict/files/patch-ac
new file mode 100644
index 000000000000..fe5706794164
--- /dev/null
+++ b/textproc/gdict/files/patch-ac
@@ -0,0 +1,26 @@
+--- gdict.c Mon Mar 29 17:35:54 1999
++++ gdict.c~ Thu Jul 22 22:25:19 1999
+@@ -13,12 +13,13 @@
+ * Window resizing and cleanup by Iain (Nodatadj, EFNet) 23-Mar-1999
+ */
+
++#include <sys/types.h>
+ #include <gtk/gtk.h>
+ #include <stdio.h>
+ #include <sys/socket.h>
+ #include <unistd.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <string.h>
+
+ /* globals */
+@@ -154,7 +155,7 @@
+ Sockaddr.sin_port = htons(2627);
+ Sockaddr.sin_addr.s_addr = inet_addr ("128.52.39.7");
+
+- err = connect (sd, &Sockaddr, sizeof(Sockaddr));
++ err = connect (sd, (struct sockaddr *) &Sockaddr, sizeof(Sockaddr));
+
+ if (err != 0) {
+ sprintf (buffer, "Could not connect to dictionary server!");
diff --git a/textproc/gdict/pkg-comment b/textproc/gdict/pkg-comment
new file mode 100644
index 000000000000..496fc91421be
--- /dev/null
+++ b/textproc/gdict/pkg-comment
@@ -0,0 +1 @@
+Small program that finds definitions of arbitrary (english) words
diff --git a/textproc/gdict/pkg-descr b/textproc/gdict/pkg-descr
new file mode 100644
index 000000000000..9379881f60b1
--- /dev/null
+++ b/textproc/gdict/pkg-descr
@@ -0,0 +1,6 @@
+gdict is a small C/GTK+ program written to find definitions of arbitrary
+words. It contacts the MIT dictionary server and returns a definition.
+
+Additionally, there is a CLI version named "dict".
+
+WWW: http://www.psilord.com/code/
diff --git a/textproc/gdict/pkg-plist b/textproc/gdict/pkg-plist
new file mode 100644
index 000000000000..b03bb42516e7
--- /dev/null
+++ b/textproc/gdict/pkg-plist
@@ -0,0 +1,2 @@
+bin/dict
+bin/gdict