aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-03 17:34:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-03 17:34:24 +0000
commitb7c21e740d568121b8fefc367d50e7a718fd7525 (patch)
treee90970ff5bfa73be55dbbb300c04347ffe4878ce /textproc
parentf97f56e86c32539ab942a033e0da803adfdcc57e (diff)
downloadports-b7c21e740d568121b8fefc367d50e7a718fd7525.tar.gz
ports-b7c21e740d568121b8fefc367d50e7a718fd7525.zip
Add p5-Apache-XBEL 1.3, apache mod_perl handler to render an XBEL file
as an HTML tree. PR: ports/69940 Submitted by: Aaron Straup Cope <ascope@cpan.org>
Notes
Notes: svn path=/head/; revision=115351
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Apache-XBEL/Makefile40
-rw-r--r--textproc/p5-Apache-XBEL/distinfo2
-rw-r--r--textproc/p5-Apache-XBEL/pkg-descr3
-rw-r--r--textproc/p5-Apache-XBEL/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 17f19d42c2c5..20194d40a91e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -226,6 +226,7 @@
SUBDIR += opensched
SUBDIR += opensp
SUBDIR += p5-Apache-ParseLog
+ SUBDIR += p5-Apache-XBEL
SUBDIR += p5-CSS-SAC
SUBDIR += p5-CSS-Tiny
SUBDIR += p5-Data-FormValidator
diff --git a/textproc/p5-Apache-XBEL/Makefile b/textproc/p5-Apache-XBEL/Makefile
new file mode 100644
index 000000000000..13d14df4d79c
--- /dev/null
+++ b/textproc/p5-Apache-XBEL/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Apache-XBEL
+# Date created: August 03 2004
+# Whom: Aaron Straup Cope <ascope@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-XBEL
+PORTVERSION= 1.3
+# PORTREVISION=
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ascope@cpan.org
+COMMENT= Apache mod_perl handler to render an XBEL file as an HTML tree
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT \
+ ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/Memoize.pm:${PORTSDIR}/devel/p5-Memoize
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::XBEL.3
+
+.if defined(NOXSL)
+PLIST_SUB+= XSL="@Comment "
+.else
+PLIST_SUB+= XSL=""
+post-install:
+ @${ECHO} "Installing ${DATADIR}/apache-xbel.xsl"
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/xsl/apache-xbel.xsl ${DATADIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Apache-XBEL/distinfo b/textproc/p5-Apache-XBEL/distinfo
new file mode 100644
index 000000000000..d50aeb983bdc
--- /dev/null
+++ b/textproc/p5-Apache-XBEL/distinfo
@@ -0,0 +1,2 @@
+MD5 (Apache-XBEL-1.3.tar.gz) = 9cf47652de8da27d8d53005c0981e317
+SIZE (Apache-XBEL-1.3.tar.gz) = 9691
diff --git a/textproc/p5-Apache-XBEL/pkg-descr b/textproc/p5-Apache-XBEL/pkg-descr
new file mode 100644
index 000000000000..112c9fc7a15a
--- /dev/null
+++ b/textproc/p5-Apache-XBEL/pkg-descr
@@ -0,0 +1,3 @@
+Apache mod_perl handler to render an XBEL file as an HTML tree
+
+WWW: http://search.cpan.org/dist/Apache-XBEL/
diff --git a/textproc/p5-Apache-XBEL/pkg-plist b/textproc/p5-Apache-XBEL/pkg-plist
new file mode 100644
index 000000000000..a5ad0721c31d
--- /dev/null
+++ b/textproc/p5-Apache-XBEL/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Apache/XBEL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/XBEL/.packlist
+%%XSL%%%%DATADIR%%/apache-xbel.xsl
+%%XSL%%@dirrm %%DATADIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/XBEL
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true