aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-22 22:41:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-22 22:41:50 +0000
commitf1905422ee6b86d1afc28896fc9c0e4de3baf608 (patch)
tree6189ae4ab63cdc0704c29f18be3e2b350c8349a3 /textproc
parent7d1d3e059567d7924496edc21ddfbaf7d920f989 (diff)
downloadports-f1905422ee6b86d1afc28896fc9c0e4de3baf608.tar.gz
ports-f1905422ee6b86d1afc28896fc9c0e4de3baf608.zip
- Fix OPTIONS support for Cabal ports by introducing
bsd.cabal.options.mk - Fix ports broken with non-default options Triggered by: Yuri Pankov <yuri.pankov@gmail.com>
Notes
Notes: svn path=/head/; revision=254867
Diffstat (limited to 'textproc')
-rw-r--r--textproc/hs-citeproc-hs/Makefile1
-rw-r--r--textproc/hs-highlighting-kate-ghc/Makefile3
-rw-r--r--textproc/hs-highlighting-kate/Makefile3
-rw-r--r--textproc/hs-pandoc/Makefile3
-rw-r--r--textproc/hs-pandoc/pkg-plist1
-rw-r--r--textproc/hs-tagsoup/Makefile1
-rw-r--r--textproc/pandoc/Makefile3
-rw-r--r--textproc/pandoc/pkg-plist1
8 files changed, 14 insertions, 2 deletions
diff --git a/textproc/hs-citeproc-hs/Makefile b/textproc/hs-citeproc-hs/Makefile
index 00996428c1f0..e2e991bf7606 100644
--- a/textproc/hs-citeproc-hs/Makefile
+++ b/textproc/hs-citeproc-hs/Makefile
@@ -18,6 +18,7 @@ PORTDATA= *
OPTIONS= BIBUTILS "Use Chris Putnam's Bibutils" off
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_BIBUTILS)
diff --git a/textproc/hs-highlighting-kate-ghc/Makefile b/textproc/hs-highlighting-kate-ghc/Makefile
index d3b1f0a9fb7b..bcf28714b49a 100644
--- a/textproc/hs-highlighting-kate-ghc/Makefile
+++ b/textproc/hs-highlighting-kate-ghc/Makefile
@@ -17,11 +17,12 @@ USE_HACKAGE= pcre-light
OPTIONS= EXECUTABLE "Build the Highlight executable" off
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_EXECUTABLE)
CONFIGURE_ARGS+= --flags="executable"
-EXECUTABLE+= Highlighting
+EXECUTABLE+= Highlight
PLIST_SUB+= MAYBE_EXECUTABLE=""
.else
CONFIGURE_ARGS+= --flags="-executable"
diff --git a/textproc/hs-highlighting-kate/Makefile b/textproc/hs-highlighting-kate/Makefile
index d3b1f0a9fb7b..bcf28714b49a 100644
--- a/textproc/hs-highlighting-kate/Makefile
+++ b/textproc/hs-highlighting-kate/Makefile
@@ -17,11 +17,12 @@ USE_HACKAGE= pcre-light
OPTIONS= EXECUTABLE "Build the Highlight executable" off
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_EXECUTABLE)
CONFIGURE_ARGS+= --flags="executable"
-EXECUTABLE+= Highlighting
+EXECUTABLE+= Highlight
PLIST_SUB+= MAYBE_EXECUTABLE=""
.else
CONFIGURE_ARGS+= --flags="-executable"
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index 941804ba49de..7d604d9e5e64 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -26,6 +26,7 @@ OPTIONS= HIGHLIGHTING "Compile in support for syntax highlighting" off \
LIBRARY "Build the pandoc library" on \
CITEPROC "Compile in support for citeproc-hs" off
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_HIGHLIGHTING)
@@ -74,8 +75,10 @@ IGNORE= cannot be compiled in this configuration. Please (re)run 'make config'
.if defined(WITH_CITEPROC)
CONFIGURE_ARGS+= --flags="citeproc"
USE_HACKAGE+= citeproc-hs
+PLIST_SUB+= MAYBE_CITEPROC=""
.else
CONFIGURE_ARGS+= --flags="-citeproc"
+PLIST_SUB+= MAYBE_CITEPROC="@comment "
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/textproc/hs-pandoc/pkg-plist b/textproc/hs-pandoc/pkg-plist
index 0f186a4140ea..6855f3c090ee 100644
--- a/textproc/hs-pandoc/pkg-plist
+++ b/textproc/hs-pandoc/pkg-plist
@@ -3,6 +3,7 @@
%%MAYBE_EXECUTABLE%%bin/pandoc
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Paths_pandoc.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc.hi
+%%MAYBE_LIBRARY%%%%MAYBE_CITEPROC%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Biblio.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Blocks.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/CharacterReferences.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Definition.hi
diff --git a/textproc/hs-tagsoup/Makefile b/textproc/hs-tagsoup/Makefile
index 44f9bf9ad9c5..771d2712eb51 100644
--- a/textproc/hs-tagsoup/Makefile
+++ b/textproc/hs-tagsoup/Makefile
@@ -20,6 +20,7 @@ INSTALL_PORTDATA= cd ${WRKSRC} && \
OPTIONS= TESTPROG "Build the test program" on
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_TESTPROG)
diff --git a/textproc/pandoc/Makefile b/textproc/pandoc/Makefile
index 941804ba49de..7d604d9e5e64 100644
--- a/textproc/pandoc/Makefile
+++ b/textproc/pandoc/Makefile
@@ -26,6 +26,7 @@ OPTIONS= HIGHLIGHTING "Compile in support for syntax highlighting" off \
LIBRARY "Build the pandoc library" on \
CITEPROC "Compile in support for citeproc-hs" off
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_HIGHLIGHTING)
@@ -74,8 +75,10 @@ IGNORE= cannot be compiled in this configuration. Please (re)run 'make config'
.if defined(WITH_CITEPROC)
CONFIGURE_ARGS+= --flags="citeproc"
USE_HACKAGE+= citeproc-hs
+PLIST_SUB+= MAYBE_CITEPROC=""
.else
CONFIGURE_ARGS+= --flags="-citeproc"
+PLIST_SUB+= MAYBE_CITEPROC="@comment "
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/textproc/pandoc/pkg-plist b/textproc/pandoc/pkg-plist
index 0f186a4140ea..6855f3c090ee 100644
--- a/textproc/pandoc/pkg-plist
+++ b/textproc/pandoc/pkg-plist
@@ -3,6 +3,7 @@
%%MAYBE_EXECUTABLE%%bin/pandoc
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Paths_pandoc.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc.hi
+%%MAYBE_LIBRARY%%%%MAYBE_CITEPROC%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Biblio.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Blocks.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/CharacterReferences.hi
%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Definition.hi