aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorTong LIU <nemoliu@FreeBSD.org>2010-02-02 08:43:14 +0000
committerTong LIU <nemoliu@FreeBSD.org>2010-02-02 08:43:14 +0000
commit3d1fcd846efca68caa8bfc652bb4a09fab72e21f (patch)
treedf8e3b8faa4c57a9f208ddcf75b1ab71385cbbb1 /textproc
parentf6f397bcff92e14a449cd1276a6e193e5026cee9 (diff)
downloadports-3d1fcd846efca68caa8bfc652bb4a09fab72e21f.tar.gz
ports-3d1fcd846efca68caa8bfc652bb4a09fab72e21f.zip
- Add PHP pcre extension as required
- Use pkg-message.in for templated message output PR: ports/143404 Submmitted by: Joe Horn <joehorn@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=249077
Diffstat (limited to 'textproc')
-rw-r--r--textproc/simplehtmldom/Makefile30
-rw-r--r--textproc/simplehtmldom/files/pkg-message.in9
-rw-r--r--textproc/simplehtmldom/pkg-message8
3 files changed, 26 insertions, 21 deletions
diff --git a/textproc/simplehtmldom/Makefile b/textproc/simplehtmldom/Makefile
index f869709f2b72..d8f193509732 100644
--- a/textproc/simplehtmldom/Makefile
+++ b/textproc/simplehtmldom/Makefile
@@ -5,27 +5,31 @@
# $FreeBSD$
#
-PORTNAME= simplehtmldom
-DISTVERSION= 1.11
-CATEGORIES= textproc www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
-DISTNAME= ${PORTNAME}_${DISTVERSION:S/./_/g}
+PORTNAME= simplehtmldom
+DISTVERSION= 1.11
+CATEGORIES= textproc www
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
+DISTNAME= ${PORTNAME}_${DISTVERSION:S/./_/g}
-MAINTAINER= joehorn@gmail.com
-COMMENT= PHP Simple HTML DOM Parser
+MAINTAINER= joehorn@gmail.com
+COMMENT= PHP Simple HTML DOM Parser
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_ZIP= YES
-USE_PHP= YES
-NO_BUILD= YES
+USE_ZIP= YES
+NO_BUILD= YES
-EXAMPLES_SUB_DIR= scraping
-DOCS_SUB_DIR= css img js
+USE_PHP= pcre
DEFAULT_PHP_VER= 5
IGNORE_WITH_PHP= 4
+SUB_FILES+= pkg-message
+SUB_LIST+= DATADIR=${DATADIR} PREFIX=${PREFIX}
+
+EXAMPLES_SUB_DIR= scraping
+DOCS_SUB_DIR= css img js
+
.include <bsd.port.pre.mk>
do-install:
diff --git a/textproc/simplehtmldom/files/pkg-message.in b/textproc/simplehtmldom/files/pkg-message.in
new file mode 100644
index 000000000000..f848359493f1
--- /dev/null
+++ b/textproc/simplehtmldom/files/pkg-message.in
@@ -0,0 +1,9 @@
+*************************************************************************
+
+You can add the library path ( DEFAULT: %%DATADIR%% )
+to the "include_path=" directive in your php.ini file
+( DEFAULT: %%PREFIX%%/etc/php.ini ), such as:
+
+ include_path = ".:%%DATADIR%%"
+
+*************************************************************************
diff --git a/textproc/simplehtmldom/pkg-message b/textproc/simplehtmldom/pkg-message
index 4609bc7ddfb4..e69de29bb2d1 100644
--- a/textproc/simplehtmldom/pkg-message
+++ b/textproc/simplehtmldom/pkg-message
@@ -1,8 +0,0 @@
-*************************************************************************
-You can add the library path ( DEFAULT: ${PREFIX}/share/simplehtmldom )
-to the "include_path=" directive in your php.ini file
-( DEFAULT: ${PREFIX}/etc/php.ini ), such as:
-
- include_path = ".:${PREFIX}/share/simplehtmldom"
-
-*************************************************************************