aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-01-24 14:58:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-01-24 14:58:48 +0000
commit9be8ffd1f2f8f7cd2f457c14f98a121369359a8f (patch)
treef0593695b586eb6bff070eef8f9e9061314dbbd1 /textproc
parent65d01cabafa03fe1cec9e5d852557e7f6c91124f (diff)
downloadports-9be8ffd1f2f8f7cd2f457c14f98a121369359a8f.tar.gz
ports-9be8ffd1f2f8f7cd2f457c14f98a121369359a8f.zip
Use more universal approach instead of patching generated Makefile to fix build on some systems.
Reported by: Pavel Gubin <pg at 2lazy.ru>, Peter Jeremy <peterjeremy at acm.org>
Notes
Notes: svn path=/head/; revision=248470
Diffstat (limited to 'textproc')
-rw-r--r--textproc/qt4-xml/Makefile6
-rw-r--r--textproc/qt4-xml/files/extrapatch-src-xml-Makefile17
2 files changed, 1 insertions, 22 deletions
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 2285b6f33a91..d30911022ff3 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -45,9 +45,6 @@ BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
-EPATCH= extrapatch-src-xml-Makefile
-
-SUB_LIST+= WRKSRC=${WRKSRC:S|//|/|}
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
@@ -62,7 +59,6 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/lib/pkgconfig/QtXml.pc
#disable installation of include/Qt/qxmlstream.h, it handled by qt-corelib package
- @${SED} ${_SUB_LIST_TEMP} ${FILESDIR}/${EPATCH} > ${WRKDIR}/${EPATCH}
- ${PATCH} -d ${WRKSRC} < ${WRKDIR}/${EPATCH}
+ ${REINPLACE_CMD} -e '\,stream/qxmlstream.h.*${QT_INCDIR}/Qt/,d' ${WRKSRC}/src/xml/Makefile
.include <bsd.port.mk>
diff --git a/textproc/qt4-xml/files/extrapatch-src-xml-Makefile b/textproc/qt4-xml/files/extrapatch-src-xml-Makefile
deleted file mode 100644
index f47416234370..000000000000
--- a/textproc/qt4-xml/files/extrapatch-src-xml-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/xml/Makefile.orig 2009-12-04 16:04:02.944271152 +1000
-+++ src/xml/Makefile 2009-12-04 16:07:07.986728782 +1000
-@@ -533,14 +533,12 @@
- @$(CHK_DIR_EXISTS) $(INSTALL_ROOT)/usr/local/include/qt4/Qt/ || $(MKDIR) $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
- -$(INSTALL_PROGRAM) %%WRKSRC%%/src/xml/sax/qxml.h $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
- -$(INSTALL_PROGRAM) %%WRKSRC%%/src/xml/dom/qdom.h $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
-- -$(INSTALL_PROGRAM) %%WRKSRC%%/src/xml/stream/qxmlstream.h $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
- -$(INSTALL_PROGRAM) %%WRKSRC%%/include/QtXml/QtXml $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
-
-
- uninstall_flat_headers: FORCE
- -$(DEL_FILE) -r $(INSTALL_ROOT)/usr/local/include/qt4/Qt/qxml.h
- -$(DEL_FILE) -r $(INSTALL_ROOT)/usr/local/include/qt4/Qt/qdom.h
-- -$(DEL_FILE) -r $(INSTALL_ROOT)/usr/local/include/qt4/Qt/qxmlstream.h
- -$(DEL_FILE) -r $(INSTALL_ROOT)/usr/local/include/qt4/Qt/QtXml
- -$(DEL_DIR) $(INSTALL_ROOT)/usr/local/include/qt4/Qt/
-