aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:06:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:06:15 +0000
commita146b99c5755f02d00a9975e0d3d02d51313e0b1 (patch)
treed004d54d8e74631d3a9638f9ed9762c9ddcdfe3b /textproc
parent88ad8afa2021847467a4d5831958c050e9c562f2 (diff)
downloadports-a146b99c5755f02d00a9975e0d3d02d51313e0b1.tar.gz
ports-a146b99c5755f02d00a9975e0d3d02d51313e0b1.zip
PHP Simple HTML DOM Parser is a HTML DOM parser written in PHP5+,
and it let you manipulate HTML in a very easy way! Features: * Supports invalid HTML. * Find tags on an HTML page with selectors just like jQuery. * Extract contents from HTML in a single line. WWW: http://simplehtmldom.sourceforge.net/ PR: ports/142933 Submitted by: Joe Horn <joehorn at gmail.com>
Notes
Notes: svn path=/head/; revision=248654
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/simplehtmldom/Makefile55
-rw-r--r--textproc/simplehtmldom/distinfo3
-rw-r--r--textproc/simplehtmldom/pkg-descr9
-rw-r--r--textproc/simplehtmldom/pkg-message8
-rw-r--r--textproc/simplehtmldom/pkg-plist25
6 files changed, 101 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dd78e3fb6e14..980f353576de 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1112,6 +1112,7 @@
SUBDIR += sgrep
SUBDIR += sgrep2
SUBDIR += silvercity
+ SUBDIR += simplehtmldom
SUBDIR += sk-aspell
SUBDIR += sk-ispell
SUBDIR += skim
diff --git a/textproc/simplehtmldom/Makefile b/textproc/simplehtmldom/Makefile
new file mode 100644
index 000000000000..f869709f2b72
--- /dev/null
+++ b/textproc/simplehtmldom/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: simplehtmldom
+# Date created: 2010-01-18
+# Whom: Joe Horn <joehorn@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simplehtmldom
+DISTVERSION= 1.11
+CATEGORIES= textproc www
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
+DISTNAME= ${PORTNAME}_${DISTVERSION:S/./_/g}
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= PHP Simple HTML DOM Parser
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_ZIP= YES
+USE_PHP= YES
+NO_BUILD= YES
+
+EXAMPLES_SUB_DIR= scraping
+DOCS_SUB_DIR= css img js
+
+DEFAULT_PHP_VER= 5
+IGNORE_WITH_PHP= 4
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${ECHO_CMD} "=> Installing simple_html_dom.php to ${DATADIR}"
+ @${INSTALL} -c -m 644 ${WRKSRC}/simple_html_dom.php ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for _DOC in ${DOCS_SUB_DIR}
+ @${MKDIR} ${DOCSDIR}/${_DOC}
+.endfor
+ @${ECHO_CMD} "=> Installing manuals to ${DOCSDIR}"
+ @cd ${WRKSRC}/manual && ${FIND} * -type f -exec ${INSTALL} -c -m 644 "{}" "${DOCSDIR}/{}" \;
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for _EXAMPLE in ${EXAMPLES_SUB_DIR}
+ @${MKDIR} ${EXAMPLESDIR}/${_EXAMPLE}
+.endfor
+ @${ECHO_CMD} "=> Installing examples to ${EXAMPLESDIR}"
+ @cd ${WRKSRC}/example && ${FIND} * -type f -exec ${INSTALL} -c -m 644 "{}" "${EXAMPLESDIR}/{}" \;
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/simplehtmldom/distinfo b/textproc/simplehtmldom/distinfo
new file mode 100644
index 000000000000..db717807dfff
--- /dev/null
+++ b/textproc/simplehtmldom/distinfo
@@ -0,0 +1,3 @@
+MD5 (simplehtmldom_1_11.zip) = 0cb34bda21e3cf71c77ec9914322ac46
+SHA256 (simplehtmldom_1_11.zip) = 2959d456943d4cace8377b64b3d85e6b32bb0efb3a0fae303c22c5b0f348a8e2
+SIZE (simplehtmldom_1_11.zip) = 42274
diff --git a/textproc/simplehtmldom/pkg-descr b/textproc/simplehtmldom/pkg-descr
new file mode 100644
index 000000000000..37de9f19bb64
--- /dev/null
+++ b/textproc/simplehtmldom/pkg-descr
@@ -0,0 +1,9 @@
+PHP Simple HTML DOM Parser is a HTML DOM parser written in PHP5+,
+and it let you manipulate HTML in a very easy way!
+
+Features:
+ * Supports invalid HTML.
+ * Find tags on an HTML page with selectors just like jQuery.
+ * Extract contents from HTML in a single line.
+
+WWW: http://simplehtmldom.sourceforge.net/
diff --git a/textproc/simplehtmldom/pkg-message b/textproc/simplehtmldom/pkg-message
new file mode 100644
index 000000000000..4609bc7ddfb4
--- /dev/null
+++ b/textproc/simplehtmldom/pkg-message
@@ -0,0 +1,8 @@
+*************************************************************************
+You can add the library path ( DEFAULT: ${PREFIX}/share/simplehtmldom )
+to the "include_path=" directive in your php.ini file
+( DEFAULT: ${PREFIX}/etc/php.ini ), such as:
+
+ include_path = ".:${PREFIX}/share/simplehtmldom"
+
+*************************************************************************
diff --git a/textproc/simplehtmldom/pkg-plist b/textproc/simplehtmldom/pkg-plist
new file mode 100644
index 000000000000..40b20ce62740
--- /dev/null
+++ b/textproc/simplehtmldom/pkg-plist
@@ -0,0 +1,25 @@
+%%DATADIR%%/simple_html_dom.php
+%%PORTDOCS%%%%DOCSDIR%%/css/default.css
+%%PORTDOCS%%%%DOCSDIR%%/css/ui.tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/img/tab.png
+%%PORTDOCS%%%%DOCSDIR%%/js/jquery-1.2.3.pack.js
+%%PORTDOCS%%%%DOCSDIR%%/js/ui.tabs.pack.js
+%%PORTDOCS%%%%DOCSDIR%%/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/manual_api.htm
+%%PORTDOCS%%%%DOCSDIR%%/manual_faq.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_advanced_selector.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_basic_selector.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_callback.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_extract_html.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_modify_contents.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scraping/example_scraping_digg.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scraping/example_scraping_imdb.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scraping/example_scraping_slashdot.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_html_dom_utility.php
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/js
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/img
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/css
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/scraping
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%