aboutsummaryrefslogtreecommitdiff
path: root/ukrainian
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-25 17:38:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-25 17:38:38 +0000
commit0a171f27927fd5e1ac486b3d264910eb59c3b2cb (patch)
tree35b1c856a112fb60a28a6c62de270624462830bc /ukrainian
parentb3f74fa24504e4ce1127cc03a76b241ec8f53230 (diff)
downloadports-0a171f27927fd5e1ac486b3d264910eb59c3b2cb.tar.gz
ports-0a171f27927fd5e1ac486b3d264910eb59c3b2cb.zip
- Fix build on 4.x
Submitted by: maintainer Reported by: bento via kris
Notes
Notes: svn path=/head/; revision=99106
Diffstat (limited to 'ukrainian')
-rw-r--r--ukrainian/iceb/Makefile1
-rw-r--r--ukrainian/iceb/files/patch-libdev-iceb_client.c12
-rw-r--r--ukrainian/iceb/files/patch-libutil::workid.c2
3 files changed, 14 insertions, 1 deletions
diff --git a/ukrainian/iceb/Makefile b/ukrainian/iceb/Makefile
index d944383d433b..d596a4452efc 100644
--- a/ukrainian/iceb/Makefile
+++ b/ukrainian/iceb/Makefile
@@ -22,6 +22,7 @@ USE_AUTOCONF= yes
USE_AUTOMAKE= yes
USE_REINPLACE= yes
USE_BZIP2= yes
+USE_GETOPT_LONG=yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
--with-lang=ua \
diff --git a/ukrainian/iceb/files/patch-libdev-iceb_client.c b/ukrainian/iceb/files/patch-libdev-iceb_client.c
new file mode 100644
index 000000000000..e2a7de7963b6
--- /dev/null
+++ b/ukrainian/iceb/files/patch-libdev-iceb_client.c
@@ -0,0 +1,12 @@
+--- iceb_client.c.old Sat Jan 24 23:05:19 2004
++++ libdev/iceb_client.c Sat Jan 24 23:05:37 2004
+@@ -6,8 +6,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <netdb.h>
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <ctype.h>
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
diff --git a/ukrainian/iceb/files/patch-libutil::workid.c b/ukrainian/iceb/files/patch-libutil::workid.c
index 78b3af8177d4..428164f02eb6 100644
--- a/ukrainian/iceb/files/patch-libutil::workid.c
+++ b/ukrainian/iceb/files/patch-libutil::workid.c
@@ -76,7 +76,7 @@
- return(ttyname_b);
+char* workid() {
+ // get host name
-+ static const long length = sysconf(_SC_HOST_NAME_MAX);
++ static const long length = 1024; //sysconf(_SC_HOST_NAME_MAX);
+ char host[length];
+ host[0] = '\0';
+ gethostname(host, length);