aboutsummaryrefslogtreecommitdiff
path: root/vietnamese
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1996-12-09 02:07:06 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1996-12-09 02:07:06 +0000
commitc972382ac4f689502206b606ecc7b1aa24389829 (patch)
tree5b45da461775953a1fe641217448d44f4c535da9 /vietnamese
parent069531a1b9b04d6c3648199204f2045051357427 (diff)
downloadports-c972382ac4f689502206b606ecc7b1aa24389829.tar.gz
ports-c972382ac4f689502206b606ecc7b1aa24389829.zip
Vnpstext converts your 8-bit Vietnamese text to a PostScript
file suitable for printing to a PostScript printer.
Notes
Notes: svn path=/head/; revision=4906
Diffstat (limited to 'vietnamese')
-rw-r--r--vietnamese/vnpstext/Makefile29
-rw-r--r--vietnamese/vnpstext/distinfo1
-rw-r--r--vietnamese/vnpstext/files/patch-0112
-rw-r--r--vietnamese/vnpstext/files/patch-0211
-rw-r--r--vietnamese/vnpstext/files/patch-0322
-rw-r--r--vietnamese/vnpstext/files/patch-0420
-rw-r--r--vietnamese/vnpstext/files/vnpstext.1131
-rw-r--r--vietnamese/vnpstext/pkg-comment1
-rw-r--r--vietnamese/vnpstext/pkg-descr11
-rw-r--r--vietnamese/vnpstext/pkg-plist11
10 files changed, 249 insertions, 0 deletions
diff --git a/vietnamese/vnpstext/Makefile b/vietnamese/vnpstext/Makefile
new file mode 100644
index 000000000000..d1ebc2c3bd1d
--- /dev/null
+++ b/vietnamese/vnpstext/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: vnpstext
+# Version required: 1.1
+# Date created: Sat Dec 7, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.1.1.1 1996/08/09 04:17:16 asami Exp $
+#
+
+DISTNAME= vnpstext
+PKGNAME= vn-vnpstext-1.1
+CATEGORIES= vietnamese
+MASTER_SITES= ftp://ftp.media.mit.edu/pub/Vietnet/Viscii/Unix/ \
+ ftp://ftp.monash.edu.au/pub/vietnam/unix/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+CFLAGS+= -I../../include
+MAN1= vnpstext.1
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/vn-fonts
+ ${INSTALL_PROGRAM} ${WRKSRC}/vnpstext ${PREFIX}/bin
+ (cd ${WRKSRC} ; \
+ ${INSTALL_DATA} *.ps prologs/*.pro ${PREFIX}/share/vn-fonts)
+ ${INSTALL_MAN} ${WRKSRC}/vnpstext.1V ${PREFIX}/man/man1/vnpstext.1
+
+.include <bsd.port.mk>
diff --git a/vietnamese/vnpstext/distinfo b/vietnamese/vnpstext/distinfo
new file mode 100644
index 000000000000..46355d04695b
--- /dev/null
+++ b/vietnamese/vnpstext/distinfo
@@ -0,0 +1 @@
+MD5 (vnpstext.tar.Z) = ef83a2ce219fea5fe37e79882174e535
diff --git a/vietnamese/vnpstext/files/patch-01 b/vietnamese/vnpstext/files/patch-01
new file mode 100644
index 000000000000..4ba0f6bc6edc
--- /dev/null
+++ b/vietnamese/vnpstext/files/patch-01
@@ -0,0 +1,12 @@
+--- Makefile.orig Thu May 14 21:59:59 1992
++++ Makefile Sat Dec 7 23:15:47 1996
+@@ -4,7 +4,8 @@
+
+ .SUFFIXES: .src .ps .pro
+
+-DEFAULT_PSLIBDIR = "\"/usr/local/lib/ps\""
++#DEFAULT_PSLIBDIR = "\"/usr/local/lib/ps\""
++DEFAULT_PSLIBDIR = "\"$(PREFIX)/share/vn-fonts\""
+
+ SHELL = /bin/sh
+ VNLIBDIR= ../lib
diff --git a/vietnamese/vnpstext/files/patch-02 b/vietnamese/vnpstext/files/patch-02
new file mode 100644
index 000000000000..49ea510cc22c
--- /dev/null
+++ b/vietnamese/vnpstext/files/patch-02
@@ -0,0 +1,11 @@
+--- ../lib/vntype/Makefile.orig Sat Jun 6 00:05:40 1992
++++ ../lib/vntype/Makefile Sat Dec 7 23:17:27 1996
+@@ -15,7 +15,7 @@
+ #FLAGS = -DNOANSI_C
+ CFLAGS = $(FLAGS) $(INC)
+ CC = cc
+-CPP = /lib/cpp
++CPP = cpp
+
+ .c.o:
+ $(CC) $(CFLAGS) -c $*.c
diff --git a/vietnamese/vnpstext/files/patch-03 b/vietnamese/vnpstext/files/patch-03
new file mode 100644
index 000000000000..881d35319534
--- /dev/null
+++ b/vietnamese/vnpstext/files/patch-03
@@ -0,0 +1,22 @@
+--- vnpstext.c.orig Wed Sep 2 14:01:59 1992
++++ vnpstext.c Sun Dec 8 01:24:48 1996
+@@ -86,7 +86,8 @@
+ dofile(input)
+ FILE *input;
+ {
+- u_char line[1024];
++#define LINESIZE 1024
++ u_char line[LINESIZE];
+ register u_char *s;
+ register int pageno = 1;
+ register short col = 0;
+@@ -95,7 +96,8 @@
+
+ printf("StartDoc\n");
+
+- while (gets(line)) {
++ while (fgets(line, LINESIZE, stdin)) {
++ if (line[ strlen(line) - 1 ] == '\n') line[ strlen(line) - 1 ] = '\0';
+ if (!*line) printf("B\n");
+ else {
+
diff --git a/vietnamese/vnpstext/files/patch-04 b/vietnamese/vnpstext/files/patch-04
new file mode 100644
index 000000000000..6ac41ff2d8c0
--- /dev/null
+++ b/vietnamese/vnpstext/files/patch-04
@@ -0,0 +1,20 @@
+--- vnpstext.1V.orig Thu May 14 21:43:57 1992
++++ vnpstext.1V Sun Dec 8 02:13:22 1996
+@@ -41,7 +41,7 @@
+ .PP
+ The location of the prolog file can either be
+ the current directory, or in
+-.I /usr/local/lib/ps.
++.I /usr/local/share/vn-fonts.
+ The latter setting may be overridden by
+ the environment variable
+ .I PSLIBDIR.
+@@ -113,7 +113,7 @@
+ Lines are not wrapped. If a line is too long to
+ fit across a page width, it is truncated (by the printer).
+ .SH FILES
+-.IP \fI/usr/local/lib/ps:\fP 20m
++.IP \fI/usr/local/share/vn-fonts:\fP 20m
+ default prolog search directory
+ .IP \fIinitcour.ps:\fP 20m
+ Vietnamese Courier font file to download to the printer.
diff --git a/vietnamese/vnpstext/files/vnpstext.1 b/vietnamese/vnpstext/files/vnpstext.1
new file mode 100644
index 000000000000..2971bbed867f
--- /dev/null
+++ b/vietnamese/vnpstext/files/vnpstext.1
@@ -0,0 +1,131 @@
+.\" to view this file, use: nroff -man vnpstext.1V | more
+.\" @(#)vnpstext.1V 2.2 (TriChlor) 5/14/92 21:43:55
+.\"
+.TH vnpstext 1V
+.SH NAME
+vnpstext \- PostScript filter for Vietnamese text printing
+.SH SYNTAX
+.B vnpstext
+[\fB-i <prologfile>\fP]
+[input_8-bit_VISCII_file(s) ...]
+.SH DESCRIPTION
+.NXR "vnpstext command"
+.PP
+The
+.PN vnpstext
+command operates much like the
+.MS pstext 1PS
+command: it reads a text file from standard input,
+and outputs the text in a format suitable for sending
+directly to a PostScript printer. A typical invocation
+is:
+.EX
+% vnpstext 8-bit-vietnamese-file | lpr -PPostScript
+.EE
+.PN Vnpstext
+expects the Vietnamese font (by default, Courier-VN)
+to have been downloaded to the PostScript printer.
+This will be discussed further below.
+.PP
+Without any arguments,
+.PN vnpstext
+will use the font Courier-VN at 10-point size.
+You may change this by specifying an appropriate
+prolog file. As of this date (5/92), the prolog files
+available with
+.I vnpstext
+are cour10.pro (default), cour12.pro, cour17.pro,
+cour10b.pro, cour12b.pro, cour17b.pro, which use
+Vietnamese Courier fonts at 10-, 12-, and 17-point
+sizes in normal and bold faces, respectively.
+.PP
+The location of the prolog file can either be
+the current directory, or in
+.I /usr/local/lib/ps.
+The latter setting may be overridden by
+the environment variable
+.I PSLIBDIR.
+.SH OPTIONS
+.IP "\fI-i <prologfile>\fP" 20m
+use the specified prolog file
+instead of generating the default (cour10.pro).
+.PP
+The prolog file is searched relative to the directory
+specified by PSLIBDIR, or the current working
+directory if PSLIBDIR is not set in the environment.
+If the prolog file name starts with the '/' character,
+it is assumed to be an absolute path name and
+PSLIBDIR is ignored.
+.SH USAGE NOTES
+.PN Vnpstext
+expects the font you use to have been downloaded
+to the printer. To do this, send it the appropriate
+font installation file. As of this date (5/92), the following
+are available with
+.PN vnpstext:
+initcour.ps and initcourb.ps, which will download
+the Vietnamese Courier and Courier-Bold fonts
+to the printer. The font sizes are continuously
+scalable and is specified in the prolog file.
+.PP
+The downloaded font will persist
+until the next time the printer is power cycled.
+Also, note that the PS engine requires that a password
+be supplied for this kind of operation to take place;
+the password is normally "0" unless it is changed
+by the user. This assumption is made in the
+init*.ps files.
+If the printer password is something other than "0",
+modify these files
+accordingly before sending it to the printer.
+.SH EXAMPLES
+To print out a mail message that contains 7-bit VIQR data,
+you might use:
+.EX
+% vn7to8 -m input_file | vnpstext | lpr -PPostScript
+.EE
+The
+.I -m
+option to
+.MS vn7to8 1V
+tells it to start out assuming English mode.
+.PP
+Or if the message contain Viet-Net style Vietnamese but is not
+necessarily VIQR-compliant in that it does not explicitly
+specify the Vietnamese language state with the sequence "\V":
+.EX
+% vn7to8 -v input_file | vnpstext | lpr -PPostScript
+.EE
+.PP
+Two sample shell scripts are provided
+to facilitate Vietnamese printing:
+.PN vnlpr7
+and
+.PN vnlpr8
+which performs the necessary conversions
+to print 7-bit VIQR and 8-bit VISCII
+data, respectively. See the contents
+of those shell scripts for usage details.
+.SH RESTRICTIONS
+.IP -
+The line length is limited to 1024 characters.
+.IP -
+Lines are not wrapped. If a line is too long to
+fit across a page width, it is truncated (by the printer).
+.SH FILES
+.IP \fI/usr/local/lib/ps:\fP 20m
+default prolog search directory
+.IP \fIinitcour.ps:\fP 20m
+Vietnamese Courier font file to download to the printer.
+.IP \fIinitcourb.ps:\fP 20m
+Vietnamese Courier-Bold font file to download to the printer.
+.IP \fIcour*.pro:\fP 20m
+Various prolog files which specify non-default values
+for font face and size.
+.SH AUTHOR
+The TriChlor Group, TriChlor@haydn.Stanford.EDU.
+.br
+Thanks also to Nam Chan Phamdo (nam@src.umd.edu)
+for pointing out the lines-per-page bug (which has been fixed!)
+.SH "SEE ALSO"
+vn7to8(1V), vnelvis(1V), pstext(1PS)
diff --git a/vietnamese/vnpstext/pkg-comment b/vietnamese/vnpstext/pkg-comment
new file mode 100644
index 000000000000..ad077158391f
--- /dev/null
+++ b/vietnamese/vnpstext/pkg-comment
@@ -0,0 +1 @@
+converts 8-bit VISCII Vietnamese text into PostScript
diff --git a/vietnamese/vnpstext/pkg-descr b/vietnamese/vnpstext/pkg-descr
new file mode 100644
index 000000000000..e5f1c697d618
--- /dev/null
+++ b/vietnamese/vnpstext/pkg-descr
@@ -0,0 +1,11 @@
+Tha^n cha`o ca'c ba.n,
+
+ Vnpstext converts your 8-bit Vietnamese text to a PostScript
+ file suitable for printing to a PostScript printer. To use it
+ you need to have an 8-bit Vietnamese text file, which may be
+ created with an editor like Vnelvis, or converted from Viet-Std
+ 7-bit (quoted-readable) format using Vn7to8.
+
+
+David O'Brien
+obrien@cs.ucdavis.edu
diff --git a/vietnamese/vnpstext/pkg-plist b/vietnamese/vnpstext/pkg-plist
new file mode 100644
index 000000000000..74204e43c539
--- /dev/null
+++ b/vietnamese/vnpstext/pkg-plist
@@ -0,0 +1,11 @@
+bin/vnpstext
+man/man1/vnpstext.1.gz
+share/vn-fonts/initcour.ps
+share/vn-fonts/initcourb.ps
+share/vn-fonts/cour10.pro
+share/vn-fonts/cour10b.pro
+share/vn-fonts/cour12.pro
+share/vn-fonts/cour12b.pro
+share/vn-fonts/cour17.pro
+share/vn-fonts/cour17b.pro
+