aboutsummaryrefslogtreecommitdiff
path: root/www/Mosaic
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-04-11 09:07:31 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-04-11 09:07:31 +0000
commita2463130837b77388447c41a678da98781fad82b (patch)
treefa7acd29cac7c14a4f1ce06a72948b05686d16f5 /www/Mosaic
parent6d95a9f6325d706d8e6bcba86972363731ca1f60 (diff)
downloadports-a2463130837b77388447c41a678da98781fad82b.tar.gz
ports-a2463130837b77388447c41a678da98781fad82b.zip
Upgrade, 2.7b2 -> 2.7b4. Also make it conform to Motif standard here.
Notes
Notes: svn path=/head/; revision=2970
Diffstat (limited to 'www/Mosaic')
-rw-r--r--www/Mosaic/Makefile26
-rw-r--r--www/Mosaic/distinfo2
-rw-r--r--www/Mosaic/files/patch-aa331
-rw-r--r--www/Mosaic/files/patch-ad30
-rw-r--r--www/Mosaic/files/patch-ae54
-rw-r--r--www/Mosaic/files/patch-ag30
-rw-r--r--www/Mosaic/pkg-plist1
7 files changed, 101 insertions, 373 deletions
diff --git a/www/Mosaic/Makefile b/www/Mosaic/Makefile
index a642ecf6d08d..90042ec73eb5 100644
--- a/www/Mosaic/Makefile
+++ b/www/Mosaic/Makefile
@@ -1,25 +1,31 @@
# New ports collection makefile for: Mosaic browser
-# Version required: 2.7b2
+# Version required: 2.7b4
# Date created: 7 August 1995
# Whom: torstenb
#
-# $Id: Makefile,v 1.6 1995/12/05 05:12:48 ache Exp $
+# $Id: Makefile,v 1.7 1996/02/19 21:39:24 ache Exp $
#
-DISTNAME= Mosaic-src-2.7b2
-PKGNAME= mosaic-2.7b2
-CATEGORIES= www
-EXTRACT_SUFX= .tar.Z
-
+DISTNAME= Mosaic-src-2.7b4
+PKGNAME= mosaic-2.7b4
+CATEGORIES+= www
MASTER_SITES= ftp://ftp.ncsa.uiuc.edu/Web/Mosaic/Unix/source/
-LIB_DEPENDS+= jpeg\\.6\\.:${PORTSDIR}/graphics/jpeg
-LIB_DEPENDS+= png\\.0\\.:${PORTSDIR}/graphics/png
+LIB_DEPENDS= jpeg\\.6\\.:${PORTSDIR}/graphics/jpeg \
+ png\\.0\\.:${PORTSDIR}/graphics/png \
+ z\\.1\\.:${PORTSDIR}/devel/libz
+
+REQUIRES_MOTIF= yes
WRKSRC= ${WRKDIR}/Mosaic-src
-ALL_TARGET= default
+ALL_TARGET= bsdi
+USE_X11= yes
# don't waste diskspace
post-extract:
@rm -rf ${WRKSRC}/libjpeg ${WRKSRC}/libpng
+do-install:
+ ${INSTALL} -c -s -g ${BINGRP} -m ${BINMODE} -o ${BINOWN} ${WRKSRC}/src/Mosaic ${PREFIX}/bin/Mosaic
+ ${INSTALL} -c -g ${BINGRP} -m ${NOBINMODE} -o ${BINOWN} ${WRKSRC}/app-defaults.color ${PREFIX}/lib/X11/app-defaults/Mosaic
+
.include <bsd.port.mk>
diff --git a/www/Mosaic/distinfo b/www/Mosaic/distinfo
index ac2490026e00..1a37c82a83c1 100644
--- a/www/Mosaic/distinfo
+++ b/www/Mosaic/distinfo
@@ -1 +1 @@
-MD5 (Mosaic-src-2.7b2.tar.Z) = d92163341415d922314c8524095f7076
+MD5 (Mosaic-src-2.7b4.tar.gz) = d58669c4ee91a3758684dbfc69e6aea3
diff --git a/www/Mosaic/files/patch-aa b/www/Mosaic/files/patch-aa
index 18064d719ac5..31da312667f9 100644
--- a/www/Mosaic/files/patch-aa
+++ b/www/Mosaic/files/patch-aa
@@ -1,270 +1,61 @@
-*** Makefile.orig Thu Oct 19 01:12:16 1995
---- Makefile Tue Dec 5 07:19:09 1995
-***************
-*** 10,22 ****
-
- prereleaseflags = -DPRERELEASE
-
-! RANLIB = /bin/true
- #### On non-SGI's, this should be ranlib.
- RANLIB = ranlib
-
- CC = cc
- #### On Sun's, this should be gcc (ANSI required).
-! CC = gcc
-
- #### Linker Flags -- Primarily for linking static on linux-elf.
- #ldflags = -static
---- 10,22 ----
-
- prereleaseflags = -DPRERELEASE
-
-! #RANLIB = /bin/true
- #### On non-SGI's, this should be ranlib.
- RANLIB = ranlib
-
- CC = cc
- #### On Sun's, this should be gcc (ANSI required).
-! #CC = gcc
-
- #### Linker Flags -- Primarily for linking static on linux-elf.
- #ldflags = -static
-***************
-*** 24,30 ****
-
- #### For a few files in the source, some compilers may need to be kicked
- #### in K&R mode. E.g., on SGI's, -cckr does this.
-! knrflag = -cckr
- #### On most systems, no flag is needed.
- knrflag =
-
---- 24,30 ----
-
- #### For a few files in the source, some compilers may need to be kicked
- #### in K&R mode. E.g., on SGI's, -cckr does this.
-! #knrflag = -cckr
- #### On most systems, no flag is needed.
- knrflag =
-
-***************
-*** 40,49 ****
- #### For Convex whatever, do -DCONVEX
- #### For SCO ODT 3.0, do -DSCO -DSVR4 -DMOTIF1_2
- #### For Motorola SVR4, do -DSVR4 -DMOTOROLA -DMOTIF1_2
-! sysconfigflags =
-
- #### System libraries.
-! syslibs = -lPW -lsun -lmalloc
- #### For AIX 3.2
- # syslibs = -lPW -lbsd
- #### For most other Motif platforms:
---- 40,49 ----
- #### For Convex whatever, do -DCONVEX
- #### For SCO ODT 3.0, do -DSCO -DSVR4 -DMOTIF1_2
- #### For Motorola SVR4, do -DSVR4 -DMOTOROLA -DMOTIF1_2
-! sysconfigflags = -DMOTIF1_2
-
- #### System libraries.
-! #syslibs = -lPW -lsun -lmalloc
- #### For AIX 3.2
- # syslibs = -lPW -lbsd
- #### For most other Motif platforms:
-***************
-*** 73,84 ****
- # xinc = -I/usr/include/X11
- #### BSD/386
- # xinc = -I/usr/X11/include
-! xinc = -I/xdev/mosaic/X11R5/include
-
- #### X library locations.
- # xlibs = -lXm_s -lXmu -lXt_s -lX11_s
- #### For Sun's (at least running stock X/Motif as installed on our machines):
-! xlibs = /xdev/mosaic/X11R5/lib/libXm.a /xdev/mosaic/X11R5/lib/libXmu.a /xdev/mosaic/X11R5/lib/libXt.a /xdev/mosaic/X11R5/lib/libXext.a /xdev/mosaic/X11R5/lib/libX11.a -lm
- #### For HP-UX 8.00:
- # xlibs = -L/usr/lib/Motif1.1 -lXm -L/usr/lib/X11R4 -lXmu -lXt -lX11
- #### For HP-UX 9.01: The X11R5 libraries are here on our systems
---- 73,85 ----
- # xinc = -I/usr/include/X11
- #### BSD/386
- # xinc = -I/usr/X11/include
-! #xinc = -I/xdev/mosaic/X11R5/include
-! xinc = -I/usr/X11R6/include
-
- #### X library locations.
- # xlibs = -lXm_s -lXmu -lXt_s -lX11_s
- #### For Sun's (at least running stock X/Motif as installed on our machines):
-! #xlibs = /xdev/mosaic/X11R5/lib/libXm.a /xdev/mosaic/X11R5/lib/libXmu.a /xdev/mosaic/X11R5/lib/libXt.a /xdev/mosaic/X11R5/lib/libXext.a /xdev/mosaic/X11R5/lib/libX11.a -lm
- #### For HP-UX 8.00:
- # xlibs = -L/usr/lib/Motif1.1 -lXm -L/usr/lib/X11R4 -lXmu -lXt -lX11
- #### For HP-UX 9.01: The X11R5 libraries are here on our systems
-***************
-*** 97,102 ****
---- 98,109 ----
- # xlibs = -L/usr/X11/lib -lXm -lXmu -lXt -lX11
- #### For Motorola SVR4:
- # xlibs = -lXm -lXmu -lXt -lXext -lX11 -lm
-+ #### For FreeBSD 2.x:
-+ .if !exists(/usr/X11R6/lib/libXm.a)
-+ xlibs = -L/usr/X11R6/lib -lXm -lXmu -lXt -lXext -lX11 -lm
-+ .else
-+ xlibs = -L/usr/X11R6/lib /usr/X11R6/lib/libXm.a -lXmu -lXt -lXext -lX11 -lm
-+ .endif
-
-
- #### DTM AND HDF SUPPORT; READ CAREFULLY
-***************
-*** 116,138 ****
- #### If your platform is not one of the above, then either do not compile
- #### with HDF/DTM support or try hacking libdtm/makefile.
-
-! dtmmachtype = sun
-! dtmdirs = libdtm libnet
-! dtmlibs = ../libnet/libnet.a ../libdtm/libdtm.a
-! dtmflags = -DHAVE_DTM -I.. -I../libnet
-! hdfdir = /hdf2/install/sun
-! hdflibs = $(hdfdir)/lib/libnetcdf.a $(hdfdir)/lib/libdf.a
-! hdfflags = -DHAVE_HDF -DHDF -I$(hdfdir)/include
-
-
- #### PNG SUPPORT
- #### For inline PNG support, the following should be defined:
- #### The libraries currently used are PNGLIB 0.81 and ZLIB 0.95
-
-! pngdir = /xdev/mosaic/libpng/sun
- pnglibdir = $(pngdir)/lib
- pngincludedir = $(pngdir)/include
-! pnglibs = $(pnglibdir)/libpng.a $(pnglibdir)/libz.a -lm
- pngflags = -I$(pngincludedir) -DHAVE_PNG
-
-
---- 123,148 ----
- #### If your platform is not one of the above, then either do not compile
- #### with HDF/DTM support or try hacking libdtm/makefile.
-
-! #dtmmachtype = sun
-! #dtmdirs = libdtm libnet
-! #dtmlibs = ../libnet/libnet.a ../libdtm/libdtm.a
-! #dtmflags = -DHAVE_DTM -I.. -I../libnet
-! #hdfdir = /hdf2/install/sun
-! #hdflibs = $(hdfdir)/lib/libnetcdf.a $(hdfdir)/lib/libdf.a
-! #hdfflags = -DHAVE_HDF -DHDF -I$(hdfdir)/include
-
-
- #### PNG SUPPORT
- #### For inline PNG support, the following should be defined:
- #### The libraries currently used are PNGLIB 0.81 and ZLIB 0.95
-
-! #pngdir = /xdev/mosaic/libpng/sun
-! pngdir = /usr/local
- pnglibdir = $(pngdir)/lib
- pngincludedir = $(pngdir)/include
-! #pnglibs = $(pnglibdir)/libpng.a $(pnglibdir)/libz.a -lm
-! #pngflags = -I$(pngincludedir) -DHAVE_PNG
-! pnglibs = -L$(pnglibdir) -lpng -lz -lm
- pngflags = -I$(pngincludedir) -DHAVE_PNG
-
-
-***************
-*** 140,147 ****
- #### For inline JPEG support, the following should be defined:
- #### The library used is Independent JPEG Group (IJG's) 5.0a.
-
-! jpegdir = /xdev/mosaic/libjpeg/sun
-! jpeglibs = $(jpegdir)/lib/libjpeg.a
- jpegflags = -I$(jpegdir)/include -DHAVE_JPEG
-
-
---- 150,159 ----
- #### For inline JPEG support, the following should be defined:
- #### The library used is Independent JPEG Group (IJG's) 5.0a.
-
-! #jpegdir = /xdev/mosaic/libjpeg/sun
-! jpegdir = /usr/local
-! #jpeglibs = $(jpegdir)/lib/libjpeg.a
-! jpeglibs = -L$(jpegdir)/lib -ljpeg
- jpegflags = -I$(jpegdir)/include -DHAVE_JPEG
-
-
-***************
-*** 154,167 ****
- #### define the KRB-ENCRYPT flag.
-
- ##krb4dir = /usr/athena
-! krb4dir = /xdev/mosaic/libkrb4/sun
-! krb4libs = $(krb4dir)/lib/libkrb.a $(krb4dir)/lib/libdes.a
-! krb4flags = -DKRB4 -I$(krb4dir)/include
-
- ##krb5dir = /krb5
-! krb5dir = /xdev/mosaic/libkrb5/sun
-! krb5libs = $(krb5dir)/lib/libkrb5.a $(krb5dir)/lib/libcrypto.a $(krb5dir)/util/et/libcom_err.a
-! krb5flags = -DKRB5 -I$(krb5dir)/include -I$(krb5dir)/include/krb5
-
- #Do not comment out.
- krbflags = $(krb4flags) $(krb5flags)
---- 166,179 ----
- #### define the KRB-ENCRYPT flag.
-
- ##krb4dir = /usr/athena
-! #krb4dir = /xdev/mosaic/libkrb4/sun
-! #krb4libs = $(krb4dir)/lib/libkrb.a $(krb4dir)/lib/libdes.a
-! #krb4flags = -DKRB4 -I$(krb4dir)/include
-
- ##krb5dir = /krb5
-! #krb5dir = /xdev/mosaic/libkrb5/sun
-! #krb5libs = $(krb5dir)/lib/libkrb5.a $(krb5dir)/lib/libcrypto.a $(krb5dir)/util/et/libcom_err.a
-! #krb5flags = -DKRB5 -I$(krb5dir)/include -I$(krb5dir)/include/krb5
-
- #Do not comment out.
- krbflags = $(krb4flags) $(krb5flags)
-***************
-*** 183,192 ****
-
- #### -lm is required for freeWAIS 0.5, as ceil() is used.
-
-! waisroot = /xdev/mosaic/freeWAIS/sun4
-! waisflags = -DDIRECT_WAIS -I$(waisroot)/include
-! waislibdir = $(waisroot)/bin
-! waislibs = $(waislibdir)/inv.a $(waislibdir)/wais.a $(waislibdir)/libftw.a -lm
-
-
- #### Customization flags:
---- 195,204 ----
-
- #### -lm is required for freeWAIS 0.5, as ceil() is used.
-
-! #waisroot = /xdev/mosaic/freeWAIS/sun4
-! #waisflags = -DDIRECT_WAIS -I$(waisroot)/include
-! #waislibdir = $(waisroot)/bin
-! #waislibs = $(waislibdir)/inv.a $(waislibdir)/wais.a $(waislibdir)/libftw.a -lm
-
-
- #### Customization flags:
-***************
-*** 203,209 ****
- # ---------------------- END OF CUSTOMIZABLE OPTIONS -------------------------
-
-
-! CFLAGS = -g $(sysconfigflags) $(prereleaseflags)
-
- # Don't worry about these -- for development purposes only.
- PURIFY = purify
---- 215,221 ----
- # ---------------------- END OF CUSTOMIZABLE OPTIONS -------------------------
-
-
-! CFLAGS += $(sysconfigflags) $(prereleaseflags)
-
- # Don't worry about these -- for development purposes only.
- PURIFY = purify
-***************
-*** 215,220 ****
---- 227,235 ----
- @echo \*\*\* Welcome to Purify'd NCSA Mosaic.
- quantifyd: $(dtmdirs) libwww2 libXmx libhtmlw libnut src-quantifyd
- @echo \*\*\* Welcome to Quantify'd NCSA Mosaic.
-+
-+ install:
-+ $(INSTALL) -c -s -g $(BINGRP) -m $(BINMODE) -o $(BINOWN) src/Mosaic ${PREFIX}/bin/Mosaic
-
- libXmx::
- @echo --- Building libXmx
+--- ./makefiles/Makefile.bsdi.org Tue Mar 26 21:25:13 1996
++++ ./makefiles/Makefile.bsdi Tue Apr 9 22:59:08 1996
+@@ -36,11 +36,11 @@
+ sysconfigflags = -DMOTIF1_2
+
+ #### System libraries.
+-syslibs = -lipc
++#syslibs = -lipc
+
+ #### X include file locations -- if your platform puts the X include
+-xinc = -I/usr/X11/include
+-xlibs = -L/usr/X11/lib -lXm -lXmu -lXt -lXext -lSM -lICE -lXpm -lX11
++xinc = -I${X11BASE}/include
++xlibs = ${MOTIFLIB} -L${X11BASE}/lib -lXmu -lXt -lXext -lSM -lICE -lXpm -lX11
+
+
+ #### DTM AND HDF SUPPORT; READ CAREFULLY
+@@ -73,10 +73,10 @@
+ #### For inline PNG support, the following should be defined:
+ #### The libraries currently used are PNGLIB 0.81 and ZLIB 0.95
+
+-pngdir = /xdev/mosaic/libpng/bsdi
++pngdir = ${LOCALBASE}
+ pnglibdir = $(pngdir)/lib
+ pngincludedir = $(pngdir)/include
+-pnglibs = $(pnglibdir)/libpng.a $(pnglibdir)/libz.a -lm
++pnglibs = -L$(pnglibdir) -lpng -lz -lm
+ pngflags = -I$(pngincludedir) -DHAVE_PNG
+
+ #pngdir = /work2/mosaic-libs/libpng
+@@ -90,9 +90,9 @@
+ #### For inline JPEG support, the following should be defined:
+ #### The library used is Independent JPEG Group (IJG's) 5.0a.
+
+-jpegdir = /work2/mosaic-libs/libjpeg-6
+-jpeglibs = $(jpegdir)/libjpeg.a
+-jpegflags = -I$(jpegdir) -DHAVE_JPEG
++jpegdir = ${LOCALBASE}
++jpeglibs = -L$(jpegdir) -ljpeg
++jpegflags = -I$(jpegdir)/include -DHAVE_JPEG
+
+
+ #### KERBEROS SUPPORT
+@@ -154,7 +154,7 @@
+ # --------------------- Do Not Modify Below This Line ------------------------
+ #
+
+-CFLAGS = -g $(sysconfigflags) $(prereleaseflags)
++CFLAGS += $(sysconfigflags) $(prereleaseflags)
+
+ # Don't worry about these -- for development purposes only.
+ PURIFY = purify
+@@ -185,7 +185,7 @@
+
+ src::
+ @echo --- Building src
+- cd src; make CC=$(CC) RANLIB=$(RANLIB) LDFLAGS="$(ldflags)" CFLAGS="$(CFLAGS) $(customflags) $(xinc) $(jpegflags) $(dtmflags) $(hdfflags) $(pngflags) $(krbflags) -I.. -I../libXmx -I../libwww2" AUX_CFLAGS=$(knrflag) X_LIBS="$(xlibs)" SYS_LIBS="$(sockslibs) $(syslibs)" DTM_LIBS="$(dtmlibs)" HDF_LIBS="$(hdflibs)" WAIS_LIBS="$(waislibs)" LIBWWW_DIR=../libwww2 JPEG_LIBS="$(jpeglibs)" PNG_LIBS="$(pnglibs)" KRB_LIBS="$(krblibs)" LIBNUT_DIR=../libnut MOSAIC="Mosaic"
++ cd src; make CC=$(CC) RANLIB=$(RANLIB) LDFLAGS="$(ldflags)" CFLAGS="$(CFLAGS) $(customflags) $(xinc) -I.. -I../libXmx -I../libwww2 $(jpegflags) $(dtmflags) $(hdfflags) $(pngflags) $(krbflags)" AUX_CFLAGS=$(knrflag) X_LIBS="$(xlibs)" SYS_LIBS="$(sockslibs) $(syslibs)" DTM_LIBS="$(dtmlibs)" HDF_LIBS="$(hdflibs)" WAIS_LIBS="$(waislibs)" LIBWWW_DIR=../libwww2 JPEG_LIBS="$(jpeglibs)" PNG_LIBS="$(pnglibs)" KRB_LIBS="$(krblibs)" LIBNUT_DIR=../libnut MOSAIC="Mosaic"
+
+ src-purifyd::
+ @echo --- Building Purify'd src
diff --git a/www/Mosaic/files/patch-ad b/www/Mosaic/files/patch-ad
index 3b4d853e621c..4a86740c75b9 100644
--- a/www/Mosaic/files/patch-ad
+++ b/www/Mosaic/files/patch-ad
@@ -1,19 +1,11 @@
-*** src/xresources.h.orig Wed Oct 25 10:40:00 1995
---- src/xresources.h Tue Dec 5 06:11:22 1995
-***************
-*** 95,101 ****
- offset (confirm_exit), XtRString, "True" },
- /* THIS USED TO BE mailCommand BUT IS NOW sendmailCommand. */
- { "sendmailCommand", "SendmailCommand", XtRString, sizeof (char *),
-! offset (sendmail_command), XtRString, "/usr/lib/sendmail -t" },
- /* Ignore this. Stealth feature. */
- { "mailFilterCommand", "MailFilterCommand", XtRString, sizeof (char *),
- offset (mail_filter_command), XtRString, NULL },
---- 95,101 ----
- offset (confirm_exit), XtRString, "True" },
- /* THIS USED TO BE mailCommand BUT IS NOW sendmailCommand. */
- { "sendmailCommand", "SendmailCommand", XtRString, sizeof (char *),
-! offset (sendmail_command), XtRString, "/usr/sbin/sendmail -t" },
- /* Ignore this. Stealth feature. */
- { "mailFilterCommand", "MailFilterCommand", XtRString, sizeof (char *),
- offset (mail_filter_command), XtRString, NULL },
+--- ./src/xresources.h.org Tue Apr 9 21:41:26 1996
++++ ./src/xresources.h Tue Apr 9 21:43:12 1996
+@@ -94,7 +94,7 @@
+ { "confirmExit", "ConfirmExit", XtRBoolean, sizeof (Boolean),
+ offset (confirm_exit), XtRString, "True" },
+ /* THIS USED TO BE mailCommand BUT IS NOW sendmailCommand. */
+-#ifdef __bsdi__
++#if defined(__bsdi__) || defined(__FreeBSD__)
+ { "sendmailCommand", "SendmailCommand", XtRString, sizeof (char *),
+ offset (sendmail_command), XtRString, "/usr/sbin/sendmail -t" },
+ #else
diff --git a/www/Mosaic/files/patch-ae b/www/Mosaic/files/patch-ae
deleted file mode 100644
index fb7864511f27..000000000000
--- a/www/Mosaic/files/patch-ae
+++ /dev/null
@@ -1,54 +0,0 @@
-*** src/pixmaps.c.orig Thu Feb 2 17:56:46 1995
---- src/pixmaps.c Fri Nov 17 12:21:32 1995
-***************
-*** 397,412 ****
- * TrueColor displays. I have no access to such displays, so I
- * can't really test it.
- * Donated by - andrew@icarus.demon.co.uk
- */
- case 16:
- bit_data = (unsigned char *)malloc(size * 2);
- bitp = bit_data;
- datap = data;
- for (w = size; w > 0; w--)
- {
-! temp = (((colrs[(int)*datap].red >> 1) & 0x7c00) |
-! ((colrs[(int)*datap].green >> 6) & 0x03e0) |
-! ((colrs[(int)*datap].blue >> 11) & 0x001f));
-
- if (BitmapBitOrder(XtDisplay(wid)) == MSBFirst)
- {
---- 397,429 ----
- * TrueColor displays. I have no access to such displays, so I
- * can't really test it.
- * Donated by - andrew@icarus.demon.co.uk
-+ * modified by smp@csn.net for XFree86-3.1.x
- */
-+ case 15:
- case 16:
- bit_data = (unsigned char *)malloc(size * 2);
- bitp = bit_data;
- datap = data;
- for (w = size; w > 0; w--)
- {
-! if (depth == 15) /* weight == 555 */
-! {
-! temp = (((colrs[(int)*datap].red >> 1)
-! & 0x7c00) |
-! ((colrs[(int)*datap].green >> 6)
-! & 0x03e0) |
-! ((colrs[(int)*datap].blue >> 11)
-! & 0x001f));
-! }
-! else /* depth == 16, weight == 565 */
-! {
-! temp = ( (colrs[(int)*datap].red
-! & 0xf800) |
-! ((colrs[(int)*datap].green >> 5)
-! & 0x07e0) |
-! ((colrs[(int)*datap].blue >> 11)
-! & 0x001f));
-! }
-
- if (BitmapBitOrder(XtDisplay(wid)) == MSBFirst)
- {
diff --git a/www/Mosaic/files/patch-ag b/www/Mosaic/files/patch-ag
index 4dd833f207ae..b2a9496b23f4 100644
--- a/www/Mosaic/files/patch-ag
+++ b/www/Mosaic/files/patch-ag
@@ -1,19 +1,11 @@
-*** src/gui.c.bak Wed Oct 25 10:39:53 1995
---- src/gui.c Tue Dec 5 07:33:41 1995
-***************
-*** 2495,2501 ****
- return 0;
- else
- {
-! {char ans[10]; gets(ans);}
- /* All other errors are 'fatal'. */
- XGetErrorText (dsp, event->error_code, buf, 128);
- fprintf (stderr, "X Error: %s\n", buf);
---- 2495,2501 ----
- return 0;
- else
- {
-! {char ans[10]; fgets(ans, sizeof(ans), stdin);}
- /* All other errors are 'fatal'. */
- XGetErrorText (dsp, event->error_code, buf, 128);
- fprintf (stderr, "X Error: %s\n", buf);
+--- ./src/gui.c.org Tue Apr 9 21:47:32 1996
++++ ./src/gui.c Tue Apr 9 22:01:26 1996
+@@ -3623,7 +3623,7 @@
+ return 0;
+ else
+ {
+-{char ans[10]; printf("Press RETURN\n"); gets(ans);}
++{char ans[10]; printf("Press RETURN\n"); fgets(ans, sizeof(ans), stdin);}
+ /* All other errors are 'fatal'. */
+ XGetErrorText (dsp, event->error_code, buf, 128);
+ fprintf (stderr, "X Error: %s\n", buf);
diff --git a/www/Mosaic/pkg-plist b/www/Mosaic/pkg-plist
index 61fb386502f1..fc8c27ec5090 100644
--- a/www/Mosaic/pkg-plist
+++ b/www/Mosaic/pkg-plist
@@ -1 +1,2 @@
bin/Mosaic
+lib/X11/app-defaults/Mosaic