aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 13:12:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 13:12:31 +0000
commit53ad8315b0a2ef773e5e5f74a380bab573e4d008 (patch)
tree5522ebdbbbc41a02fbc8bf3da8fa96b3719b6d61 /www/WebMagick/Makefile
parentc0af1ccd5f350208e51572a7122f075c545462ec (diff)
downloadports-53ad8315b0a2ef773e5e5f74a380bab573e4d008.tar.gz
ports-53ad8315b0a2ef773e5e5f74a380bab573e4d008.zip
Add some shebangfix to allow building most of the ports tree without /usr/bin/perl
Submitted by: John Marino Obtained from: DPorts
Notes
Notes: svn path=/head/; revision=317605
Diffstat (limited to 'www/WebMagick/Makefile')
-rw-r--r--www/WebMagick/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index c2ab5c1af1b7..2a0684995867 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: WebMagick
-# Date created: 20 May 1998
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= WebMagick
PORTVERSION= 2.03p18
@@ -20,6 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS= p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
+USES= shebangfix
USE_PERL5= yes
USE_AUTOTOOLS= autoconf aclocal automake
AUTOMAKE_ARGS+= --add-missing
@@ -30,6 +27,10 @@ CONFIGURE_ENV= webmagick_cv_rootpath=${PREFIX}/www/data \
webmagick_cv_htimage="" \
webmagick_cv_maptype=ncsa \
PERL=${PERL}
+SHEBANG_FILES= utils/aub \
+ utils/aub_hook \
+ utils/help2man \
+ utils/make_dir_index.pl
.include <bsd.port.pre.mk>