aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2010-07-10 21:42:10 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2010-07-10 21:42:10 +0000
commit405fd721dede7500cdccfce4dcf02f54cb31824d (patch)
tree80cf23508f3857aabe47cbfd6a615250700ca468 /www/WebMagick
parent31cf3e8ea81286ba374a5b1235eeb59ae3f620cc (diff)
downloadports-405fd721dede7500cdccfce4dcf02f54cb31824d.tar.gz
ports-405fd721dede7500cdccfce4dcf02f54cb31824d.zip
Quote COORDS value and add ALT="" to pass HTML validators.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=257623
Diffstat (limited to 'www/WebMagick')
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--www/WebMagick/files/patch-aa21
2 files changed, 13 insertions, 10 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 2d728b13d0ea..009750f63b5f 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 34
+PORTREVISION= 35
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}-beta/2.03pre3
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index fc9acdf17f99..52e345242479 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.155
-diff -u -r1.117 -r1.155
+retrieving revision 1.157
+diff -u -r1.117 -r1.157
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 24 Aug 2009 02:31:29 -0000 1.155
++++ webmagick.in 10 Jul 2010 21:34:55 -0000 1.157
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.155 2009/08/24 02:31:29 ache Exp $
++# $Id: webmagick.in,v 1.157 2010/07/10 21:34:55 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -1053,7 +1053,7 @@ diff -u -r1.117 -r1.155
+ }
+ }
+ print ( PICHTML "<IMG SRC=\"$iconImageUrls{'prev_gray'}\"",
-+ " $iconImageSizes{'prev_gray'} BORDER=0>\n");
++ " $iconImageSizes{'prev_gray'} ALT=\"\" BORDER=0>\n");
+ if ( $opt_edgelinksindex ) {
+ print ( PICHTML "</A>");
+ }
@@ -1101,7 +1101,7 @@ diff -u -r1.117 -r1.155
+ }
+ }
+ print ( PICHTML "<IMG SRC=\"$iconImageUrls{'next_gray'}\"",
-+ " $iconImageSizes{'next_gray'} BORDER=0>\n");
++ " $iconImageSizes{'next_gray'} ALT=\"\" BORDER=0>\n");
+ if ( $opt_edgelinksindex ) {
+ print ( PICHTML "</A>");
+ }
@@ -1148,23 +1148,26 @@ diff -u -r1.117 -r1.155
}
print( PICHTML "$opt_pichtmlbottom\n") if ("$opt_pichtmlbottom" ne '');
-@@ -2570,14 +2742,14 @@
+@@ -2570,15 +2742,15 @@
unless ($opt_tables)
{
- print( INDEX " <AREA${target} HREF=\"",
+- escapeurl($pichtml), "\" SHAPE=RECT COORDS=", $imageThumbCoords[$pageNumber - 1][$imageNum],">\n" );
+ print( INDEX " <AREA${target} ALT=\"${altlabel}\" TITLE=\"${altlabel}\" HREF=\"",
- escapeurl($pichtml), "\" SHAPE=RECT COORDS=", $imageThumbCoords[$pageNumber - 1][$imageNum],">\n" );
++ escapeurl($pichtml), "\" SHAPE=RECT COORDS=\"", $imageThumbCoords[$pageNumber - 1][$imageNum],"\">\n" );
}
} else
{
unless ($opt_tables)
{
- print( INDEX " <AREA HREF=\"", escapeurl($pic),
+- "\" SHAPE=RECT COORDS=", $imageThumbCoords[$pageNumber - 1][$imageNum],">\n" );
+ print( INDEX " <AREA ALT=\"${altlabel}\" TITLE=\"${altlabel}\" HREF=\"", escapeurl($pic),
- "\" SHAPE=RECT COORDS=", $imageThumbCoords[$pageNumber - 1][$imageNum],">\n" );
++ "\" SHAPE=RECT COORDS=\"", $imageThumbCoords[$pageNumber - 1][$imageNum],"\">\n" );
}
}
+
@@ -2590,7 +2762,7 @@
print INDEX "<TR ALIGN=CENTER VALIGN=TOP>";
}