aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-10-19 08:38:06 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-10-19 08:38:06 +0000
commit441ee365f5e9474986590b73950a437b83ccf6dc (patch)
tree87705eab32b8d3a935261e9b4bb0b812c9c8de61 /www/WebMagick
parentd47da21df6291d929f8d3ea7a2b2ddf6ca459017 (diff)
downloadports-441ee365f5e9474986590b73950a437b83ccf6dc.tar.gz
ports-441ee365f5e9474986590b73950a437b83ccf6dc.zip
Update from latest project CVS
Notes
Notes: svn path=/head/; revision=91631
Diffstat (limited to 'www/WebMagick')
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--www/WebMagick/files/patch-aa44
2 files changed, 28 insertions, 18 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 58aff8d4efda..838f859b2434 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index 7458aa8a49d5..92b814fdaa88 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.125
-diff -u -r1.117 -r1.125
+retrieving revision 1.126
+diff -u -r1.117 -r1.126
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 18 Jul 2003 00:27:35 -0000 1.125
++++ webmagick.in 19 Oct 2003 08:12:35 -0000 1.126
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.125 2003/07/18 00:27:35 ache Exp $
++# $Id: webmagick.in,v 1.126 2003/10/19 08:12:35 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -152,7 +152,17 @@ diff -u -r1.117 -r1.125
'pichtmlbottom' => !$opt_pichtml ? "" : $opt_pichtmlbottom,
'pichtmlext' => !$opt_pichtml ? "" : $opt_pichtmlext,
'pichtmlnav' => !$opt_pichtml ? 0 : $opt_pichtmlnav,
-@@ -2173,20 +2177,17 @@
+@@ -2135,7 +2139,8 @@
+ print( INDEX " <TITLE>${pageTitle}</TITLE>\n" );
+
+ # Meta tags
+- print( INDEX " <META NAME=\"GENERATOR\" CONTENT=\"WebMagick/$webmagickInfo{version} [WebMagick]\">\n" );
++ print( INDEX " <META NAME=\"GENERATOR\" CONTENT=\"WebMagick/$webmagickInfo{version} [WebMagick]\">\n" )
++ if (!$opt_anonymous);
+ print( INDEX " <META NAME=\"Author\" CONTENT=\"${opt_metaauthor}\">\n" )
+ if( "$opt_metaauthor" ne '' );
+ print( INDEX " <META NAME=\"Description\" CONTENT=\"${opt_metadescription}\">\n" )
+@@ -2173,20 +2178,17 @@
print( INDEX $framespechtml );
print( INDEX "<NOFRAMES>\n" );
print( INDEX "<BODY\n" );
@@ -182,7 +192,7 @@ diff -u -r1.117 -r1.125
close( INDEX );
-@@ -2242,17 +2243,14 @@
+@@ -2242,17 +2244,14 @@
print( INDEX "</HEAD>\n" );
print( INDEX "<BODY\n" );
@@ -208,7 +218,7 @@ diff -u -r1.117 -r1.125
print( INDEX ">\n");
print( INDEX $pagedirhtml );
print( INDEX "</BODY></HTML>\n" );
-@@ -2379,16 +2377,13 @@
+@@ -2379,16 +2378,13 @@
print( INDEX "</HEAD>\n" );
print( INDEX "<BODY\n" );
@@ -232,7 +242,7 @@ diff -u -r1.117 -r1.125
print( INDEX ">\n");
print( INDEX "${opt_header}\n" ) if ("$opt_header" ne '');
-@@ -2397,8 +2392,12 @@
+@@ -2397,8 +2393,12 @@
if( $numimages > 0 ) {
# Total HACK!!!
if( !$opt_frames || $opt_framestyle == 1 ) {
@@ -247,7 +257,7 @@ diff -u -r1.117 -r1.125
}
print( INDEX "$indexbar<BR>\n" );
-@@ -2433,22 +2432,30 @@
+@@ -2433,22 +2433,30 @@
my $pic = $imageNames[$pageNumber - 1][$imageNum];
my $pichtml;
@@ -280,7 +290,7 @@ diff -u -r1.117 -r1.125
# Meta tags
print( PICHTML " <META NAME=\"GENERATOR\" CONTENT=\"WebMagick/$webmagickInfo{version} [WebMagick]\">\n" );
-@@ -2469,28 +2476,19 @@
+@@ -2469,28 +2477,19 @@
print( PICHTML "</HEAD>\n" );
print( PICHTML "<BODY\n" );
@@ -317,7 +327,7 @@ diff -u -r1.117 -r1.125
}
if ($opt_pichtmlnav) {
-@@ -2526,9 +2524,9 @@
+@@ -2526,9 +2525,9 @@
} else {
print ( PICHTML "<A${target} HREF=\"");
if ($imageNum == 0 && $pageNumber != 1) {
@@ -329,7 +339,7 @@ diff -u -r1.117 -r1.125
}
print ( PICHTML $opt_pichtmlext);
print ( PICHTML "\"><IMG SRC=\"$iconImageUrls{'prev'}\"",
-@@ -2543,9 +2541,9 @@
+@@ -2543,9 +2542,9 @@
} else {
print ( PICHTML "<A${target} HREF=\"");
if (($imageNum == $#{$imageNames[$pageNumber - 1]}) && $pageNumber != $numPages) {
@@ -341,7 +351,7 @@ diff -u -r1.117 -r1.125
}
print ( PICHTML $opt_pichtmlext);
print ( PICHTML "\"><IMG SRC=\"$iconImageUrls{'next'}\"",
-@@ -2556,10 +2554,10 @@
+@@ -2556,10 +2555,10 @@
print ( PICHTML "</NOBR><BR>");
}
@@ -355,7 +365,7 @@ diff -u -r1.117 -r1.125
}
print( PICHTML "$opt_pichtmlbottom\n") if ("$opt_pichtmlbottom" ne '');
-@@ -2601,12 +2599,16 @@
+@@ -2601,12 +2600,16 @@
# TODO: make sure the thumbnails are created, and get some image sizes
# TODO: save the labels in a new array, maybe same with sizes
if ( $thumbImageSizes{$pic}) {
@@ -375,7 +385,7 @@ diff -u -r1.117 -r1.125
if ($imageNum%$opt_columns == ($opt_columns - 1))
{
-@@ -4156,25 +4158,29 @@
+@@ -4156,25 +4159,29 @@
--footer Page footer (imagemap frame) (default to </CENTER>)
--header Page header (imagemap frame) (default to <CENTER>)
--[no]javascript Enable JavaScript output (default off)
@@ -410,7 +420,7 @@ diff -u -r1.117 -r1.125
--framestyle Frame style to use (out of those available)
--[no]allowconfig Allow user to configure framestyle, columns and rows (requires javascript and tables) (default off)
-@@ -4296,6 +4302,7 @@
+@@ -4296,6 +4303,7 @@
s/&/&amp;/g;
s/>/&gt;/g;
s/</&lt;/g;
@@ -418,7 +428,7 @@ diff -u -r1.117 -r1.125
return( $_ );
}
-@@ -4324,22 +4331,10 @@
+@@ -4324,22 +4332,10 @@
# Escape unsafe characters in URLs
#
sub escapeurl {