aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2009-08-24 02:35:56 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2009-08-24 02:35:56 +0000
commitc5c855f843df1da387ab873a3305f3728e4195d4 (patch)
tree5c38e14c9e591340468b24f7e1a04d5d8436bc38 /www/WebMagick
parenta34f1ce1e85e816c5f725f7d21f717cb4d324f25 (diff)
downloadports-c5c855f843df1da387ab873a3305f3728e4195d4.tar.gz
ports-c5c855f843df1da387ab873a3305f3728e4195d4.zip
Update to the latest snapshot from the project CVS
Notes
Notes: svn path=/head/; revision=240242
Diffstat (limited to 'www/WebMagick')
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--www/WebMagick/files/patch-aa17
2 files changed, 14 insertions, 5 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 99c9537511fd..1431ef74f12b 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 30
+PORTREVISION= 31
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}-beta/2.03pre3
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index 7b7ae2c11f1c..fc9acdf17f99 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.154
-diff -u -r1.117 -r1.154
+retrieving revision 1.155
+diff -u -r1.117 -r1.155
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 26 Jul 2006 03:36:05 -0000 1.154
++++ webmagick.in 24 Aug 2009 02:31:29 -0000 1.155
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.154 2006/07/26 03:36:05 ache Exp $
++# $Id: webmagick.in,v 1.155 2009/08/24 02:31:29 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -1294,6 +1294,15 @@ diff -u -r1.117 -r1.154
# Table image labels
print( PERLVARS "\n# table image titles\n", plHash( 'tableImageLabels', \%tableImageLabels ) );
+@@ -3062,7 +3268,7 @@
+ # Copy image so we can play with it without effecting original
+ print( STDERR "Copying montage to scratch ...\n" )
+ if $opt_debug;
+- $image = $montage->Copy();
++ $image = $montage->Clone();
+ handleMagickError( __FILE__, __LINE__, "", $image) unless ref($image);
+ last MONTAGE unless ref($image);
+
@@ -3465,6 +3671,10 @@
sub sortDir {
if(defined($dirOrder{$a}) && defined($dirOrder{$b})) {