aboutsummaryrefslogtreecommitdiff
path: root/www/apache-jserv
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1999-06-30 22:03:13 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1999-06-30 22:03:13 +0000
commit1e257996e8fbdf4354acea384b88de9bd19e12ad (patch)
treecf637d9330240c343eec281e22a9b43afee6530c /www/apache-jserv
parente9cec94908105b71c471be5942cdef4e68fa2d1e (diff)
downloadports-1e257996e8fbdf4354acea384b88de9bd19e12ad.tar.gz
ports-1e257996e8fbdf4354acea384b88de9bd19e12ad.zip
Loadable servlet module for apache.
PR: ports/10389 (part of) Submitted by: greg@greg.rim.or.jp
Notes
Notes: svn path=/head/; revision=19924
Diffstat (limited to 'www/apache-jserv')
-rw-r--r--www/apache-jserv/Makefile46
-rw-r--r--www/apache-jserv/distinfo1
-rw-r--r--www/apache-jserv/files/patch-aa11
-rw-r--r--www/apache-jserv/files/patch-ab11
-rw-r--r--www/apache-jserv/files/patch-ac35
-rw-r--r--www/apache-jserv/files/patch-ad37
-rw-r--r--www/apache-jserv/files/patch-ae20
-rw-r--r--www/apache-jserv/pkg-comment1
-rw-r--r--www/apache-jserv/pkg-descr19
-rw-r--r--www/apache-jserv/pkg-message7
-rw-r--r--www/apache-jserv/pkg-plist52
11 files changed, 240 insertions, 0 deletions
diff --git a/www/apache-jserv/Makefile b/www/apache-jserv/Makefile
new file mode 100644
index 000000000000..aca50624e79f
--- /dev/null
+++ b/www/apache-jserv/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: apache mod_jserv
+# Version required: 1.0
+# Date created: 1999/05/29
+# Whom: Kensaku Masuda <greg@greg.rim.or.jp>
+#
+# $Id$
+
+DISTNAME= Apache_JServ_1.0
+PKGNAME= apache-jserv-1.0
+CATEGORIES= www java
+MASTER_SITES= http://java.apache.org/jserv/dist/
+
+MAINTAINER= greg@greg.rim.or.jp
+
+BUILD_DEPENDS= ${PREFIX}/jdk1.1.8/bin/javac:${PORTSDIR}/java/jdk\
+ ${PREFIX}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
+RUN_DEPENDS= ${PREFIX}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk\
+ ${PREFIX}/sbin/apachectl:${PORTSDIR}/www/apache13\
+ ${PREFIX}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
+
+WRKSRC= ${WRKDIR}/ApacheJServ-1.0
+USE_LIBTOOL= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS= --prefix=${PREFIX}\
+ --libexecdir=${PREFIX}/libexec/apache\
+ --libdir=${PREFIX}/libexec/apache\
+ --sysconfdir=${PREFIX}/etc/apache\
+ --with-jdk-home=${PREFIX}/jdk1.1.8\
+ --with-jsdk=${PREFIX}/share/java/classes/jsdk.jar\
+ --with-apache-install=${PREFIX}\
+ --with-java=${PREFIX}/jdk1.1.8/bin/java\
+ --with-javac=${PREFIX}/jdk1.1.8/bin/javac\
+ --with-gnu-ld\
+ --enable-compressed-jar
+
+post-install:
+ @(cd ${WRKSRC}/conf;\
+ ${INSTALL_DATA} httpd.conf \
+ ${PREFIX}/etc/apache/jserv.conf.default;\
+ ${INSTALL_DATA} jserv.properties \
+ ${PREFIX}/etc/apache/jserv.properties.default; \
+ ${INSTALL_DATA} zone.properties \
+ ${PREFIX}/etc/apache/zone.properties.default)
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/www/apache-jserv/distinfo b/www/apache-jserv/distinfo
new file mode 100644
index 000000000000..1ff09e052140
--- /dev/null
+++ b/www/apache-jserv/distinfo
@@ -0,0 +1 @@
+MD5 (Apache_JServ_1.0.tar.gz) = 772027454979e53a51c5ceefe3860ed6
diff --git a/www/apache-jserv/files/patch-aa b/www/apache-jserv/files/patch-aa
new file mode 100644
index 000000000000..addcb364415f
--- /dev/null
+++ b/www/apache-jserv/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Wed Mar 3 08:46:29 1999
++++ configure Wed Mar 3 08:46:42 1999
+@@ -1239,7 +1239,7 @@
+ fi
+
+ # Always use our own libtool.
+-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++LIBTOOL='libtool'
+
+ # Check for any special flags to pass to ltconfig.
+ libtool_flags=
diff --git a/www/apache-jserv/files/patch-ab b/www/apache-jserv/files/patch-ab
new file mode 100644
index 000000000000..a3247303a387
--- /dev/null
+++ b/www/apache-jserv/files/patch-ab
@@ -0,0 +1,11 @@
+--- docs/Makefile.in.orig Sat Jun 12 05:47:51 1999
++++ docs/Makefile.in Sat Jun 26 23:45:33 1999
+@@ -87,7 +87,7 @@
+
+ DOCFILES = $(strip $(shell ls $(EXTRA_DIST)))
+
+-docdir = ${prefix}/docs
++docdir = ${prefix}/share/doc/mod_jserv
+ mkinstalldirs = $(SHELL) $(top_srcdir)/src/scripts/build/unix/mkinstalldirs
+ CONFIG_CLEAN_FILES =
+ DIST_COMMON = Makefile.am Makefile.in
diff --git a/www/apache-jserv/files/patch-ac b/www/apache-jserv/files/patch-ac
new file mode 100644
index 000000000000..4d484cc4f81c
--- /dev/null
+++ b/www/apache-jserv/files/patch-ac
@@ -0,0 +1,35 @@
+--- conf/httpd.conf.in.orig Sat Jun 12 05:38:46 1999
++++ conf/httpd.conf.in Thu Jul 1 00:07:44 1999
+@@ -6,7 +6,7 @@
+ # Note: this file should be appended to or included in httpd.conf
+
+ # Tell Apache on win32 to load the Apache JServ communication module
+-#LoadModule jserv_module modules/ApacheModuleJServ.dll
++LoadModule jserv_module libexec/apache/mod_jserv.so
+
+ <IfModule mod_jserv.c>
+
+@@ -19,13 +19,13 @@
+ # In manual mode this directive is ignored
+ # Syntax: ApJServProperties [filename]
+ # Default: "./conf/jserv.properties"
+-ApJServProperties ./conf/jserv.properties
++ApJServProperties etc/apache/jserv.properties
+
+ # Log file for this module operation relative to Apache root directory.
+ # Syntax: ApJServLogFile [filename]
+ # Default: "./logs/mod_jserv.log"
+ # Note: when set to "DISABLED", the log will be redirected to Apache error log
+-ApJServLogFile ./logs/mod_jserv.log
++ApJServLogFile /var/log/mod_jserv.log
+
+ # Log Level for this module
+ # Syntax: ApJServLogLevel [debug|info|notice|warn|error|crit|alert|emerg]
+@@ -99,6 +99,7 @@
+ #ApJServAction .jsp /servlets/nl.nmg.jsp.JSPServlet
+ #ApJServAction .gsp /servlets/com.bitmechanics.gsp.GspServlet
+ #ApJServAction .jhtml /servlets/org.apache.servlet.ssi.SSI
++# Uncomment if you use Cocoon.
+ #ApJServAction .xml /servlets/org.apache.cocoon.Cocoon
+
+ # Enable the Apache JServ status handler with the URL of
diff --git a/www/apache-jserv/files/patch-ad b/www/apache-jserv/files/patch-ad
new file mode 100644
index 000000000000..d66834a164ec
--- /dev/null
+++ b/www/apache-jserv/files/patch-ad
@@ -0,0 +1,37 @@
+--- conf/jserv.properties.in.orig Sat Jun 12 05:38:46 1999
++++ conf/jserv.properties.in Tue Jun 29 23:02:02 1999
+@@ -52,8 +52,15 @@
+ # Note: the classes you want to be automatically reloaded upon modification
+ # MUST NOT be in this classpath or the classpath of the shell
+ # you start the Apache from.
+-wrapper.classpath=@JSERV_CLASSES@
++wrapper.classpath=@libexecdir@/ApacheJServ.jar
+ wrapper.classpath=@JSDK_CLASSES@
++# Uncomment if you use Cocoon.
++#wrapper.classpath=@prefix@/share/java/classes/Cocoon.jar
++#wrapper.classpath=@prefix@/share/java/classes/openxml.jar
++#wrapper.classpath=@prefix@/share/java/classes/xslp.jar
++# Currently, these are not officially supported by the Cocoon team.
++#wrapper.classpath=@prefix@/share/java/classes/xml4j.jar
++#wrapper.classpath=@prefix@/share/java/classes/lotusxsl.jar
+
+ # An environment name with value passed to the JVM
+ # Syntax: wrapper.env=[name]=[value]
+@@ -94,7 +101,7 @@
+ # Syntax: [servlet zone name as on the zones list].properties=[full path to configFile] (String)
+ # Default: NONE
+ # Note: if the file could not be opened, try using absolute paths.
+-root.properties=@JSERV_CONF@/zone.properties
++root.properties=@sysconfdir@/zone.properties
+
+ #
+ # Security parameters
+@@ -177,7 +184,7 @@
+ # Syntax: log.file=[log path and filename] (String)
+ # Default: NONE
+ # Note: if the file could not be opened, try using absolute paths.
+-log.file=@JSERV_LOG@/jserv.log
++log.file=/var/log/jserv.log
+
+ # Enable the timestamp before the log message
+ # Syntax: log.timestamp=[true,false] (boolean)
diff --git a/www/apache-jserv/files/patch-ae b/www/apache-jserv/files/patch-ae
new file mode 100644
index 000000000000..6b2f886f9d88
--- /dev/null
+++ b/www/apache-jserv/files/patch-ae
@@ -0,0 +1,20 @@
+--- conf/zone.properties.in~ Fri Feb 19 13:09:29 1999
++++ conf/zone.properties.in Tue Jun 29 23:04:05 1999
+@@ -23,6 +23,8 @@
+ # here.
+
+ repositories=
++# Uncomment if you use Cocoon.
++#repositories=@prefix@/share/java/classes/Cocoon.jar
+
+ # Classloader parameters
+ #########################
+@@ -133,6 +135,8 @@
+ # Syntax: servlet.[classname].initArgs=[name]=[value],[name]=[value],...
+ # Default: NONE
+ # servlet.org.fool.Dummy.initArgs=message=I'm a dummy servlet
++# Uncomment if you use Cocoon.
++#servlet.org.apache.cocoon.Cocoon.initArgs=properties=@prefix@/etc/apache/cocoon.properties
+
+ # Aliased Servlet Init Parameters
+ ##################################
diff --git a/www/apache-jserv/pkg-comment b/www/apache-jserv/pkg-comment
new file mode 100644
index 000000000000..b2008d43168b
--- /dev/null
+++ b/www/apache-jserv/pkg-comment
@@ -0,0 +1 @@
+Loadable servlet module for apache.
diff --git a/www/apache-jserv/pkg-descr b/www/apache-jserv/pkg-descr
new file mode 100644
index 000000000000..61be900828d8
--- /dev/null
+++ b/www/apache-jserv/pkg-descr
@@ -0,0 +1,19 @@
+What is it?
+ Apache JServ is a 100% pure Java servlet engine designed to
+ implement the Sun Java Servlet API 2.0 specifications and
+ add Java Servlet capabilities to the Apache
+ HTTP Server <http://www.apache.org/>.
+
+The Latest Version
+ Details of the latest version can be found on the Java
+ Apache Project web site <http://java.apache.org/>.
+
+Documentation
+ Documentation is available in HTML format, in the docs/
+ directory. The most up-to-date documentation can be found at
+ <http://java.apache.org/jserv/docs/>.
+
+Licensing
+ Please see the file called LICENSE.
+
+WWW: http://java.apache.org/jserv/
diff --git a/www/apache-jserv/pkg-message b/www/apache-jserv/pkg-message
new file mode 100644
index 000000000000..f49c9a54c2a4
--- /dev/null
+++ b/www/apache-jserv/pkg-message
@@ -0,0 +1,7 @@
+To activate mod_jserv:
+
+o Copy jserv.conf.default, jserv.properties.default and
+ zone.properties.default in ${PREFIX}/etc/apache to jserv.conf,
+ jserv.properties and zone.properties.
+o Touch /var/log/jserv.log with write permission for owner of httpd.
+o Add "Include etc/apache/jserv.conf" into httpd.conf to activate mod_jserv.
diff --git a/www/apache-jserv/pkg-plist b/www/apache-jserv/pkg-plist
new file mode 100644
index 000000000000..db5cd86f2355
--- /dev/null
+++ b/www/apache-jserv/pkg-plist
@@ -0,0 +1,52 @@
+etc/apache/jserv.conf.default
+etc/apache/jserv.properties.default
+etc/apache/zone.properties.default
+libexec/apache/libjserv.a
+libexec/apache/libjserv.so
+libexec/apache/libjserv.so.0
+libexec/apache/mod_jserv.so
+libexec/apache/ApacheJServ.jar
+share/doc/mod_jserv/FAQ.html
+share/doc/mod_jserv/api/index.html
+share/doc/mod_jserv/bugs.html
+share/doc/mod_jserv/changes.html
+share/doc/mod_jserv/contributing.html
+share/doc/mod_jserv/contributors.html
+share/doc/mod_jserv/features.html
+share/doc/mod_jserv/future/index.html
+share/doc/mod_jserv/future/sandboxing.html
+share/doc/mod_jserv/glossary.html
+share/doc/mod_jserv/howto.load-balancing.html
+share/doc/mod_jserv/images/apache_pb.gif
+share/doc/mod_jserv/images/java-apache-project.gif
+share/doc/mod_jserv/images/lbfail001.gif
+share/doc/mod_jserv/images/lbfail002.gif
+share/doc/mod_jserv/images/lbfail003.gif
+share/doc/mod_jserv/images/lbprod001.gif
+share/doc/mod_jserv/images/lbprod002.gif
+share/doc/mod_jserv/images/lbshm001.gif
+share/doc/mod_jserv/index.html
+share/doc/mod_jserv/license.html
+share/doc/mod_jserv/install/howto.security.html
+share/doc/mod_jserv/install/howto.servlets.html
+share/doc/mod_jserv/install/howto.status.html
+share/doc/mod_jserv/install/howto.unix_install.html
+share/doc/mod_jserv/install/howto.win32_install.html
+share/doc/mod_jserv/install/index.html
+share/doc/mod_jserv/modules.html
+share/doc/mod_jserv/operation.html
+share/doc/mod_jserv/protocol/AJPv1.html
+share/doc/mod_jserv/protocol/AJPv11.html
+share/doc/mod_jserv/protocol/AJPv2.html
+share/doc/mod_jserv/protocol/AJPv21.html
+share/doc/mod_jserv/security.html
+share/doc/mod_jserv/sendbug.html
+share/doc/mod_jserv/support.html
+share/doc/mod_jserv/y2k.html
+share/doc/mod_jserv/zones.html
+@dirrm share/doc/mod_jserv/api
+@dirrm share/doc/mod_jserv/future
+@dirrm share/doc/mod_jserv/images
+@dirrm share/doc/mod_jserv/install
+@dirrm share/doc/mod_jserv/protocol
+@dirrm share/doc/mod_jserv