aboutsummaryrefslogtreecommitdiff
path: root/www/apache13+ipv6
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-09-25 21:29:04 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-09-25 21:29:04 +0000
commit680f1ac6bcde51dec3e2929341b29d025e08f475 (patch)
tree975f9d2447c476dfe70e3afce6e43ee241f0ffb7 /www/apache13+ipv6
parent175caad64ef954cce9f5485fb5de1ca963a09f29 (diff)
downloadports-680f1ac6bcde51dec3e2929341b29d025e08f475.tar.gz
ports-680f1ac6bcde51dec3e2929341b29d025e08f475.zip
Upgrade to 1.3.28.
PR: ports/56737 Submitted by: Jeroen Ruigrok van der Werven <asmodai@tendra.org>
Notes
Notes: svn path=/head/; revision=89386
Diffstat (limited to 'www/apache13+ipv6')
-rw-r--r--www/apache13+ipv6/Makefile64
-rw-r--r--www/apache13+ipv6/distinfo4
-rw-r--r--www/apache13+ipv6/files/patch-ac31
-rw-r--r--www/apache13+ipv6/files/patch-ad11
-rw-r--r--www/apache13+ipv6/files/patch-ba20
-rw-r--r--www/apache13+ipv6/files/patch-bb60
-rw-r--r--www/apache13+ipv6/pkg-deinstall2
-rw-r--r--www/apache13+ipv6/pkg-descr2
-rw-r--r--www/apache13+ipv6/pkg-plist15
9 files changed, 180 insertions, 29 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index 7db355dede1c..b681bd4553d1 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -6,35 +6,48 @@
#
PORTNAME= apache+ipv6
-PORTVERSION= 1.3.27
+PORTVERSION= 1.3.28
CATEGORIES= www ipv6
-MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
+MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
-PATCH_SITES= http://motoyuki.bsdclub.org/data/IPv6/
-PATCHFILES= apache-1.3.27-v6-20021004.diff.gz
+PATCH_SITES= http://www.tendra.org/~asmodai/ipv6/
+PATCHFILES= apache-1.3.28-v6-20030912.diff.gz
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= The extremely popular Apache http server. Very fast, very clean
-USE_PERL5= yes
+USE_PERL5= yes
DATADIR=${PREFIX}/www
DOCUMENT_ROOT=${DATADIR}/data
DEFAULT_PATH=/bin:/usr/bin:${PREFIX}/bin
+.if defined(WITHOUT_APACHE_EXPAT) && ${WITHOUT_APACHE_EXPAT} == yes
+EXPAT_CONF+= --disable-rule=EXPAT
+.else
+.if !defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes
+LIB_DEPENDS+= expat.4:${PORTSDIR}/textproc/expat2
+.endif
+EXPAT_CONF+= --enable-rule=EXPAT
+.endif
+
.if defined(WITH_APACHE_SUEXEC) && ${WITH_APACHE_SUEXEC} == yes
APACHE_SUEXEC_DOCROOT?=${DOCUMENT_ROOT}
+APACHE_SUEXEC_LOG?=/var/log/httpd-suexec.log
APACHE_SUEXEC_USERDIR?=public_html
+APACHE_SUEXEC_UIDMIN?=1000
+APACHE_SUEXEC_GIDMIN?=1000
+APACHE_SUEXEC_CALLER?=www
SUEXEC_CONF= \
--enable-suexec \
--suexec-docroot=${APACHE_SUEXEC_DOCROOT} \
- --suexec-caller=www \
- --suexec-uidmin=1000 \
- --suexec-gidmin=1000 \
- --suexec-logfile=/var/log/httpd-suexec.log \
+ --suexec-caller=${APACHE_SUEXEC_CALLER} \
+ --suexec-uidmin=${APACHE_SUEXEC_UIDMIN} \
+ --suexec-gidmin=${APACHE_SUEXEC_GIDMIN} \
+ --suexec-logfile=${APACHE_SUEXEC_LOG} \
--suexec-userdir=${APACHE_SUEXEC_USERDIR} \
--suexec-safepath=${DEFAULT_PATH}
@@ -54,7 +67,7 @@ SUEXEC_MAN=
.endif # !SUEXEC
-HAS_CONFIGURE= yes
+HAS_CONFIGURE= yes
# += for child ports
CONFIGURE_ARGS+= \
--prefix=${PREFIX} \
@@ -69,29 +82,38 @@ CONFIGURE_ARGS+= \
--enable-module=mmap_static \
--disable-module=auth_dbm \
--enable-shared=max \
- ${SUEXEC_CONF}
+ ${SUEXEC_CONF} \
+ ${EXPAT_CONF}
-OPTIM= -DDOCUMENT_LOCATION=\\"${DOCUMENT_ROOT}\\" \
- -DDEFAULT_PATH=\\"${DEFAULT_PATH}\\"
+CFLAGS+=-DDOCUMENT_LOCATION=\\\\\"${DOCUMENT_ROOT}\\\\\" \
+ -DDEFAULT_PATH=\\\\\"${DEFAULT_PATH}\\\\\"
#
# Set APACHE_HARD_SERVER_LIMIT env. variable to desired value
#
.if defined(APACHE_HARD_SERVER_LIMIT)
-OPTIM+= -DHARD_SERVER_LIMIT=${APACHE_HARD_SERVER_LIMIT}
+CFLAGS+=-DHARD_SERVER_LIMIT=${APACHE_HARD_SERVER_LIMIT}
.else
-OPTIM+= -DHARD_SERVER_LIMIT=512
+CFLAGS+=-DHARD_SERVER_LIMIT=512
.endif
#
-# Set WITH_APACHE_PERF_TUNING env. variable to YES to get maximum performance
+# Set WITH_APACHE_PERF_TUNING env. variable to yes to get maximum performance
#
-.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS
-CFLAGS+= -O6 -fomit-frame-pointer
+.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == yes
+CFLAGS+=-DBUFFERED_LOGS
+# Don't use OPTIM below, it is inserted _before_ CFLAGS
+CFLAGS+=-O6 -fomit-frame-pointer
.endif
-CONFIGURE_ENV= OPTIM='${OPTIM}' LD_SHLIB='${CC}'
+CONFIGURE_ENV= OPTIM='${OPTIM}' LD_SHLIB='${CC}' LIBS='${LIBS}'
+
+.if (!defined(WITHOUT_APACHE_EXPAT) || ${WITHOUT_APACHE_EXPAT} != yes) && \
+ (!defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes)
+CONFIGURE_ENV+= \
+ INCLUDES=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+.endif
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
@@ -102,7 +124,7 @@ post-extract:
> ${WRKSRC}/apache.sh
pre-install:
- PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
${INSTALL_DATA} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh-dist
diff --git a/www/apache13+ipv6/distinfo b/www/apache13+ipv6/distinfo
index 3c63759b4380..1863f2b1f059 100644
--- a/www/apache13+ipv6/distinfo
+++ b/www/apache13+ipv6/distinfo
@@ -1,2 +1,2 @@
-MD5 (apache_1.3.27.tar.gz) = 65b89365a65dcad71d4402b4862beeaa
-MD5 (apache-1.3.27-v6-20021004.diff.gz) = 72753dcc35ee2ba29e1ee1e376c00907
+MD5 (apache_1.3.28.tar.gz) = 2cdece7b4881d541e072de6a2b65db77
+MD5 (apache-1.3.28-v6-20030912.diff.gz) = ecdb35435f97d7a68e3eb7107737dd57
diff --git a/www/apache13+ipv6/files/patch-ac b/www/apache13+ipv6/files/patch-ac
new file mode 100644
index 000000000000..f4f02e80cbc2
--- /dev/null
+++ b/www/apache13+ipv6/files/patch-ac
@@ -0,0 +1,31 @@
+--- src/modules/standard/mod_auth_db.module.bak Tue Oct 16 13:12:02 2001
++++ src/modules/standard/mod_auth_db.module Thu Feb 20 12:55:19 2003
+@@ -4,23 +4,23 @@
+ DB_LIB=''
+ if ./helpers/TestCompile func db_create; then
+ DB_VERSION='Berkeley-DB/3.x'
+- elif ./helpers/TestCompile lib db db_create; then
++ elif ./helpers/TestCompile lib dbXXX db_create; then
+ DB_VERSION='Berkeley-DB/3.x'
+ DB_LIB='-ldb'
+ elif ./helpers/TestCompile func db_open; then
+ DB_VERSION='Berkeley-DB/2.x'
+- elif ./helpers/TestCompile lib db db_open; then
++ elif ./helpers/TestCompile lib dbXXX db_open; then
+ DB_VERSION='Berkeley-DB/2.x'
+ DB_LIB='-ldb'
+- elif ./helpers/TestCompile lib db2 db_open; then
++ elif ./helpers/TestCompile lib db2XXX db_open; then
+ DB_VERSION='Berkeley-DB/2.x'
+ DB_LIB='-ldb2'
+ elif ./helpers/TestCompile func dbopen; then
+ DB_VERSION='Berkeley-DB/1.x'
+- elif ./helpers/TestCompile lib db dbopen; then
++ elif ./helpers/TestCompile lib dbXXX dbopen; then
+ DB_VERSION='Berkeley-DB/1.x'
+ DB_LIB='-ldb'
+- elif ./helpers/TestCompile lib db1 dbopen; then
++ elif ./helpers/TestCompile lib db1XXX dbopen; then
+ DB_VERSION='Berkeley-DB/1.x'
+ DB_LIB='-ldb1'
+ elif TCADDINCL='#include <db.h>' INCLUDES1="$INCLUDES1 -I/usr/include/db1" TLIB="-ldb1" \
diff --git a/www/apache13+ipv6/files/patch-ad b/www/apache13+ipv6/files/patch-ad
new file mode 100644
index 000000000000..d92d2f447613
--- /dev/null
+++ b/www/apache13+ipv6/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/support/dbmmanage.bak Thu Mar 14 00:05:37 2002
++++ src/support/dbmmanage Mon Jun 2 23:05:27 2003
+@@ -338,6 +338,8 @@
+ } elsif (substr($chkpass, 0, 5) eq '{SHA}') {
+ need_sha1_crypt;
+ $crypt_method = "sha1";
++ } elsif (substr($chkpass, 0, 3) eq '$1$') {
++ $crypt_method = "crypt";
+ } elsif (length($chkpass) == 13 && $chkpass ne $testpass) {
+ $crypt_method = "crypt";
+ } else {
diff --git a/www/apache13+ipv6/files/patch-ba b/www/apache13+ipv6/files/patch-ba
new file mode 100644
index 000000000000..1f92bd360250
--- /dev/null
+++ b/www/apache13+ipv6/files/patch-ba
@@ -0,0 +1,20 @@
+--- src/support/Makefile.tmpl.orig Sat Mar 2 20:46:23 2002
++++ src/support/Makefile.tmpl Tue Oct 22 00:31:18 2002
+@@ -7,7 +7,7 @@
+ # LIBS=-L$(SSLLOC)/lib -lssl -lcrypto -lm -lap -los $(EXTRA_LIBS) $(LIBS1)
+ # INCLUDES=-I$(SSLLOC)/include $(INCLUDES1) $(INCLUDES0) $(EXTRA_INCLUDES)
+
+-CFLAGS=$(OPTIM) $(CFLAGS1) $(EXTRA_CFLAGS)
++CFLAGS=-DLOGIN_CAP $(OPTIM) $(CFLAGS1) $(EXTRA_CFLAGS)
+ LIBS=-lm -lap -los $(EXTRA_LIBS) $(LIBS1)
+ INCLUDES=$(INCLUDES1) $(INCLUDES0) $(EXTRA_INCLUDES)
+ LDFLAGS=$(LDFLAGS1) $(EXTRA_LDFLAGS) -L$(OSDIR) -L$(SRCDIR)/ap
+@@ -50,7 +50,7 @@
+ -e 's%@LIBS_SHLIB@%$(LIBS_SHLIB)%g' && chmod a+x apxs
+
+ suexec: suexec.o
+- $(CC) $(CFLAGS) -o suexec $(LDFLAGS) suexec.o $(LIBS)
++ $(CC) $(CFLAGS) -lutil -o suexec $(LDFLAGS) suexec.o $(LIBS)
+
+ clean:
+ rm -f $(TARGETS) *.o
diff --git a/www/apache13+ipv6/files/patch-bb b/www/apache13+ipv6/files/patch-bb
new file mode 100644
index 000000000000..313c5f515759
--- /dev/null
+++ b/www/apache13+ipv6/files/patch-bb
@@ -0,0 +1,60 @@
+--- src/support/suexec.c.orig Wed Mar 5 18:50:29 2003
++++ src/support/suexec.c Fri Jul 18 18:09:56 2003
+@@ -90,6 +90,9 @@
+ #include <sys/types.h>
+
+ #include <stdarg.h>
++#ifdef LOGIN_CAP
++#include <login_cap.h>
++#endif
+
+ #include "suexec.h"
+
+@@ -322,6 +325,9 @@
+ #ifdef LOG_EXEC
+ fprintf(stderr, " -D LOG_EXEC=\"%s\"\n", LOG_EXEC);
+ #endif
++#ifdef LOGIN_CAP
++ fprintf(stderr, " -D LOGIN_CAP\n");
++#endif
+ #ifdef SAFE_PATH
+ fprintf(stderr, " -D SAFE_PATH=\"%s\"\n", SAFE_PATH);
+ #endif
+@@ -480,7 +486,28 @@
+
+ /*
+ * Change UID/GID here so that the following tests work over NFS.
+- *
++ */
++
++#ifdef LOGIN_CAP
++ /*
++ * Set user context (resources, priority and grouplist).
++ * If unsuccessful, error out.
++ */
++ if (setusercontext(NULL, pw, uid, LOGIN_SETRESOURCES | LOGIN_SETPRIORITY |
++ LOGIN_SETGROUP | LOGIN_SETLOGIN) == -1) {
++ log_err("emerg: failed to set user context (%ld: %s)\n", uid, cmd);
++ exit(108);
++ }
++
++ /*
++ * Set gid to the target group. If unsuccessful, error out.
++ */
++ if ((setgid(gid)) != 0) {
++ log_err("emerg: failed to setgid (%ld: %s)\n", gid, cmd);
++ exit(109);
++ }
++#else /* !LOGIN_CAP */
++ /*
+ * Initialize the group access list for the target user,
+ * and setgid() to the target group. If unsuccessful, error out.
+ */
+@@ -488,6 +515,7 @@
+ log_err("emerg: failed to setgid (%ld: %s)\n", gid, cmd);
+ exit(109);
+ }
++#endif /* LOGIN_CAP */
+
+ /*
+ * setuid() to the target user. Error out on fail.
diff --git a/www/apache13+ipv6/pkg-deinstall b/www/apache13+ipv6/pkg-deinstall
index 4576501c0ef6..c37189c5875e 100644
--- a/www/apache13+ipv6/pkg-deinstall
+++ b/www/apache13+ipv6/pkg-deinstall
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-deinstall,v 1.3 2002-06-21 12:06:04 sumikawa Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-deinstall,v 1.4 2003-09-25 21:29:03 sumikawa Exp $
#
if [ "$2" != "POST-DEINSTALL" ]; then
diff --git a/www/apache13+ipv6/pkg-descr b/www/apache13+ipv6/pkg-descr
index edb36c918c7c..8803492624a1 100644
--- a/www/apache13+ipv6/pkg-descr
+++ b/www/apache13+ipv6/pkg-descr
@@ -3,4 +3,4 @@ server version 1.3 (or 1.4). It fixes numerous bugs in the NCSA server and
includes many frequently requested new features, and has an API which
allows it to be extended to meet users' needs more easily.
-WWW: http://www.apache.org/
+WWW: http://httpd.apache.org/
diff --git a/www/apache13+ipv6/pkg-plist b/www/apache13+ipv6/pkg-plist
index 034d72b63152..431eb8db2a49 100644
--- a/www/apache13+ipv6/pkg-plist
+++ b/www/apache13+ipv6/pkg-plist
@@ -1,4 +1,4 @@
-@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.16 2002-10-05 09:18:44 kris Exp $
+@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.17 2003-09-25 21:29:03 sumikawa Exp $
bin/checkgid
bin/dbmmanage
bin/htdigest
@@ -138,7 +138,7 @@ www/data-dist/index.html.ru.ucs2
www/data-dist/index.html.ru.ucs4
www/data-dist/index.html.ru.utf8
www/data-dist/index.html.se
-www/data-dist/index.html.zh
+www/data-dist/index.html.zh-tw.big5
share/doc/apache/LICENSE
share/doc/apache/bind.html.en
share/doc/apache/bind.html.fr
@@ -152,7 +152,9 @@ share/doc/apache/configuring.html.en
share/doc/apache/configuring.html.fr
share/doc/apache/configuring.html.html
share/doc/apache/configuring.html.ja.jis
-share/doc/apache/content-negotiation.html
+share/doc/apache/content-negotiation.html.en
+share/doc/apache/content-negotiation.html.html
+share/doc/apache/content-negotiation.html.ja.jis
share/doc/apache/custom-error.html.en
share/doc/apache/custom-error.html.fr
share/doc/apache/custom-error.html.html
@@ -237,6 +239,7 @@ share/doc/apache/misc/windoz_keepalive.html
share/doc/apache/mod/core.html.en
share/doc/apache/mod/core.html.fr
share/doc/apache/mod/core.html.html
+share/doc/apache/mod/core.html.ja.jis
share/doc/apache/mod/directive-dict.html.en
share/doc/apache/mod/directive-dict.html.fr
share/doc/apache/mod/directive-dict.html.html
@@ -263,11 +266,13 @@ share/doc/apache/mod/mod_actions.html.en
share/doc/apache/mod/mod_actions.html.html
share/doc/apache/mod/mod_actions.html.ja.jis
share/doc/apache/mod/mod_alias.html.en
+share/doc/apache/mod/mod_alias.html.html
share/doc/apache/mod/mod_alias.html.ja.jis
share/doc/apache/mod/mod_asis.html.en
share/doc/apache/mod/mod_asis.html.html
share/doc/apache/mod/mod_asis.html.ja.jis
share/doc/apache/mod/mod_auth.html.en
+share/doc/apache/mod/mod_auth.html.html
share/doc/apache/mod/mod_auth.html.ja.jis
share/doc/apache/mod/mod_auth_anon.html
share/doc/apache/mod/mod_auth_db.html
@@ -299,7 +304,9 @@ share/doc/apache/mod/mod_info.html.ja.jis
share/doc/apache/mod/mod_isapi.html
share/doc/apache/mod/mod_log_agent.html
share/doc/apache/mod/mod_log_common.html
-share/doc/apache/mod/mod_log_config.html
+share/doc/apache/mod/mod_log_config.html.en
+share/doc/apache/mod/mod_log_config.html.html
+share/doc/apache/mod/mod_log_config.html.ja.jis
share/doc/apache/mod/mod_log_referer.html
share/doc/apache/mod/mod_mime.html.en
share/doc/apache/mod/mod_mime.html.html