aboutsummaryrefslogtreecommitdiff
path: root/www/apache13+ipv6
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2002-06-28 09:51:32 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2002-06-28 09:51:32 +0000
commit807943fa6d05c98793c9ab99886da0f869a5895e (patch)
treee6f00b439fd6e07f50c11997724e19df722ba0cb /www/apache13+ipv6
parent34822a889a63c0334312ca76c0a5bb4ab3c3eee9 (diff)
downloadports-807943fa6d05c98793c9ab99886da0f869a5895e.tar.gz
ports-807943fa6d05c98793c9ab99886da0f869a5895e.zip
Sync with www/apache13.
Notes
Notes: svn path=/head/; revision=62148
Diffstat (limited to 'www/apache13+ipv6')
-rw-r--r--www/apache13+ipv6/Makefile3
-rw-r--r--www/apache13+ipv6/files/patch-ab64
-rw-r--r--www/apache13+ipv6/pkg-plist96
3 files changed, 90 insertions, 73 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index cabe6a4cb92e..3b2dc943f590 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache+ipv6
PORTVERSION= 1.3.26
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.apache.org/dist/httpd/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/httpd/ \
@@ -116,7 +117,7 @@ pre-install:
PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
post-install:
- ${INSTALL_DATA} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh.default
+ ${INSTALL_DATA} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh-dist
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
${INSTALL_SCRIPT} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
diff --git a/www/apache13+ipv6/files/patch-ab b/www/apache13+ipv6/files/patch-ab
index a99bd7305990..567c58ca2e00 100644
--- a/www/apache13+ipv6/files/patch-ab
+++ b/www/apache13+ipv6/files/patch-ab
@@ -1,19 +1,19 @@
--- Makefile.tmpl.orig Thu Mar 14 00:05:27 2002
-+++ Makefile.tmpl Thu Jun 20 05:30:58 2002
++++ Makefile.tmpl Sat Jun 22 09:33:52 2002
@@ -270,10 +270,10 @@
$(MKDIR) $(root)$(mandir)/man1
$(MKDIR) $(root)$(mandir)/man8
$(MKDIR) $(root)$(sysconfdir)
- $(MKDIR) $(root)$(htdocsdir)
-+ $(MKDIR) $(root)$(htdocsdir).default
++ $(MKDIR) $(root)$(htdocsdir)-dist
$(MKDIR) $(root)$(manualdir)
$(MKDIR) $(root)$(iconsdir)
- $(MKDIR) $(root)$(cgidir)
-+ $(MKDIR) $(root)$(cgidir).default
++ $(MKDIR) $(root)$(cgidir)-dist
$(MKDIR) $(root)$(includedir)
$(MKDIR) $(root)$(includedir)/xml
$(MKDIR) $(root)$(runtimedir)
-@@ -459,33 +459,39 @@
+@@ -459,33 +459,29 @@
# icons and distributed CGI scripts.
install-data:
@echo "===> [data: Installing initial data files]"
@@ -21,54 +21,46 @@
- echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
- else \
- echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir)/"; \
-+# -@if [ -f $(root)$(htdocsdir)/index.html ] || [ -f $(root)$(htdocsdir)/index.html.en ]; then \
-+# echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
-+# else \
-+ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir).default/"; \
++ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir)-dist/"; \
(cd $(TOP)/htdocs/ && $(TAR) $(TAROPT) - index* apache_pb.* ) |\
- (cd $(root)$(htdocsdir)/ && $(TAR) -xf -); \
- find $(root)$(htdocsdir)/ -type d -exec chmod a+rx {} \; ; \
- find $(root)$(htdocsdir)/ -type f -print | xargs chmod a+r ; \
- fi
- -@if [ -d $(TOP)/htdocs/manual ]; then \
-+ (cd $(root)$(htdocsdir).default/ && $(TAR) -xf -); \
-+ find $(root)$(htdocsdir).default/ -type d -exec chmod a+rx {} \; ; \
-+ find $(root)$(htdocsdir).default/ -type f -print | xargs chmod a+r ; \
-+# fi
-+# -@if [ -d $(TOP)/htdocs/manual ]; then \
++ (cd $(root)$(htdocsdir)-dist/ && $(TAR) -xf -); \
++ find $(root)$(htdocsdir)-dist/ -type d -exec chmod a+rx {} \; ; \
++ find $(root)$(htdocsdir)-dist/ -type f -print | xargs chmod a+r ;
echo "Copying tree $(TOP)/htdocs/manual -> $(root)/$(manualdir)/"; \
(cd $(TOP)/htdocs/manual/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(manualdir)/ && $(TAR) -xf -); \
find $(root)$(manualdir)/ -type d -exec chmod a+rx {} \; ; \
- find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ; \
-+# fi
+- find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ; \
++ find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ;
+ if [ ! -d $(root)$(htdocsdir)/ ]; then \
-+ $(LN) -sf $(root)$(htdocsdir).default $(root)$(htdocsdir); \
++ $(LN) -sf $(root)$(htdocsdir)-dist $(root)$(htdocsdir); \
fi
- -@if [ -f $(root)$(cgidir)/printenv ]; then \
- echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
- else \
-+# -@if [ -f $(root)$(cgidir)/printenv ]; then \
-+# echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
-+# else \
for script in printenv test-cgi; do \
cat $(TOP)/cgi-bin/$${script} |\
sed -e 's;^#!/.*perl;#!$(PERL);' \
> $(TOP)/$(SRC)/.apaci.install.tmp; \
- echo "$(INSTALL_DATA) $(TOP)/conf/$${script}[*] $(root)$(cgidir)/$${script}"; \
- $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(cgidir)/$${script}; \
-+ echo "$(INSTALL_DATA) $(TOP)/conf/$${script}[*] $(root)$(cgidir).default/$${script}"; \
-+ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(cgidir).default/$${script}; \
- done; \
+- done; \
- fi
-+# fi
++ echo "$(INSTALL_DATA) $(TOP)/conf/$${script}[*] $(root)$(cgidir)-dist/$${script}"; \
++ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(cgidir)-dist/$${script}; \
++ done;
+ if [ ! -d $(root)$(cgidir)/ ]; then \
-+ $(LN) -sf $(root)$(cgidir).default $(root)$(cgidir); \
++ $(LN) -sf $(root)$(cgidir)-dist $(root)$(cgidir); \
+ fi
@echo "Copying tree $(TOP)/icons/ -> $(root)$(iconsdir)/"; \
(cd $(TOP)/icons/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(iconsdir)/ && $(TAR) -xf -); \
-@@ -524,10 +530,10 @@
+@@ -524,10 +520,10 @@
-e 's;logs/accept\.lock;$(runtimedir)/$(TARGET).lock;' \
-e 's;logs/apache_runtime_status;$(runtimedir)/$(TARGET).scoreboard;' \
-e 's;logs/httpd\.pid;$(runtimedir)/$(TARGET).pid;' \
@@ -83,3 +75,25 @@
-e 's;conf/magic;$(sysconfdir)/magic;' \
-e 's;conf/mime\.types;$(sysconfdir)/mime.types;' \
-e 's;User nobody;User $(conf_user);' \
+@@ -537,8 +533,8 @@
+ -e 's;ServerAdmin you@your.address;ServerAdmin $(conf_serveradmin);' \
+ -e 's;ServerName new.host.name;ServerName $(conf_servername);' \
+ > $(TOP)/$(SRC)/.apaci.install.tmp && \
+- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}.default"; \
+- $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}.default; \
++ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}-dist"; \
++ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}-dist; \
+ if [ ! -f "$(root)$(sysconfdir)/$${target_conf}" ]; then \
+ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}"; \
+ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}; \
+@@ -547,8 +543,8 @@
+ fi; \
+ done
+ -@for conf in mime.types magic; do \
+- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}.default"; \
+- $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}.default; \
++ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}-dist"; \
++ $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}-dist; \
+ if [ ! -f "$(root)$(sysconfdir)/$${conf}" ]; then \
+ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}"; \
+ $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}; \
diff --git a/www/apache13+ipv6/pkg-plist b/www/apache13+ipv6/pkg-plist
index d56b59851e34..eac68a8b40e6 100644
--- a/www/apache13+ipv6/pkg-plist
+++ b/www/apache13+ipv6/pkg-plist
@@ -1,25 +1,25 @@
-@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.14 2002-06-21 12:06:04 sumikawa Exp $
+@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.15 2002-06-28 09:51:31 sumikawa Exp $
bin/checkgid
bin/dbmmanage
bin/htdigest
bin/htpasswd
-@unexec if cmp -s %D/etc/apache/access.conf %D/etc/apache/access.conf.default; then rm -f %D/etc/apache/access.conf; fi
-etc/apache/access.conf.default
+@unexec if cmp -s %D/etc/apache/access.conf %D/etc/apache/access.conf-dist; then rm -f %D/etc/apache/access.conf; fi
+etc/apache/access.conf-dist
@exec [ -f %B/access.conf ] || cp %B/%f %B/access.conf
-@unexec if cmp -s %D/etc/apache/httpd.conf %D/etc/apache/httpd.conf.default; then rm -f %D/etc/apache/httpd.conf; fi
-etc/apache/httpd.conf.default
+@unexec if cmp -s %D/etc/apache/httpd.conf %D/etc/apache/httpd.conf-dist; then rm -f %D/etc/apache/httpd.conf; fi
+etc/apache/httpd.conf-dist
@exec [ -f %B/httpd.conf ] || cp %B/%f %B/httpd.conf
-@unexec if cmp -s %D/etc/apache/magic %D/etc/apache/magic.default; then rm -f %D/etc/apache/magic; fi
-etc/apache/magic.default
+@unexec if cmp -s %D/etc/apache/magic %D/etc/apache/magic-dist; then rm -f %D/etc/apache/magic; fi
+etc/apache/magic-dist
@exec [ -f %B/magic ] || cp %B/%f %B/magic
-@unexec if cmp -s %D/etc/apache/mime.types %D/etc/apache/mime.types.default; then rm -f %D/etc/apache/mime.types; fi
-etc/apache/mime.types.default
+@unexec if cmp -s %D/etc/apache/mime.types %D/etc/apache/mime.types-dist; then rm -f %D/etc/apache/mime.types; fi
+etc/apache/mime.types-dist
@exec [ -f %B/mime.types ] || cp %B/%f %B/mime.types
-@unexec if cmp -s %D/etc/apache/srm.conf %D/etc/apache/srm.conf.default; then rm -f %D/etc/apache/srm.conf; fi
-etc/apache/srm.conf.default
+@unexec if cmp -s %D/etc/apache/srm.conf %D/etc/apache/srm.conf-dist; then rm -f %D/etc/apache/srm.conf; fi
+etc/apache/srm.conf-dist
@exec [ -f %B/srm.conf ] || cp %B/%f %B/srm.conf
-@unexec if cmp -s %D/etc/rc.d/apache.sh %D/etc/rc.d/apache.sh.default; then rm -f %D/etc/rc.d/apache.sh; fi
-etc/rc.d/apache.sh.default
+@unexec if cmp -s %D/etc/rc.d/apache.sh %D/etc/rc.d/apache.sh-dist; then rm -f %D/etc/rc.d/apache.sh; fi
+etc/rc.d/apache.sh-dist
@exec [ -f %B/apache.sh ] || ( cp %B/%f %B/apache.sh; chmod 755 %B/apache.sh )
include/apache/ap.h
include/apache/ap_alloc.h
@@ -50,7 +50,9 @@ include/apache/multithread.h
include/apache/os-inline.c
include/apache/os.h
include/apache/rfc1413.h
+include/apache/sa_len.h
include/apache/scoreboard.h
+include/apache/sockaddr_storage.h
include/apache/util_date.h
include/apache/util_md5.h
include/apache/util_script.h
@@ -106,37 +108,37 @@ sbin/httpd
sbin/logresolve
sbin/rotatelogs
%%SUB_SUEXEC%%sbin/suexec
-www/data.default/apache_pb.gif
+www/data-dist/apache_pb.gif
@exec [ -d %D/www/data/ ] || ln -fs %B %D/www/data
-www/data.default/index.html.ca
-www/data.default/index.html.cz
-www/data.default/index.html.de
-www/data.default/index.html.dk
-www/data.default/index.html.ee
-www/data.default/index.html.el
-www/data.default/index.html.en
-www/data.default/index.html.es
-www/data.default/index.html.fr
-www/data.default/index.html.he.iso8859-8
-www/data.default/index.html.it
-www/data.default/index.html.ja.jis
-www/data.default/index.html.kr.iso-kr
-www/data.default/index.html.lb.utf8
-www/data.default/index.html.nl
-www/data.default/index.html.nn
-www/data.default/index.html.no
-www/data.default/index.html.po.iso-pl
-www/data.default/index.html.pt
-www/data.default/index.html.pt-br
-www/data.default/index.html.ru.cp-1251
-www/data.default/index.html.ru.cp866
-www/data.default/index.html.ru.iso-ru
-www/data.default/index.html.ru.koi8-r
-www/data.default/index.html.ru.ucs2
-www/data.default/index.html.ru.ucs4
-www/data.default/index.html.ru.utf8
-www/data.default/index.html.se
-www/data.default/index.html.zh
+www/data-dist/index.html.ca
+www/data-dist/index.html.cz
+www/data-dist/index.html.de
+www/data-dist/index.html.dk
+www/data-dist/index.html.ee
+www/data-dist/index.html.el
+www/data-dist/index.html.en
+www/data-dist/index.html.es
+www/data-dist/index.html.fr
+www/data-dist/index.html.he.iso8859-8
+www/data-dist/index.html.it
+www/data-dist/index.html.ja.jis
+www/data-dist/index.html.kr.iso-kr
+www/data-dist/index.html.lb.utf8
+www/data-dist/index.html.nl
+www/data-dist/index.html.nn
+www/data-dist/index.html.no
+www/data-dist/index.html.po.iso-pl
+www/data-dist/index.html.pt
+www/data-dist/index.html.pt-br
+www/data-dist/index.html.ru.cp-1251
+www/data-dist/index.html.ru.cp866
+www/data-dist/index.html.ru.iso-ru
+www/data-dist/index.html.ru.koi8-r
+www/data-dist/index.html.ru.ucs2
+www/data-dist/index.html.ru.ucs4
+www/data-dist/index.html.ru.utf8
+www/data-dist/index.html.se
+www/data-dist/index.html.zh
share/doc/apache/LICENSE
share/doc/apache/bind.html.en
share/doc/apache/bind.html.fr
@@ -412,9 +414,9 @@ share/doc/apache/win_service.html.html
share/doc/apache/win_service.html.ja.jis
share/doc/apache/windows.html.en
share/doc/apache/windows.html.ja.jis
-www/cgi-bin.default/printenv
+www/cgi-bin-dist/printenv
@exec [ -d %D/www/cgi-bin/ ] || ln -fs %B %D/www/cgi-bin
-www/cgi-bin.default/test-cgi
+www/cgi-bin-dist/test-cgi
www/icons/README
www/icons/a.gif
www/icons/a.png
@@ -648,8 +650,8 @@ www/icons/world2.png
@dirrm share/doc/apache/search
@dirrm share/doc/apache/vhosts
@dirrm share/doc/apache
-@dirrm www/data.default
-@dirrm www/cgi-bin.default
+@dirrm www/data-dist
+@dirrm www/cgi-bin-dist
@dirrm www/icons/small
@dirrm www/icons
@dirrm www/proxy