aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modssl/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-01-15 10:03:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-01-15 10:03:24 +0000
commit3f2a71d4bfb7b892e8fffa6c5967f486468020e8 (patch)
tree968c6da55bf75a1c8a3ccd0713795c4af1b70385 /www/apache13-modssl/Makefile
parentd7a44d9b2f148e5cd087253aff3c16b41b9d13eb (diff)
downloadports-3f2a71d4bfb7b892e8fffa6c5967f486468020e8.tar.gz
ports-3f2a71d4bfb7b892e8fffa6c5967f486468020e8.zip
- new option WITH_APACHE_LATESTLOG
that patches rotatelogs to always keep a hardlink to the latest log file, but without the seconds-since-epoch integer. Just as a convenience - when developing web apps, it makes it easier to just check the log file. Submitted by: Palle Girgensohn
Notes
Notes: svn path=/head/; revision=126492
Diffstat (limited to 'www/apache13-modssl/Makefile')
-rw-r--r--www/apache13-modssl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 7bd710c8f404..20681ab690cc 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -268,6 +268,10 @@ PLIST_FILES+= include/apache/sa_len.h \
include/apache/sockaddr_storage.h
.endif
+.if defined(WITH_APACHE_LATESTLOG)
+EXTRA_PATCHES+= ${FILESDIR}/rotatelogs.c.patch
+.endif
+
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
OPTIM='${OPTIM}' \
SSL_BASE='${OPENSSLBASE}' \
@@ -321,6 +325,7 @@ pre-fetch:
@${ECHO_MSG} " This setting may produce broken code and thus"
@${ECHO_MSG} " is not recommended for production servers."
@${ECHO_MSG} " [default is no]"
+ @${ECHO_MSG} " WITH_APACHE_LATESTLOG=yes keep a hardlink on the lastest log."
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_APACHE_IPV6=yes IPv6 support."
@${ECHO_MSG} " This setting turns IPv6 support on."