aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modssl/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-10-22 17:43:30 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-10-22 17:43:30 +0000
commit883e62364ca8cbec62b813d932517c2d7e3fa347 (patch)
treeb9d0f3b2435958d25203ab5bdfe0ee1e4e0abafb /www/apache13-modssl/Makefile
parent925425e291b53a0dac27ca62498e935ba4d1191a (diff)
downloadports-883e62364ca8cbec62b813d932517c2d7e3fa347.tar.gz
ports-883e62364ca8cbec62b813d932517c2d7e3fa347.zip
Sync with main Apache port
Notes
Notes: svn path=/head/; revision=49084
Diffstat (limited to 'www/apache13-modssl/Makefile')
-rw-r--r--www/apache13-modssl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index b992fe832fb1..f6c22df0e35e 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+mod_ssl
PORTVERSION= ${VERSION_APACHE}+${VERSION_MODSSL}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.apache.org/dist/httpd/ \
http://www.modssl.org/source/ \
@@ -54,7 +54,8 @@ VERSION_MODSSL= 2.8.5
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --server-gid=nogroup \
+ --server-uid=www \
+ --server-gid=www \
--with-perl=${PERL} \
--with-layout=${FILESDIR}/FreeBSD.layout:FreeBSD \
--suexec-docroot=${PREFIX}/www/data \
@@ -72,7 +73,7 @@ OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\" \
-DACCEPT_FILTER_NAME=\\"httpready\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
+.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == YES
OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
-fexpensive-optimizations -ffast-math
@@ -113,6 +114,9 @@ certificate:
&& ${ECHO_MSG} "===> Creating Test Certificate for Server" \
&& ${MAKE} certificate TYPE=${TYPE} CRT=${CRT} KEY=${KEY}
+pre-install:
+ PKG_PREFIX=${PREFIX} ./pkg-install ${PKGNAME} PRE-INSTALL
+
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \