aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-12-16 16:28:57 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-12-16 16:28:57 +0000
commitc3d954814a2fa2c55475ee57971bd812dce9f0e7 (patch)
treebcaff9781c0b52dc87b9745e3412aa02ccf47845 /www/apache13-modssl
parent6e54503ac840b95786cce0e162bd65727ea0754e (diff)
downloadports-c3d954814a2fa2c55475ee57971bd812dce9f0e7.tar.gz
ports-c3d954814a2fa2c55475ee57971bd812dce9f0e7.zip
- fix package when WITHOUT_RC_SUBR=YES
and old rc files are installed. Submitted by: Dave Ryan
Notes
Notes: svn path=/head/; revision=124219
Diffstat (limited to 'www/apache13-modssl')
-rw-r--r--www/apache13-modssl/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 85f7a7a3f121..7bd710c8f404 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -71,12 +71,14 @@ check-depends::
@${FALSE}
.endif
-.if exists(${PREFIX}/etc/rc.d/apache.sh)
-PLIST_FILES+= etc/rc.d/apache.sh.sample
+.if exists(${PREFIX}/etc/rc.d/apache.sh) || !defined(USE_RC_SUBR)
+APACHE_SH?= etc/rc.d/apache.sh.sample
.else
-PLIST_FILES+= etc/rc.d/apache.sh
+APACHE_SH?= etc/rc.d/apache.sh
.endif
+PLIST_FILES+= ${APACHE_SH}
+
.if defined(WITH_APACHE_SUEXEC) && ${WITH_APACHE_SUEXEC} == yes
APACHE_SUEXEC_CALLER?=www
@@ -390,9 +392,9 @@ pre-install:
post-install:
.if defined(USE_RC_SUBR)
- ${INSTALL_SCRIPT} ${WRKSRC}/rcng.sh ${PREFIX}/etc/rc.d/apache.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/rcng.sh ${PREFIX}/${APACHE_SH}
.else
- ${INSTALL_SCRIPT} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/apache.sh ${PREFIX}/${APACHE_SH}
.endif
.if defined(WITH_APACHE_MODSNMP) || defined(APACHE_WITH_MODSNMP)
@${MKDIR} ${DATADIR}/buckets