aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:06:32 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:06:32 +0000
commitd4b9b686e1c69125d0bc45f38a101896419380da (patch)
treeb54dfa28bebf093d2bdc6b9eeeff08ba9301aa48 /www/apache13-modssl
parent3f876547de717e125902ce4beffb069e6c200137 (diff)
downloadports-d4b9b686e1c69125d0bc45f38a101896419380da.tar.gz
ports-d4b9b686e1c69125d0bc45f38a101896419380da.zip
- Patch for keepalive-bug
PR: 71961 Submitted by: Kenneth Vestergaard Schmidt
Notes
Notes: svn path=/head/; revision=118762
Diffstat (limited to 'www/apache13-modssl')
-rw-r--r--www/apache13-modssl/Makefile1
-rw-r--r--www/apache13-modssl/files/patch-http_request.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index e69880dbb481..5f4fb8edc924 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache+mod_ssl
PORTVERSION= ${VERSION_APACHE}+${VERSION_MODSSL}
+PORTREVISION?= 1
CATEGORIES?= www security
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITES_MODSSL:S/$/:mod_ssl/} \
diff --git a/www/apache13-modssl/files/patch-http_request.c b/www/apache13-modssl/files/patch-http_request.c
new file mode 100644
index 000000000000..e4642e4f2d27
--- /dev/null
+++ b/www/apache13-modssl/files/patch-http_request.c
@@ -0,0 +1,11 @@
+--- src/main/http_request.c.bak Wed Apr 28 20:58:42 2004
++++ src/main/http_request.c Mon Jun 14 17:11:06 2004
+@@ -1056,7 +1056,7 @@
+ */
+ if ((r->status != HTTP_NOT_MODIFIED) && (r->status != HTTP_NO_CONTENT)
+ && !ap_status_drops_connection(r->status)
+- && r->connection && (r->connection->keepalive > 0)) {
++ && r->connection && (r->connection->keepalive != -1)) {
+
+ (void) ap_discard_request_body(r);
+ }