aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-ssl
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1996-08-11 14:50:01 +0000
committerMark Murray <markm@FreeBSD.org>1996-08-11 14:50:01 +0000
commit6d3a35ad639cf80a572a677ecd7c311d4eff87be (patch)
treee901fef7dd5e84dbb9dc684089cad6b581795224 /www/apache13-ssl
parent762edd202588ed8c199f45bad911bbea30c2d35b (diff)
downloadports-6d3a35ad639cf80a572a677ecd7c311d4eff87be.tar.gz
ports-6d3a35ad639cf80a572a677ecd7c311d4eff87be.zip
1) Add the ability to build a secure (SSL'ed) server, conditionalised
on the presence of SECURE_SERVER. 2) Clean up the installation in accordance with BSD religion: Now all the configs go in ${PREFIX}/etc/apache and the data (documents) stay in ${PREFIX}/www.
Notes
Notes: svn path=/head/; revision=3579
Diffstat (limited to 'www/apache13-ssl')
-rw-r--r--www/apache13-ssl/Makefile24
-rw-r--r--www/apache13-ssl/distinfo2
-rw-r--r--www/apache13-ssl/pkg-comment1
-rw-r--r--www/apache13-ssl/pkg-descr15
-rw-r--r--www/apache13-ssl/pkg-plist86
5 files changed, 126 insertions, 2 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index 78777d258b80..0bbf3dd5f6b1 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -1,9 +1,9 @@
-# New ports collection makefile for: apache HTTPD
+# New ports collection makefile for: apache HTTPD and HTTPSD
# Version required: 1.1.1
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.15 1996/07/12 06:41:05 pst Exp $
+# $Id: Makefile,v 1.16 1996/07/12 10:27:53 asami Exp $
#
DISTNAME= apache_1.1.1
@@ -13,6 +13,26 @@ MASTER_SITES= ftp://www.apache.org/apache/dist/
MAINTAINER= ache@freebsd.org
+.if defined(SECURE_SERVER)
+PKGNAME= apache_SSL-1.1.1
+MAIN_SRC= ${DISTNAME}${EXTRACT_SUFX}
+SSL_EXTRAS= ${DISTNAME}+1.3.ssl${EXTRACT_SUFX}
+DISTFILES= ${MAIN_SRC} ${SSL_EXTRAS}
+MASTER_SITES+= ftp://ftp.ox.ac.uk/pub/crypto/SSL/
+EXTRACT_ONLY= ${MAIN_SRC}
+MD5_FILE= ${FILESDIR}/md5.SSL
+PATCHDIR= ${.CURDIR}/patches.SSL
+PKGDIR= ${.CURDIR}/pkg.SSL
+CONFIGURE_SCRIPT= configure.SSL
+DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+
+post-extract:
+ @cd ${WRKSRC} && tar xzf ${DISTDIR}/${SSL_EXTRAS}
+
+pre-patch:
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < SSLpatch
+.endif
+
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
diff --git a/www/apache13-ssl/distinfo b/www/apache13-ssl/distinfo
new file mode 100644
index 000000000000..cac0b1f5916e
--- /dev/null
+++ b/www/apache13-ssl/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache_1.1.1.tar.gz) = 0dc9c3a3148d2acf419dd926018003c3
+MD5 (apache_1.1.1+1.3.ssl.tar.gz) = bef929679760796eb9955ed941ace370
diff --git a/www/apache13-ssl/pkg-comment b/www/apache13-ssl/pkg-comment
new file mode 100644
index 000000000000..0a8a9cf142af
--- /dev/null
+++ b/www/apache13-ssl/pkg-comment
@@ -0,0 +1 @@
+The extremely popular Apache http server. Very fast, very clean.
diff --git a/www/apache13-ssl/pkg-descr b/www/apache13-ssl/pkg-descr
new file mode 100644
index 000000000000..f08e87f934fa
--- /dev/null
+++ b/www/apache13-ssl/pkg-descr
@@ -0,0 +1,15 @@
+ Apache
+ Version 1.0 (and up)
+
+What is it?
+-----------
+
+Apache is an HTTP server designed as a plug-in replacement for the NCSA
+server version 1.3 (or 1.4). It fixes numerous bugs in the NCSA server and
+includes many frequently requested new features, and has an API which
+allows it to be extended to meet users' needs more easily.
+
+Documentation
+-------------
+
+All the documentation is on-line on the WWW, via the URL http://www.apache.org
diff --git a/www/apache13-ssl/pkg-plist b/www/apache13-ssl/pkg-plist
new file mode 100644
index 000000000000..0a00eaf51a6c
--- /dev/null
+++ b/www/apache13-ssl/pkg-plist
@@ -0,0 +1,86 @@
+etc/rc.d/apache.sh
+@exec mkdir %D/etc/apache/logs %D/www/cgi-bin %D/www/data
+@unexec rm %D/etc/rc.d/apache.sh
+etc/apache/conf/httpd.conf
+etc/apache/conf/httpd.conf-SSL
+etc/apache/conf/srm.conf
+etc/apache/conf/access.conf
+etc/apache/conf/mime.types
+etc/apache/conf/mime.types-SSL
+sbin/httpsd
+www/icons/README
+www/icons/a.gif
+www/icons/alert.black.gif
+www/icons/alert.red.gif
+www/icons/apache_pb.gif
+www/icons/back.gif
+www/icons/ball.gray.gif
+www/icons/ball.red.gif
+www/icons/binary.gif
+www/icons/binhex.gif
+www/icons/blank.gif
+www/icons/bomb.gif
+www/icons/box1.gif
+www/icons/box2.gif
+www/icons/broken.gif
+www/icons/burst.gif
+www/icons/c.gif
+www/icons/comp.blue.gif
+www/icons/comp.gray.gif
+www/icons/compressed.gif
+www/icons/continued.gif
+www/icons/dir.gif
+www/icons/down.gif
+www/icons/dvi.gif
+www/icons/f.gif
+www/icons/folder.gif
+www/icons/folder.open.gif
+www/icons/folder.sec.gif
+www/icons/forward.gif
+www/icons/generic.gif
+www/icons/generic.red.gif
+www/icons/generic.sec.gif
+www/icons/hand.right.gif
+www/icons/hand.up.gif
+www/icons/icon.sheet.gif
+www/icons/image1.gif
+www/icons/image2.gif
+www/icons/image3.gif
+www/icons/index.gif
+www/icons/layout.gif
+www/icons/left.gif
+www/icons/link.gif
+www/icons/movie.gif
+www/icons/p.gif
+www/icons/patch.gif
+www/icons/pdf.gif
+www/icons/pie0.gif
+www/icons/pie1.gif
+www/icons/pie2.gif
+www/icons/pie3.gif
+www/icons/pie4.gif
+www/icons/pie5.gif
+www/icons/pie6.gif
+www/icons/pie7.gif
+www/icons/pie8.gif
+www/icons/portal.gif
+www/icons/ps.gif
+www/icons/quill.gif
+www/icons/right.gif
+www/icons/screw1.gif
+www/icons/screw2.gif
+www/icons/script.gif
+www/icons/sound1.gif
+www/icons/sound2.gif
+www/icons/sphere1.gif
+www/icons/sphere2.gif
+www/icons/tar.gif
+www/icons/tex.gif
+www/icons/text.gif
+www/icons/transfer.gif
+www/icons/unknown.gif
+www/icons/up.gif
+www/icons/uu.gif
+www/icons/uuencoded.gif
+www/icons/world1.gif
+www/icons/world2.gif