aboutsummaryrefslogtreecommitdiff
path: root/www/apache13/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-10-21 17:33:37 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-10-21 17:33:37 +0000
commiteac6cc1767fb60e30ff96ff26156b8e16346b903 (patch)
treeeeb079098de7731570044e2742295c983139c391 /www/apache13/Makefile
parentd473fdb9f31038830429266be181a0c4ddeea79a (diff)
downloadports-eac6cc1767fb60e30ff96ff26156b8e16346b903.tar.gz
ports-eac6cc1767fb60e30ff96ff26156b8e16346b903.zip
Switch to www:www
Notes
Notes: svn path=/head/; revision=49028
Diffstat (limited to 'www/apache13/Makefile')
-rw-r--r--www/apache13/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index f2f099872871..ef352b6bbdef 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache
PORTVERSION= 1.3.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/httpd/ \
@@ -31,14 +31,11 @@ DISTNAME= apache_${PORTVERSION}
MAINTAINER= ache@freebsd.org
-#
-# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
-#
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
- --server-gid=nogroup \
+ --server-uid=www \
+ --server-gid=www \
--with-perl=${PERL} \
--with-layout=${FILESDIR}/FreeBSD.layout:FreeBSD \
--suexec-docroot=${PREFIX}/www/data \
@@ -54,7 +51,10 @@ OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\" \
-DACCEPT_FILTER_NAME=\\"httpready\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
+#
+# Set WITH_APACHE_PERF_TUNING env. variable to YES to get maximum performance
+#
+.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == YES
OPTIM+= -DBUFFERED_LOGS
CFLAGS+= -O6 -fomit-frame-pointer
.endif
@@ -64,6 +64,9 @@ CONFIGURE_ENV= OPTIM='${OPTIM}'
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8
+pre-install:
+ PKG_PREFIX=${PREFIX} ./pkg-install ${PKGNAME} PRE-INSTALL
+
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \