aboutsummaryrefslogtreecommitdiff
path: root/www/apache2/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-07-01 05:54:56 +0000
committerClement Laforet <clement@FreeBSD.org>2004-07-01 05:54:56 +0000
commitd84ad3cbde7e7df0aa59ac575926488dcdcf50af (patch)
tree64268d5a10cc324a1b9b30e99c5169c724b887f2 /www/apache2/Makefile
parent8f484b7d54fb8b4ffb5c025643dacb47b381a9c7 (diff)
downloadports-d84ad3cbde7e7df0aa59ac575926488dcdcf50af.tar.gz
ports-d84ad3cbde7e7df0aa59ac575926488dcdcf50af.zip
- Update to 2.0.50
Important changes: *) SECURITY: CAN-2004-0493 (cve.mitre.org) Close a denial of service vulnerability identified by Georgi Guninski which could lead to memory exhaustion with certain input data. [Jeff Trawick] *) SECURITY: CAN-2004-0488 (cve.mitre.org) mod_ssl: Fix a buffer overflow in the FakeBasicAuth code for a (trusted) client certificate subject DN which exceeds 6K in length. [Joe Orton] Details can be found here: http://www.apache.org/dist/httpd/CHANGES_2.0 - Use autoconf 2.59 - Add add SUEXEC_LOGFILE tunable to set suexec logfile [1] - Silently ignore removal of libexec/apache2 directory - Import latest version of apr_reslit.c from apr CVS which adds timeout feature to apr_reslist_acquire(). This is required for future mod_logio-st. - Add explicit dependency on libiconv (so nowwe support libiconv) - Move Windows Update fix from MASTER_SITE_LOCAL to ports tree - add WITH_EXPERIMENTAL_PATCHES knobs: These patches are backports from apache CVS HEAD or apr CVS HEAD. They have positive impacts on apache responsiveness but can be instable and are NOT currently supported by apache/apr teams. * exp-http-ready.patch: add "httpready" support for ACCEPT_FILTER (currently apache 2 only support "dataready") * exp-apr-kqueue.patch: add support for kqueue in apr_poll(). This patch greatly improves apache network performance (up to 18% according to the author, on my test box, between 13% and 21%) Test and feedback on -STABLE are welcome ;) For more details, please see: http://marc.theaimsgroup.com/?t=108650227500001&r=1&w=2 Submitted by: knu [1] NOTE: Please set MASTER_SITE_APACHE_HTTPD to closest mirrors. you can easily find them from: http://www.apache.org/dyn/closer.cgi/httpd/ Thanks :
Notes
Notes: svn path=/head/; revision=112641
Diffstat (limited to 'www/apache2/Makefile')
-rw-r--r--www/apache2/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index f9a76626224a..bc49c1096203 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= apache
-PORTVERSION= 2.0.49
-PORTREVISION= 3
+PORTVERSION= 2.0.50
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
@@ -33,10 +32,12 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
ru-apache+mod_ssl-1.* ru-apache-1.* thttpd-2.*
# patch files
-PATCH_SITES+= ${MASTER_SITE_LOCAL:S/$/:clement/}
-PATCH_SITE_SUBDIR= clement/:clement
.if defined (WITH_WINDOWSUPDATEFIX)
-PATCHFILES+= httpd-${PORTVERSION}-windowsupdate.patch:clement
+EXTRA_PATCHES+= ${FILESDIR}/exp-windowsupdate.patch
+.endif
+.if defined(WITH_EXPERIMENTAL_PATCHES)
+EXTRA_PATCHES+= ${FILESDIR}/exp-apr-kqueue.patch \
+ ${FILESDIR}/exp-http-ready.patch
.endif
SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
@@ -44,7 +45,8 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
-USE_AUTOCONF_VER= 257
+USE_ICONV= yes
+USE_AUTOCONF_VER= 259
USE_LIBTOOL_VER= 15
USE_PERL5= yes
USE_RC_SUBR= yes
@@ -56,6 +58,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--with-perl=${PERL5} \
--with-port=${WITH_HTTP_PORT} \
--with-expat=${LOCALBASE} \
+ --with-iconv=${LOCALBASE} \
--libdir=${PREFIX_RELDEST}/lib/apache2 \
--includedir=${PREFIX_RELDEST}/include/apache2
@@ -69,7 +72,7 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAKE_ENV+= DESTDIR=${DESTDIR} EXPR_COMPAT=yes
-WITH_MPM?= prefork # or worker, perchild
+WITH_MPM?= prefork # or worker, perchild, threadpool
WITH_HTTP_PORT?= 80