aboutsummaryrefslogtreecommitdiff
path: root/www/apache20
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-12-03 23:04:21 +0000
committerClement Laforet <clement@FreeBSD.org>2005-12-03 23:04:21 +0000
commit54b5eedff9ebe60138c1eeebbc11d3a96c9af5c0 (patch)
tree190adf7e3d222ca97150d9411bbba792cbc6adf9 /www/apache20
parent38b905579167f607a837d2a81352ced36430b67b (diff)
downloadports-54b5eedff9ebe60138c1eeebbc11d3a96c9af5c0.tar.gz
ports-54b5eedff9ebe60138c1eeebbc11d3a96c9af5c0.zip
- resync' with www/apache2
Notes
Notes: svn path=/head/; revision=150324
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile1
-rw-r--r--www/apache20/Makefile.modules.3rd19
-rw-r--r--www/apache20/files/apache.sh2
3 files changed, 17 insertions, 5 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index c49f1f096892..c1a90522f89c 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -34,6 +34,7 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
# patch files
EXTRA_PATCHES+= ${FILESDIR}/build-fix-openssl_beta
+
.if defined (WITH_WINDOWSUPDATEFIX)
EXTRA_PATCHES+= ${FILESDIR}/exp-windowsupdate.patch
.endif
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index 6305ceffd39c..48a9aa53b1d4 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -33,7 +33,7 @@ IGNORE= "This module require apache2 and you have apache13 installed"
. endif
. endif
. ifdef(WITH_APACHE2)
-.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but apache13 is installed Please undefine and try again.
+IGNORE= You have 'WITH_APACHE2' variable defined either in environment or in make(1) arguments. but apache13 is installed Please undefine and try again.
. endif
.endif
@@ -158,6 +158,17 @@ CONFIGURE_ARGS+= --disable-access --disable-auth \
--disable-asis --disable-cgid --disable-cgi \
--disable-negotiation --disable-dir --disable-imap \
--disable-actions --disable-userdir --disable-alias
+.elif ${WANT_APACHE} == common21
+CONFIGURE_ARGS+= --disable-authn-file --disable-authn-default \
+ --disable-authz-host --disable-authz-groupfile \
+ --disable-authz-user --disable-authz-default \
+ --disable-auth-basic --disable-charset-lite \
+ --disable-include --disable-log-config --disable-env \
+ --disable-setenvif --disable-mime --disable-status \
+ --disable-autoindex --disable-asis --disable-cgid \
+ --disable-cgi --disable-negotiation --disable-dir \
+ --disable-imagemap --disable-actions --disable-userdir \
+ --disable-alias
.endif
.if defined(WITH_MODULES)
@@ -182,13 +193,13 @@ _APACHE_MODULES+= ${WITH_EXTRA_MODULES}
.if !defined(WITH_STATIC_APACHE)
-. if ${WANT_APACHE} == common2
+. if ${WANT_APACHE} == common2 || ${WANT_APACHE} == common21
# FYI
#DYNAMIC_MODULES= so
CONFIGURE_ARGS+= --enable-so
. endif
.else
-. if ${WANT_APACHE} == common2
+. if ${WANT_APACHE} == common2 || ${WANT_APACHE} == common21
CONFIGURE_ARGS+= --disable-so
. endif
WITH_ALL_STATIC_MODULES= YES
@@ -198,7 +209,7 @@ WITH_ALL_STATIC_MODULES= YES
.if ${WANT_APACHE} == common13
SUEXEC_CONFARGS= suexec
CONFIGURE_ARGS+= --enable-suexec
-.elif ${WANT_APACHE} == common2
+.elif ${WANT_APACHE} == common2 || ${WANT_APACHE} == common21
SUEXEC_CONFARGS= with-suexec
.else
IGNORE= Can not determine apache version
diff --git a/www/apache20/files/apache.sh b/www/apache20/files/apache.sh
index 4afaeb55890b..5d6dc0db2e17 100644
--- a/www/apache20/files/apache.sh
+++ b/www/apache20/files/apache.sh
@@ -93,7 +93,7 @@ checkyesno apache2ssl_enable && \
apache2_checkconfig()
{
echo "Performing sanity check on apache2 configuration:"
- ${command} ${apache2_flags} -t
+ eval "${command} ${apache2_flags} -t"
}
apache2_precmd()