aboutsummaryrefslogtreecommitdiff
path: root/www/apache20
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1996-11-07 01:49:57 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1996-11-07 01:49:57 +0000
commit866036dc8085557514d394ec9ac7dbd17e478592 (patch)
treee0d28dd7622fe59b8a485c43f9894db7436e7b8c /www/apache20
parent0063086e56e1ef90d4c1c6315c7e3f619d094950 (diff)
downloadports-866036dc8085557514d394ec9ac7dbd17e478592.tar.gz
ports-866036dc8085557514d394ec9ac7dbd17e478592.zip
Conditionalize all my patches
Notes
Notes: svn path=/head/; revision=4326
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile35
-rw-r--r--www/apache20/distinfo2
-rw-r--r--www/apache20/files/patch-ag127
3 files changed, 36 insertions, 128 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index a92c153898a7..6b911bf6d6c1 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.18 1996/10/26 18:49:52 markm Exp $
+# $Id: Makefile,v 1.19 1996/10/31 17:42:13 markm Exp $
#
DISTNAME= apache_1.1.1
@@ -13,6 +13,39 @@ MASTER_SITES= ftp://www.apache.org/apache/dist/
MAINTAINER= ache@freebsd.org
+# User-controlled variables list
+# CHARSET_ACHE - add charset negotiation to .var files and charset guessing
+# DIR_ACHE - add SuppressHTMLPreamble option to directory index
+# ALL_ACHE - both patches from above
+# SECURE_SERVER - build Apache with SSL
+
+.if defined(ALL_ACHE)
+CHARSET_ACHE=YES
+DIR_ACHE=YES
+.endif
+.if defined(CHARSET_ACHE) || defined(DIR_ACHE)
+PATCH_SITES+= http://www.nagual.ru/~ache/
+.endif
+.if defined(CHARSET_ACHE)
+PATCHFILES+= mod.patch
+VERS_ID1= charset/
+.endif
+.if defined(DIR_ACHE)
+PATCHFILES+= dir.patch
+VERS_ID2= dir/
+.endif
+.if defined(VERS_ID1) || defined(VERS_ID2)
+VERS_ID= ${VERS_ID1}${VERS_ID2}ache
+.endif
+
+.if defined(VERS_ID)
+post-patch:
+ @cd ${WRKSRC}/src; \
+ mv httpd.h httpd.h.old; \
+ sed 's=SERVER_VERSION *"\(.*\)"=SERVER_VERSION "\1 '"${VERS_ID}"'"=' \
+ < httpd.h.old > httpd.h
+.endif
+
.if defined(SECURE_SERVER)
PKGNAME= apache_SSL-1.1.1
diff --git a/www/apache20/distinfo b/www/apache20/distinfo
index 1426022ab32e..514ab3bc56da 100644
--- a/www/apache20/distinfo
+++ b/www/apache20/distinfo
@@ -1 +1,3 @@
MD5 (apache_1.1.1.tar.gz) = 0dc9c3a3148d2acf419dd926018003c3
+MD5 (mod.patch) = ae4c7ec8520bd384f7552f4dd5f4151e
+MD5 (dir.patch) = d840a0a1b484a1820e246ed1effcf561
diff --git a/www/apache20/files/patch-ag b/www/apache20/files/patch-ag
deleted file mode 100644
index 48d05fff51c2..000000000000
--- a/www/apache20/files/patch-ag
+++ /dev/null
@@ -1,127 +0,0 @@
-*** src/mod_dir.c.orig Sat Jun 22 00:12:07 1996
---- src/mod_dir.c Sun Nov 3 08:33:16 1996
-***************
-*** 83,88 ****
---- 83,89 ----
- #define SUPPRESS_LAST_MOD 8
- #define SUPPRESS_SIZE 16
- #define SUPPRESS_DESC 32
-+ #define SUPPRESS_HTML_PREAMBLE 64
-
- struct item {
- char *type;
-***************
-*** 205,210 ****
---- 206,213 ----
- opts |= SUPPRESS_SIZE;
- else if(!strcasecmp(w,"SuppressDescription"))
- opts |= SUPPRESS_DESC;
-+ else if(!strcasecmp(w,"SuppressHTMLPreamble"))
-+ opts |= SUPPRESS_HTML_PREAMBLE;
- else if(!strcasecmp(w,"None"))
- opts = 0;
- else
-***************
-*** 404,411 ****
- * Actually generating output
- */
-
-
-! int insert_readme(char *name, char *readme_fname, int rule, request_rec *r) {
- char *fn;
- FILE *f;
- struct stat finfo;
---- 407,421 ----
- * Actually generating output
- */
-
-+ void put_html_preamble(char *title_name, request_rec *r)
-+ {
-+ rvputs(r, "<HEAD><TITLE>Index of ", title_name,
-+ "</TITLE></HEAD><BODY>\n", NULL);
-+ }
-
-! int insert_readme(char *name, char *readme_fname, int rule,
-! char *title_name, request_rec *r)
-! {
- char *fn;
- FILE *f;
- struct stat finfo;
-***************
-*** 419,430 ****
- if(stat(fn,&finfo) == -1)
- return 0;
- plaintext=1;
-- if(rule) rputs("<HR>\n", r);
-- rputs("<PRE>\n", r);
- }
-- else if (rule) rputs("<HR>\n", r);
- if(!(f = pfopen(r->pool,fn,"r")))
- return 0;
- if (!plaintext)
- send_fd(f, r);
- else
---- 429,442 ----
- if(stat(fn,&finfo) == -1)
- return 0;
- plaintext=1;
- }
- if(!(f = pfopen(r->pool,fn,"r")))
- return 0;
-+ if(!rule && plaintext && title_name != NULL)
-+ put_html_preamble(title_name, r);
-+ if(rule) rputs("<HR>\n", r);
-+ if(plaintext) rputs("<PRE>\n", r);
-+
- if (!plaintext)
- send_fd(f, r);
- else
-***************
-*** 714,724 ****
- while (title_endp > title_name && *title_endp == '/')
- *title_endp-- = '\0';
-
-! rvputs(r, "<HEAD><TITLE>Index of ", title_name, "</TITLE></HEAD><BODY>\n",
-! NULL);
-
-! if((!(tmp = find_header(dir_conf,r))) || (!(insert_readme(name,tmp,0,r))))
- rvputs(r, "<H1>Index of ", title_name, "</H1>\n", NULL);
-
- /*
- * Since we don't know how many dir. entries there are, put them into a
---- 726,743 ----
- while (title_endp > title_name && *title_endp == '/')
- *title_endp-- = '\0';
-
-! if(!(dir_opts & SUPPRESS_HTML_PREAMBLE))
-! put_html_preamble(title_name, r);
-
-! if((!(tmp = find_header(dir_conf,r))) ||
-! (!(insert_readme(name, tmp, 0,
-! ((dir_opts & SUPPRESS_HTML_PREAMBLE) ?
-! title_name : NULL), r))))
-! {
-! if(dir_opts & SUPPRESS_HTML_PREAMBLE)
-! put_html_preamble(title_name, r);
- rvputs(r, "<H1>Index of ", title_name, "</H1>\n", NULL);
-+ }
-
- /*
- * Since we don't know how many dir. entries there are, put them into a
-***************
-*** 751,757 ****
-
- if (dir_opts & FANCY_INDEXING)
- if((tmp = find_readme(dir_conf, r)))
-! insert_readme(name,tmp,1,r);
- else {
- rputs("</UL>", r);
- }
---- 770,776 ----
-
- if (dir_opts & FANCY_INDEXING)
- if((tmp = find_readme(dir_conf, r)))
-! insert_readme(name,tmp,1,NULL,r);
- else {
- rputs("</UL>", r);
- }